Bug 195440 - vfat corruption
vfat corruption
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
NeedsRetesting
:
: 195439 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 04:11 EDT by barry gould
Modified: 2008-03-12 15:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 01:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description barry gould 2006-06-15 04:11:48 EDT
Description of problem:
A VFAT partition which is mounted frequently gets corrupted after adding,
changing, or deleting files.

Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2122_FC5
and earlier, but not in FC4 AFAIK

How reproducible:
fairly

Steps to Reproduce:
1. copy, change, and/or delete files on a mounted vfat partition
2. run fsck or windows chkdsk to check for corruption.
  
Actual results:
fsck or chkdsk reports fs damage

the most common result is that deleted files end up as 'lost chains' according
to XP chkdsk,
however, I have had data loss on files edited by emacs, etc.

Expected results:


Additional info:
this is on a Dell D800 notebook, Pentium M, 1GB RAM, 100GB Seagate notebook HD.
note I have no swapfile or swap partition, period.

I have tried re-creating and re-formatting the partition; it hasn't made a
difference.

I am not having any problems with lockups or crashes.

I have not seen any problems with my ext3 partition, or my NTFS partition
(dual-boot winXP)
Note that the corruption happens even if I never boot XP.

Also note that deleting files from XP on the vfat partition works fine. Also, XP
chkdsk always fixes the problem (but data loss still occurs on the corrupted
files). I have not tried letting fsck fix the partition.
After fixing with chkdsk, both chkdsk and fsck say the partition is fine.


$ sudo fdisk -l /dev/hda

Disk /dev/hda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1        1460    11727418+  83  Linux
/dev/hda2   *        1462        2920    11719417+   7  HPFS/NTFS
/dev/hda3            2921       12161    74228332+   f  W95 Ext'd (LBA)
/dev/hda4            1461        1461        8032+  83  Linux
/dev/hda5            2921       12161    74228301    b  W95 FAT32

Partition table entries are not in disk order


$ mount
/dev/hda1 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
/dev/hda5 on /mnt/fatdata type vfat (rw,umask=0000)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)


Please let me know if additional information is needed.

Thanks!
Comment 1 barry gould 2006-06-15 12:51:50 EDT
*** Bug 195439 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2006-10-16 13:56:54 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 3 petrosyan 2008-03-12 01:59:06 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.
Comment 4 barry gould 2008-03-12 15:01:24 EDT
I'm using Fedora 8 now, and haven't had the problem anymore.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.