Bug 195441 - [FC5] cannot activate scim setup on Western desktop
[FC5] cannot activate scim setup on Western desktop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 195442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 04:20 EDT by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-15 04:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jong Bae KO 2006-06-15 04:20:17 EDT
Description of problem:
It seems that the version currently in updates-testing (scim-1.4.4-9.3.fc5) does
not allow activating scim inputs on anything other than pre-defined CJK locales
(e.g. zh_CN.UTF-8). I have not been successful in triggering the layout under
en_CA.UTF-8, even though it worked before the update, and I have the necessary
symlink in ~/.xinput.d/default->/etc/X11/xinit/xinput.d/scim (also tried
creating ~/.xinput.d/en_CA with no results).


Version-Release number of selected component (if applicable):
scim-1.4.4-9.3.fc5

How reproducible:
always

Steps to Reproduce:
1. Configure scim under en_US or en_CA locales (e.g. by running im-switch -s scim).
2. Try to switch to any SCIM locale by either key combos, or by left-clicking on
the notification area applet. SCIM shows no signs of life.
3. This only works if an application is started in, say, zh_CN.UTF-8 locale --
then SCIM works as expected.

Additional info:
I have reproduced this problem on 2 different machines, plus at least one other
person is seeing the same behaviour
(http://mricon.livejournal.com/329742.html?thread=544270#t544270).
Comment 1 Jong Bae KO 2006-06-15 04:46:00 EDT
*** Bug 195442 has been marked as a duplicate of this bug. ***
Comment 2 Jong Bae KO 2006-06-15 04:49:13 EDT
------- Additional Comments From petersen@redhat.com  2006-06-13 04:13 EST -------
Hmm strange, works ok for me.  And you have xorg-x11-xinit-1.0.1-2, right?
Comment 3 Jong Bae KO 2006-06-15 05:01:31 EDT
------- Additional Comments From petersen@redhat.com  2006-06-13 07:48 EST -------
Do you see any yum upgrade log errors.  I found a %post error:
it seems the scim libraries and gtimm module were not linked against
libstdc++so7 even though they were compiled with it.

Unfortunately this time I mainly just tested upgrading the main package not
scim-libs since the only change packaging change was scim obsoleting
scim-qtimm, and worse the package was just pushed to final. :-(
Comment 4 Jong Bae KO 2006-06-15 05:02:07 EDT
------- Additional Comments From petersen@redhat.com  2006-06-13 07:52 EST -------
Ok, thanks for the report: I think this is because I forgot to
update the libtool tweaking for libstdc++so7 for gcc-4.1.1,
which broken libtool linking of the .so files unfortunately.

Note You need to log in before you can comment on or make changes to this bug.