Bug 195445 - scim-libs: Cannot load module /usr/lib64/gtk-2.0/immodules/im-scim.so: /usr/lib64/libscim-x11utils-1.0.so.8: undefined symbol:_ZNSt11_7_200604288ios_base4InitC1Ev
scim-libs: Cannot load module /usr/lib64/gtk-2.0/immodules/im-scim.so: /usr/l...
Status: CLOSED DUPLICATE of bug 194561
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Depends On:
  Show dependency treegraph
Reported: 2006-06-15 04:57 EDT by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-05 06:49:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jong Bae KO 2006-06-15 04:57:12 EDT
Description of problem:
When updating to scim-libs-1.4.4-9.3.fc5, the RPM post scriptlet fails with:

Cannot load module /usr/lib64/gtk-2.0/immodules/im-scim.so:
/usr/lib64/libscim-x11utils-1.0.so.8: undefined symbol:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. rpm -e scim-libs
2. rpm -i fedora/core/updates/5/x86_64/scim-libs-1.4.4-9.3.fc5.x86_64.rpm

Actual results:
Cannot load module /usr/lib64/gtk-2.0/immodules/im-scim.so:
/usr/lib64/libscim-x11utils-1.0.so.8: undefined symbol:
/usr/lib64/gtk-2.0/immodules/im-scim.so does not export GTK+ IM module API:
/usr/lib64/libscim-x11utils-1.0.so.8: undefined symbol:

Expected results:
update-gtk-immodules to succeed.

Additional info:
Passing the missing symbol "_ZNSt11_7_200604288ios_base4InitC1Ev" through
c++filt, I get "std::_7_20060428::ios_base::Init::Init()", which presumably is
provided by libstd++.so.7.

The last working version is "scim-libs-1.4.4-9.2.fc5.x86_64"
Comparing the contents, I see that it links against libstdc++.so.7:
 ldd scim-libs-1.4.4-9.2.fc5/usr/lib64/libscim-x11utils-1.0.so.8 | grep stdc++
        libstdc++-20060428.so.7 => /usr/lib64/libstdc++-20060428.so.7

While "1.4.4-9.3" links with libstdc++.so.6:
ldd scim-libs-1.4.4-9.3.fc5/usr/lib64/libscim-x11utils-1.0.so.8 | grep stdc++
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002aaaaacd7000)

I'm personally curious as to why you guys decided to link with libstdc++.so.7 in
the first place.
Comment 1 Jong Bae KO 2006-06-15 05:09:07 EDT
------- Additional Comments From mtasaka@ioa.s.u-tokyo.ac.jp  2006-06-13 08:49
EST -------
Perhaps can be marked as a duplicate of 194953.
Comment 2 Mamoru TASAKA 2006-06-15 05:14:07 EDT
Already fixed by the bug 194561 . 
Comment 3 Jens Petersen 2006-07-05 06:49:09 EDT

*** This bug has been marked as a duplicate of 194561 ***

Note You need to log in before you can comment on or make changes to this bug.