Bug 195465 - [RFE] UI: "Select All" and "Deselect All" are needed
[RFE] UI: "Select All" and "Deselect All" are needed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 209340 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 08:49 EDT by Masaki Katakai
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 14:01:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Masaki Katakai 2006-06-15 08:49:24 EDT
Description of problem:

 This is an request for UI improvement. Currently there is no
 button for "Select All" and "Deslect All" buttons at selecting
 packages for update. I saw many packages that need to be
 updated but I wanted to select just one. However, I could not
 find easy way to do it. I had to un-select all packages, then
 selected just one package.

Version-Release number of selected component (if applicable):

 FC5

How reproducible:


Steps to Reproduce:
1. Run software updater
2. after checking, many rpms are listed and selected (checkbox is selcted)
3. 
  
Actual results:

I wanted to select just one rpm, how to do it?
Do I need to unselect all rpms except desire one?

Expected results:

Please provide "Select All" and "Deselect All" buttons

Additional info:
Comment 1 John Thacker 2006-10-29 08:30:21 EST
These are all bugs in pirut/pup, not up2date.  Pirut replaced up2date in FC5 and
forward.  Reassigning component.
Comment 2 Jeremy Katz 2006-11-06 14:01:19 EST
Implemented right click select/unselect for pirut-1.2.7
Comment 3 Jeremy Katz 2006-11-06 15:18:48 EST
*** Bug 209340 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2006-11-06 15:37:04 EST
pirut-1.2.7-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Masaki Katakai 2006-11-06 23:35:24 EST
Thank you very much for fixing this. Sure, I'll try this when I have time.
Comment 6 Fedora Update System 2006-11-10 13:19:40 EST
pirut-1.2.8-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Fedora Update System 2006-11-16 18:11:46 EST
pirut-1.2.8-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Masaki Katakai 2006-11-21 08:46:33 EST
I have verified this on fc6. Great! Thanks!

Note You need to log in before you can comment on or make changes to this bug.