Bug 1954733 - Errors using dnf system-upgrade download --refresh --releasever=34
Summary: Errors using dnf system-upgrade download --refresh --releasever=34
Keywords:
Status: CLOSED DUPLICATE of bug 1956631
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 33
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-28 17:29 UTC by Steve
Modified: 2021-05-04 06:27 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-04 06:27:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Steve 2021-04-28 17:29:02 UTC
Description of problem: 
dnf system-upgrade download --refresh --releasever=34 gives errors, see below
[root@localhost stephenmauersberg]# dnf system-upgrade download --refresh --releasever=34
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Copr repo for fedy owned by kwizart                                                                 18 kB/s | 3.3 kB     00:00    
Fedora 34 openh264 (From Cisco) - x86_64                                                           822  B/s | 271  B     00:00    
Errors during downloading metadata for repository 'fedora-cisco-openh264':
  - Status code: 404 for https://codecs.fedoraproject.org/openh264/34/x86_64/repodata/repomd.xml (IP: 8.43.85.67)
Error: Failed to download metadata for repo 'fedora-cisco-openh264': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Fedora Modular 34 - x86_64                                                                          54 kB/s |  10 kB     00:00    
Fedora Modular 34 - x86_64 - Updates                                                                65 kB/s |  11 kB     00:00    
Fedora 34 - x86_64 - Updates                                                                        34 kB/s | 4.6 kB     00:00    
Fedora 34 - x86_64                                                                                  65 kB/s |  10 kB     00:00    
google-chrome                                                                                       10 kB/s | 1.3 kB     00:00    
packages-microsoft-com-prod                                                                        7.9 kB/s | 3.0 kB     00:00    
MySQL 8.0 Community Server                                                                         7.6 kB/s | 2.6 kB     00:00    
MySQL Connectors Community                                                                         8.3 kB/s | 2.6 kB     00:00    
MySQL Tools Community                                                                               17 kB/s | 2.6 kB     00:00    
Opera packages                                                                                     5.7 kB/s | 2.9 kB     00:00    
RPM Fusion for Fedora 34 - Free - Updates                                                          4.9 kB/s | 2.4 kB     00:00    
RPM Fusion for Fedora 34 - Free                                                                     56 kB/s |  11 kB     00:00    
skype (stable)                                                                                     6.3 kB/s | 2.9 kB     00:00    
TeamViewer - x86_64                                                                                1.8 kB/s | 867  B     00:00    
WineHQ packages                                                                                     14 kB/s | 3.3 kB     00:00    
Ignoring repositories: fedora-cisco-openh264
No match for group package "intel-media-driver"
No match for group package "k3b-extras-freeworld"
No match for group package "xorg-x11-drv-armsoc"
No match for group package "oflb-brett-fonts"
No match for group package "paratype-pt-sans-caption-fonts"
No match for group package "aldusleaf-crimson-text-fonts"
No match for group package "tlomt-orbitron-fonts"
No match for group package "almas-mongolian-title-fonts"
No match for group package "vdr-skinsoppalusikka"
No match for group package "specialelite-fonts"
No match for group package "phetsarath-fonts"
No match for group package "powerpc-utils"
No match for group package "ht-alegreya-smallcaps-fonts"
No match for group package "senamirmir-washra-yigezu-bisrat-goffer-fonts"
No match for group package "google-croscore-arimo-fonts"
No match for group package "fedora-user-agent-chrome"
No match for group package "pagul-fonts"
No match for group package "khmeros-muol-fonts"
No match for group package "tuladha-jejeg-fonts"
No match for group package "tangerine-fonts"
No match for group package "dnf-yum"
No match for group package "impallari-lobster-fonts"
No match for group package "khmeros-siemreap-fonts"
No match for group package "oflb-roadstencil-fonts"
No match for group package "senamirmir-washra-tint-fonts"
No match for group package "senamirmir-washra-yigezu-bisrat-gothic-fonts"
No match for group package "paratype-pt-sans-fonts"
No match for group package "wallpoet-fonts"
No match for group package "shadowsintolight-fonts"
No match for group package "min12xxw"
No match for group package "google-crosextra-carlito-fonts"
No match for group package "astloch-fonts"
No match for group package "moyogo-molengo-fonts"
No match for group package "senamirmir-washra-hiwua-fonts"
No match for group package "lsvpd"
No match for group package "google-droid-kufi-fonts"
No match for group package "senamirmir-washra-yebse-fonts"
No match for group package "tharlon-fonts"
No match for group package "stix-math-fonts"
No match for group package "google-crosextra-caladea-fonts"
No match for group package "ecolier-court-lignes-fonts"
No match for group package "xorg-x11-drv-omap"
No match for group package "oflb-icelandic-fonts"
No match for group package "xorg-x11-drv-geode"
No match for group package "khmeros-bokor-fonts"
No match for group package "banshee"
No match for group package "typemade-josefinsansstd-light-fonts"
No match for group package "apanov-edrip-fonts"
No match for group package "kranky-fonts"
No match for group package "sonic-visualiser-freeworld"
No match for group package "google-croscore-cousine-fonts"
No match for group package "google-croscore-symbolneu-fonts"
No match for group package "senamirmir-washra-zelan-fonts"
No match for group package "smc-kalyani-fonts"
No match for group package "trabajo-fonts"
No match for group package "khmeros-battambang-fonts"
No match for group package "isight-firmware-tools"
No match for group package "carterone-fonts"
No match for group package "google-noto-sans-ui-fonts"
No match for group package "mph-2b-damase-fonts"
No match for group package "tabish-eeyek-fonts"
No match for group package "google-noto-sans-balinese-fonts"
No match for group package "cyreal-wireone-fonts"
No match for group package "senamirmir-washra-fantuwua-fonts"
No match for group package "smc-raghumalayalam-fonts"
No match for group package "cf-sorts-mill-goudy-fonts"
No match for group package "inkboy-fonts"
No match for group package "senamirmir-washra-wookianos-fonts"
No match for group package "sarai-fonts"
No match for group package "bcm283x-firmware"
No match for group package "labelleaurore-fonts"
No match for group package "khmeros-handwritten-fonts"
No match for group package "totem-nautilus"
No match for group package "lame-mp3x"
No match for group package "google-noto-mono-fonts"
No match for group package "senamirmir-washra-jiret-fonts"
No match for group package "vt323-fonts"
No match for group package "oflb-sportrop-fonts"
No match for group package "reeniebeanie-fonts"
No match for group package "khmeros-metal-chrieng-fonts"
No match for group package "monofett-fonts"
No match for group package "google-croscore-tinos-fonts"
Error: 
 Problem 1: package gnome-getting-started-docs-hu-3.38.1-1.fc33.noarch requires gnome-getting-started-docs = 3.38.1-1.fc33, but none of the providers can be installed
  - gnome-getting-started-docs-3.38.1-1.fc33.noarch does not belong to a distupgrade repository
  - problem with installed package gnome-getting-started-docs-hu-3.38.1-1.fc33.noarch
 Problem 2: rdma-core-34.0-1.fc33.i686 has inferior architecture
  - rdma-core-34.0-1.fc33.x86_64 does not belong to a distupgrade repository
  - problem with installed package rdma-core-34.0-1.fc33.i686
(try to add '--skip-broken' to skip uninstallable packages)
[root@localhost 

Version-Release number of selected component (if applicable):
FC 33
How reproducible:
dnf system-upgrade download --refresh --releasever=34 

Steps to Reproduce:
1.see above
2.
3.

Actual results:
Error messges posted above

Expected results:


Additional info:

Comment 1 Pavla Kratochvilova 2021-05-04 06:27:42 UTC
Hello,

there are two separate issues:

First is broken upgrade path for gnome-getting-started-docs-hu package, which was already fixed, see bug 1954117.

Second is broken upgrade path for rdma-core package, which is tracked by bug 1956631. Since there is no problem in dnf, and the only remaining issue is the one with rdma-core package I am closing this as its duplicate.

*** This bug has been marked as a duplicate of bug 1956631 ***


Note You need to log in before you can comment on or make changes to this bug.