Bug 1956631 - Fedora 34 upgrade from Fedora 33 blocked by rdma-core
Summary: Fedora 34 upgrade from Fedora 33 blocked by rdma-core
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rdma-core
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Honggang LI
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1954733 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-04 05:46 UTC by Jeff lats
Modified: 2022-02-04 02:50 UTC (History)
13 users (show)

Fixed In Version: rdma-core-37.2-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-04 02:50:45 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Jeff lats 2021-05-04 05:46:44 UTC
Description of problem:upgrading from FC33 to FC34is blocked 

Error: 
 Problem: rdma-core-34.0-1.fc33.i686 has inferior architecture
  - rdma-core-34.0-1.fc33.x86_64 does not belong to a distupgrade repository
  - problem with installed package rdma-core-34.0-1.fc33.i686



Version-Release number of selected component (if applicable):


How reproducible:
Happens every time following the upgrade guide.

Steps to Reproduce:
1. sudo dnf system-upgrade download --releasever=34 --skip-broken
2.
3.

Actual results:

Error: 
 Problem: rdma-core-34.0-1.fc33.i686 has inferior architecture
  - rdma-core-34.0-1.fc33.x86_64 does not belong to a distupgrade repository
  - problem with installed package rdma-core-34.0-1.fc33.i686

Expected results:


Additional info:
Attempting to erase rdma-core gives:
sudo dnf erase rdma-core-34.0-1.fc33.i686

Error: 
 Problem: The operation would result in removing the following protected packages: systemd
(try to add '--skip-broken' to skip uninstallable packages)

Comment 1 Pavla Kratochvilova 2021-05-04 06:27:39 UTC
*** Bug 1954733 has been marked as a duplicate of this bug. ***

Comment 2 Steve 2021-05-05 11:50:09 UTC
I can confirm this bug, except that it would not remove systemd but wine*.

$ sudo dnf remove rdma-core-34.0-1.fc33.i686
Dependencies resolved.
================================================================================
 Package                        Arch   Version                   Repo      Size
================================================================================
Removing:
 rdma-core                      i686   34.0-1.fc33               @updates 115 k
Removing dependent packages:
 libibverbs                     i686   34.0-1.fc33               @updates 990 k
 libpcap                        i686   14:1.10.0-1.fc33          @updates 404 k
 wine                           x86_64 6.7-1.fc33                @updates   0  
 wine-core                      i686   6.7-1.fc33                @updates 473 M
Removing unused dependencies:
 SDL2                           i686   2.0.14-1.fc33             @updates 1.6 M
 gd                             i686   2.3.0-3.fc33              @fedora  406 k
 libFAudio                      i686   21.03.05-1.fc33           @updates 258 k
 libXcomposite                  i686   0.4.5-3.fc33              @fedora   41 k
 libXcursor                     i686   1.2.0-3.fc33              @fedora   49 k
 libXinerama                    i686   1.1.4-6.fc33              @fedora   18 k
 libXpm                         i686   3.5.13-3.fc33             @fedora  129 k
 liberation-narrow-fonts        noarch 2:1.07.6-4.fc33           @fedora  503 k
 libexif                        i686   0.6.22-3.fc33             @updates 2.3 M
 libgphoto2                     i686   2.5.27-1.fc33             @updates 5.8 M
 libieee1284                    i686   0.2.11-34.fc33            @fedora   96 k
 libimagequant                  i686   2.12.6-3.fc33             @fedora  142 k
 libraqm                        i686   0.7.0-6.fc33              @fedora   24 k
 libusbx                        i686   1.0.24-2.fc33             @updates 163 k
 libvkd3d                       i686   1.2-1.fc33                @fedora  386 k
 libvkd3d-shader                i686   1.2-1.fc33                @fedora  277 k
 mesa-libOSMesa                 i686   20.3.5-2.fc33             @updates  11 M
 mingw32-wine-gecko             noarch 2.47.2-1.fc33             @updates  51 M
 mingw64-wine-gecko             noarch 2.47.2-1.fc33             @updates  49 M
 ocl-icd                        i686   2.2.13-1.fc33             @updates 161 k
 samba-common-tools             x86_64 2:4.13.7-1.fc33           @updates 1.2 M
 samba-winbind                  x86_64 2:4.13.7-1.fc33           @updates 1.6 M
 samba-winbind-clients          x86_64 2:4.13.7-1.fc33           @updates 162 k
 samba-winbind-modules          x86_64 2:4.13.7-1.fc33           @updates  81 k
 sane-backends-drivers-cameras  i686   1.0.32-4.fc33             @updates  56 k
 sane-backends-drivers-scanners i686   1.0.32-4.fc33             @updates  13 M
 sane-backends-libs             i686   1.0.32-4.fc33             @updates 100 k
 spirv-tools-libs               i686   2020.5-1.20200803.git92a7165.fc33
                                                                 @fedora  4.4 M
 vulkan-tools                   x86_64 1.2.148.0-1.fc33          @fedora  998 k
 wine-alsa                      i686   6.7-1.fc33                @updates 232 k
 wine-alsa                      x86_64 6.7-1.fc33                @updates 250 k
 wine-arial-fonts               noarch 6.7-1.fc33                @updates 157 k
 wine-capi                      i686   6.7-1.fc33                @updates  84 k
 wine-capi                      x86_64 6.7-1.fc33                @updates  86 k
 wine-cms                       i686   6.7-1.fc33                @updates 396 k
 wine-cms                       x86_64 6.7-1.fc33                @updates 449 k
 wine-courier-fonts             noarch 6.7-1.fc33                @updates 170 k
 wine-desktop                   noarch 6.7-1.fc33                @updates 696 k
 wine-dxvk                      i686   1.8.1-1.fc33              @updates  48 M
 wine-dxvk                      x86_64 1.8.1-1.fc33              @updates  60 M
 wine-dxvk-d3d9                 i686   1.8.1-1.fc33              @updates  14 M
 wine-dxvk-d3d9                 x86_64 1.8.1-1.fc33              @updates  17 M
 wine-dxvk-dxgi                 i686   1.8.1-1.fc33              @updates  13 M
 wine-dxvk-dxgi                 x86_64 1.8.1-1.fc33              @updates  16 M
 wine-fixedsys-fonts            noarch 6.7-1.fc33                @updates  37 k
 wine-fonts                     noarch 6.7-1.fc33                @updates   0  
 wine-ldap                      i686   6.7-1.fc33                @updates 1.3 M
 wine-ldap                      x86_64 6.7-1.fc33                @updates 1.6 M
 wine-marlett-fonts             noarch 6.7-1.fc33                @updates  32 k
 wine-mono                      noarch 6.1.1-1.fc33              @updates 222 M
 wine-ms-sans-serif-fonts       noarch 6.7-1.fc33                @updates 4.6 M
 wine-openal                    i686   6.7-1.fc33                @updates 119 k
 wine-openal                    x86_64 6.7-1.fc33                @updates 157 k
 wine-opencl                    i686   6.7-1.fc33                @updates 332 k
 wine-opencl                    x86_64 6.7-1.fc33                @updates 381 k
 wine-pulseaudio                i686   6.7-1.fc33                @updates 227 k
 wine-pulseaudio                x86_64 6.7-1.fc33                @updates 240 k
 wine-small-fonts               noarch 6.7-1.fc33                @updates  65 k
 wine-symbol-fonts              noarch 6.7-1.fc33                @updates  51 k
 wine-system-fonts              noarch 6.7-1.fc33                @updates 121 k
 wine-systemd                   noarch 6.7-1.fc33                @updates 119  
 wine-tahoma-fonts              noarch 6.7-1.fc33                @updates 300 k
 wine-times-new-roman-fonts     noarch 6.7-1.fc33                @updates 170 k
 wine-twain                     i686   6.7-1.fc33                @updates 282 k
 wine-twain                     x86_64 6.7-1.fc33                @updates 320 k
 wine-webdings-fonts            noarch 6.7-1.fc33                @updates  30 k
 wine-wingdings-fonts           noarch 6.7-1.fc33                @updates  35 k

Transaction Summary
================================================================================
Remove  72 Packages

Freed space: 1.0 G
Is this ok [y/N]:

Comment 3 Steve 2021-05-05 14:16:38 UTC
There is no dependency error by upgrading with the GUI (Gnome-Software) and rdma-core* is deinstalled after upgrading.

Comment 4 John Gotts 2021-05-08 23:33:28 UTC
Probably it would be better to fix the package rather than requiring you to remove 1 GB worth of packages before the upgrade can proceed. Seems a bit excessive to have to remove wine to upgrade to Fedora 34. It's like 50 packages, right?

Comment 5 Jeff lats 2021-05-09 23:34:32 UTC
Note that in my case it was trying to remove systemd not wine.

Comment 6 Honggang LI 2021-05-10 00:40:02 UTC
Remove the rdma-core.i686 package with "rpm -e --nodeps" before you upgrade. That is the workaround.

Comment 7 Dominik 'Rathann' Mierzejewski 2021-05-17 10:37:29 UTC
Duplicate of bug 1919864.

Comment 8 Troy Volin 2021-06-19 02:55:49 UTC
The recent update to rdma-core (in f33 and f34) to rdma-core-35.0-1 breaks the previously-working fix to the "rdma-core prevents F33 to F34 system upgrade" bug.
Specifically, advisory FEDORA-2021-a9fa349382 fixed that by adding obsoletes in the RPM spec which don't work for version 35.0-1:
90	+ %if 0%{?fedora} >= 34
91	+ # self obsoletes to remove i686 multilib package when updating to F34
92	+ Obsoletes: rdma-core < 34.0-3
93	+ %endif
94	+

So when 35.0-1 got introduced, it needed to also update the .spec file to update the Obsoletes to "Obsoletes: rdma-core < 35.0-1"

If you push that change, nobody will need to do any "rpm -e --nodeps rdma-core.i686" as part of their upgrade path.

Comment 9 Leszek Matok 2021-07-03 20:38:14 UTC
Trying to upgrade F33->F34 I hit this thing.

Thinking I might have upgraded F33 too much, I did yum downgrade rdma\*

Now I have
rdma-core-31.0-1.fc33.x86_64
rdma-core-31.0-1.fc33.i686

And yet, Error: 
 Problem: rdma-core-31.0-1.fc33.i686 has inferior architecture
  - rdma-core-31.0-1.fc33.x86_64 does not belong to a distupgrade repository
  - problem with installed package rdma-core-31.0-1.fc33.i686

So NO, it is NOT an issue with the F33 35.0-1 update. Downgrading from it still does NOT allow upgrade to F34.

So then I searched and found this bug, but it says the issue is with Obsoletes < 34.0? I already have 31.0 and still can't upgrade. Even trying to yum update only rdma\* says
 Problem: package rdma-core-35.0-1.fc34.x86_64 obsoletes rdma-core < 34.0-3 provided by rdma-core-31.0-1.fc33.i686
  - cannot install the best update candidate for package rdma-core-31.0-1.fc33.x86_64
  - problem with installed package rdma-core-31.0-1.fc33.i686

Clearly F34 simply doesn't have rdma-core.i686, confirmed by yum --releasever=34 info rdma-core

And yet, it's required by existing software (yes, for this system it's WINE _from_Fedora_repositories_, but I support algo-trading software on RHEL which also depends on 32-bit rdma+libibverbs - guess RHEL7 will be the terminal release for actual enterprise Linux if this creeps down to RHEL8?)

I'm baffled how a bug like this was caught in March (reported on the forum), and this BZ is from May... and here I am, unable to upgrade to a final F34 in July. Does anyone not have WINE installed on their "home" Fedora? Except the developers who don't even use it daily, of course...

Comment 10 Lindsay MacVean 2021-08-05 14:37:15 UTC
When upgrading from 33 to 34 I used --allowerasing and this seemed to work for me to only remove that single package (I am still waiting for upgrade so have not tested Wine on 34 yet)

As in 
```
$ sudo dnf system-upgrade download --releasever=34 --allowerasing
...

Removing dependent packages:
 kmod-nvidia-5.11.22-100.fc32.x86_64
                                   x86_64 3:460.67-1.fc32         @@commandline
                                                                           43 M
 rdma-core                         i686   35.0-1.fc33             @updates
                                                                          115 k
```




As per Kamil Paral comment here https://bugzilla.redhat.com/show_bug.cgi?id=1919864#c17

Comment 11 Robert Scheck 2022-01-09 01:26:43 UTC
Dear package maintainer, may I kindly ask you to fix this issue after 8+ months as e.g. suggested in comment #8, please? Thank you :)

Comment 12 Honggang LI 2022-01-10 13:58:53 UTC
(In reply to Robert Scheck from comment #11)
> Dear package maintainer, may I kindly ask you to fix this issue after 8+
> months as e.g. suggested in comment #8, please? Thank you :)

 %if 0%{?fedora} >= 34
 # self obsoletes to remove i686 multilib package when updating to F34
-Obsoletes: rdma-core < 34.0-3
+Obsoletes: rdma-core < %{version}-%{release}

Please try this scratch build.

https://koji.fedoraproject.org/koji/taskinfo?taskID=81062599


Note You need to log in before you can comment on or make changes to this bug.