Bug 195475 - [RHEL4] rhgb should kill itself before letting gdm start
[RHEL4] rhgb should kill itself before letting gdm start
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhgb (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: 198694 223074
  Show dependency treegraph
 
Reported: 2006-06-15 09:23 EDT by Chris Williams
Modified: 2010-10-22 01:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0271
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 19:53:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Williams 2006-06-15 09:23:00 EDT
Description of problem:
When going from gdm or a VT and changing to runlevel 3 we are sent to V8 where
the various service are shutdown. Since there is no getty running on VT8, in
order to get to a functional console you have to use Alt + Fn. To the layman it
appears as though the console is hung.


Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1. Log into gdm or a VT, execute 'init 3'
2. We are sent to VT8 where the various services are shutdown.
3. VT8 has no getty running on it so it appears hung. Alt + Fn is required to
get to a usable console.
  
Actual results:
We are sent to VT8 where no getty is running.

Expected results:
Return to VT 5 or what ever VT we executed the 'init 3' from. Or just sent to a
usable VT.

Additional info:
Comment 1 RHEL Product and Program Management 2006-08-18 11:30:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Ray Strode [halfline] 2007-01-17 14:38:46 EST
there ended up being another component to this fix.  Namely, rhgb needed to
waitpid() on the x server before exiting and the X server needed to block on the
vt change before exiting (with a VT_WAITACTIVE ioctl)

I'll clone this bug for the X half.
Comment 7 Ray Strode [halfline] 2007-01-17 14:55:54 EST
For reference, the X half of this is filed as bug 223074
Comment 13 Red Hat Bugzilla 2007-05-01 19:53:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0271.html

Note You need to log in before you can comment on or make changes to this bug.