Bug 1956107 - Reject RHEL < 6.9 on PPC
Summary: Reject RHEL < 6.9 on PPC
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.4.5
Hardware: ppc64
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ovirt-4.5.0
: 4.5.0
Assignee: Michal Skrivanek
QA Contact: Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-02 19:24 UTC by Arik
Modified: 2022-04-28 09:26 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.5.0
Doc Type: Bug Fix
Doc Text:
This change changes the following: 1- reject RHEL up to 6.8 OS for all cluster levels instead of only 4.2 and 4.3 2- filters out RHEL up to 6.8 from webadmin Operation system drop-down in new VM, pool and import VM dialogs if there is such VMs with this OS, RHEL up to 6.8 OS will still be visible in the Operation system drop-down, but it will not be possible to run this VM or edit it, since its blocked
Clone Of:
Environment:
Last Closed: 2022-04-28 09:26:34 UTC
oVirt Team: Virt
pm-rhel: ovirt-4.5?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 116158 0 master MERGED engine: Reject RHEL up to 6.8 OS on PPC 2021-11-04 12:00:23 UTC

Description Arik 2021-05-02 19:24:16 UTC
The solution for bz 1490784 blocked RHEL < 6.9 on PPC for compatibility level 4.2 (since they were not supported on pseries-rhel7.4.0+). Later they were blocked also for compatibility level 4.3 for the same reason.

The problem is that we need to manually add every new compatibility version to that list now (and of course we didn't since 4.4).

As we dropped compatibility levels <= 4.1, we can now just block them altogether - we can introduce a validation that rejects this OS type, and remove it from the list of operating systems on new/edit VM.

Comment 2 Tamir 2022-04-24 15:00:36 UTC
Verified on RHV 4.5.0-7.

Env (PPC):
    - Engine instance with RHV 4.5.0-7 (ovirt-engine-4.5.0.4-0.1.el8ev) and RHEL 8.6 installed.
    - 3 Power 8 hosts with RHV 4.5.0-7 and RHEL 8.6 and with vdsm-4.50.0.13-1.el8ev.

Steps:

In Admin Portal:
1. Create a 4.7 data center and a 4.7 cluster.
2. Install the hosts and create a new NFS storage domain.
3. Open the "New Virtual Machine" modal via Compute -> Virtual Machines -> New.
4. In the Operating System dropdown, check that there aren't any earlier versions than RHEL 6.9.
5. Create an RHEL VM with a 10GB disk.
6. Edit the VM.
7. In the Operating System dropdown, check that there aren't any earlier versions than RHEL 6.9.
8. Open the "New Pool" modal via Compute -> Pools -> New.
9. In the Operating System dropdown, check that there aren't any earlier versions than RHEL 6.9.
10. Repeat steps 1 to 9 for 4.2 to 4.6 clusters.
11. In the engine host, open the file /etc/ovirt-engine/osinfo.conf.d/00-defaults.properties.
12. Under the rhel6ppc64(1003, OsType.Linux, true) section, check that the line os.rhel_6_ppc64.deprecated.value = true appears.

Results (As Expected):
1. The 4.7 data center and the 4.7 cluster were created.
2. The hosts were installed and the NFS storage domain was created.
3. The "New Virtual Machine" modal is open.
4. There aren't any earlier versions than RHEL 6.9.
5. The VM was created.
6. The "Edit Virtual Machine" modal is open.
7. There aren't any earlier versions than RHEL 6.9.
8. The "New Pool" modal is open.
9. There aren't any earlier versions than RHEL 6.9.
10. In every cluster version, there aren't any earlier versions than RHEL 6.9.
11. The file has opened.
12. The line "os.rhel_6_ppc64.deprecated.value = true" appears in the file.

Comment 3 Sandro Bonazzola 2022-04-28 09:26:34 UTC
This bugzilla is included in oVirt 4.5.0 release, published on April 20th 2022.

Since the problem described in this bug report should be resolved in oVirt 4.5.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.