Bug 195616 - undefined symbol: gtk_print_operation_get_error
Summary: undefined symbol: gtk_print_operation_get_error
Status: CLOSED DUPLICATE of bug 196276
Alias: None
Product: Fedora
Classification: Fedora
Component: gajim (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dawid Gajownik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-15 21:57 UTC by Paul Dickson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 15:30:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Dickson 2006-06-15 21:57:29 UTC
Description of problem:
gajim aborts with the error:
ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/gtk/_gtk.so: undefined
symbol: gtk_print_operation_get_error

Version-Release number of selected component (if applicable):
gajim-0.10.1-1.fc6
pygtk2-2.9.1-2
gtk2-2.9.2-4

How reproducible:
Always

Steps to Reproduce:
1. yum install gajim
2. gajim
3.
  
Actual results:
Traceback (most recent call last):
  File "gajim.py", line 36, in ?
    import message_control
  File "/usr/share/gajim/src/message_control.py", line 14, in ?
    import gtk
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 43, in ?
    from _gtk import *
ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/gtk/_gtk.so: undefined
symbol: gtk_print_operation_get_error

Expected results:
progam runs.

Additional info:

Comment 1 Paul Dickson 2006-06-15 22:32:35 UTC
Revert back to:
    pygtk2-2.9.0-3.i386.rpm
    pygtk2-libglade-2.9.0-3.i386.rpm
    pygtk2-devel-2.9.0-3.i386.rpm
allowed gajim to run.

This is likely a pygtk2 problem.

Comment 2 Dawid Gajownik 2006-06-22 16:01:38 UTC
Thanks for your bug report and sorry that it took so long. It's a hectic time at
the University (lots of exams), my cousin had a wedding and I wasn't able to
reinstall my Rawhide system (bug #195766).

Can we close this bug as a dupe of #195706 ? ;-)

Comment 3 Paul Dickson 2006-06-23 06:09:29 UTC
Yes.  I tried changing the package for this bug, but there was a boundary
between Extras and Core packages.  So I reissued the bug.

Comment 4 Jeremy Katz 2006-06-23 15:30:54 UTC

*** This bug has been marked as a duplicate of 196276 ***


Note You need to log in before you can comment on or make changes to this bug.