Bug 195702 - /etc/rc.d/init.d/snmptrapd does not honor options set in /etc/snmp/snmptrapd.options
/etc/rc.d/init.d/snmptrapd does not honor options set in /etc/snmp/snmptrapd....
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
: 198532 (view as bug list)
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-06-16 13:53 EDT by Brian Reichert
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0183
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Reichert 2006-06-16 13:53:41 EDT
Description of problem:

  
/etc/rc.d/init.d/snmptrapd does not honor options set in /etc/snmp/snmptrapd.options

More specifically, after selectively reading the contents of the
/etc/snmp/snmptrapd.options file (if present), /etc/rc.d/init.d/snmptrapd goes
on to hard-code a list or options for snmptrapd.  This lies in questions that do
this:

if [ -e /etc/snmp/snmptrapd.options ]; then
  . /etc/snmp/snmptrapd.options
else
   OPTIONS="-Lsd -p /var/run/snmptrapd.pid"
fi

OPTIONS="-Lsd -p /var/run/snmptrapd.pid"



Version-Release number of selected component (if applicable):

  net-snmp-5.1.2-11.EL4.6


How reproducible:


Steps to Reproduce:
1.  Attempt to set any options in /etc/snmp/snmptrapd.options (for example '-d')
2.  Restart snmptrapd: 'service snmptrapd restart'
3.  Observe via 'ps' or otherwise that the added options are not in use.
  
Actual results:

options set in /etc/snmp/snmptrapd.options are ignored


Expected results:

options set in /etc/snmp/snmptrapd.options are honored

Additional info:
Comment 1 Brian Reichert 2006-06-16 13:57:52 EDT
Typo in my description, sorry.  The phrase 'This lies in questions' should have
been 'The lines in question'.
Comment 2 Radek Vokal 2006-07-11 07:10:23 EDT
This is already fixed in rawhide, I'm adding it on proposed list for next update
Comment 3 Radek Vokal 2006-07-12 08:19:40 EDT
*** Bug 198532 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2006-08-18 11:27:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Red Hat Bugzilla 2007-05-01 13:25:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0183.html

Note You need to log in before you can comment on or make changes to this bug.