Bug 198532 - snmptrapd parameters from snmptrapd.options
Summary: snmptrapd parameters from snmptrapd.options
Status: CLOSED DUPLICATE of bug 195702
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-11 17:13 UTC by John DeFranco
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-12 12:19:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John DeFranco 2006-07-11 17:13:46 UTC
Description of problem:
 snmptrapd parameters from snmptrapd.options

If /etc/snmp/snmptrapd.options is used to define invocation
parameters for the daemon by defining a value for OPTIONS,
this definition is overwritten hard in
/etc{/rc.d}/init.d/snmptrapd

The OPTIONS= statement in init.d/snmptrapd should probably
preceed the sourcing of /etc/snmp/snmptrapd.options


Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11


How reproducible:

Look at the script. We souce the snmptrapd.options file if it exists
but then hardcode the OPTIONS regardless of anything that is defined in
the options file.

[ -e /etc/snmp/snmptrapd.options ] && . /etc/snmp/snmptrapd.options
OPTIONS="-Lsd -p /var/run/snmptrapd.pid"
RETVAL=0
prog="snmptrapd"


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

The values for the OPTIONS paramater would be obtained from the options file.

Additional info:

Comment 1 Radek Vokal 2006-07-12 12:19:38 UTC

*** This bug has been marked as a duplicate of 195702 ***


Note You need to log in before you can comment on or make changes to this bug.