Bug 195749 - Install FC6 via http BSOD
Install FC6 via http BSOD
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
: Reopened
: 196304 196898 (view as bug list)
Depends On:
Blocks: FC6Test3Blocker
  Show dependency treegraph
 
Reported: 2006-06-16 20:39 EDT by Darwin H. Webb
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 10:57:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen photograph of VT3 showing DHCP failure (133.42 KB, image/jpeg)
2006-06-30 09:30 EDT, John Reiser
no flags Details

  None (edit)
Description Darwin H. Webb 2006-06-16 20:39:08 EDT
Description of problem:
Boot.iso vis http - install excited abnorally -- recieved signal 6
/sbin/loader 08262000-0828e000 rw-p 08262000 00:00 0
   086d55000-087b2000 rw-p 08d5000 00:00 [heap]
 b7e00000-b7e25000 rw-p b7e00000 00:00 0
 b7e25000-b7f00000 ---p 
 b7e25000 00:00 0
 b7fb6000-b7fba000 rw-p b7fb6000 00:00 0
 bf863000-bf878000 rw-p bf863000 00:00 0 [stack]
   installed exicted abnorally -- recieved signal 6
sneding termination signals...done
sending kil signals...done
disabling swap... unmounting file systems...

...
you may saftly reboot your system

Version-Release number of selected component (if applicable):
FC6 development for local mirror (that was updated this afternoon June 16th, pst

How reproducible:
Tried it twice

Steps to Reproduce:
1. press enter after entering the http site and path
2. BOSD
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Darwin H. Webb 2006-06-17 14:16:09 EDT
I got the same results for http and ftp install for boot.iso June 17th.

I noticed that the updates had an anaconda comment in libdhcp.
I noted that my current FC6 install did not have this package lib dhcp.
I yum installed it and it also installed dhcp4client and dhcp6client.

Q1. What was the system using for dhcpclient w/o these (as it works)?

Q2. Anaconda net install fails right after the enter of wensite and path.
Before this is the dhcp ip address get.
I do not notice and net activity on the dhcp server side.
Could the linkage between dhcplib and clients be missing in anaconda?

Just a thoht for debugging I don't need an answer.

FYI: The mail for this bug was never recieved.

Darwin
Comment 2 Scott Tsai 2006-06-17 22:34:09 EDT
Seeing this glibc detected double free or corruption error on both USB diskimage
and boot.iso. Using the FC5 installer images avoids it.
Comment 3 Matthias Saou 2006-06-26 10:52:25 EDT
This looks a bit like bug #196304 ...
Comment 4 David Cantrell 2006-06-27 12:56:50 EDT
*** Bug 196898 has been marked as a duplicate of this bug. ***
Comment 5 David Cantrell 2006-06-27 12:59:27 EDT
*** Bug 196304 has been marked as a duplicate of this bug. ***
Comment 6 David Cantrell 2006-06-27 16:17:04 EDT
This has been fixed in rawhide and will be in the next anaconda build.
Comment 7 Matthias Saou 2006-06-28 05:53:27 EDT
Thanks a lot.
Unfortunately, the joys of Rawhide are preventing me from testing the fix as the
installer fails to load the ne2k-pci module today *sigh* ;-)
Comment 8 John Reiser 2006-06-28 11:21:17 EDT
(In reply to comment #6)
> This has been fixed in rawhide and will be in the next anaconda build.

But that build did make it out to mirrors in the nightly push of Tuesday night
to Wednesday morning, June 27 to 28.  The "rawhide report: 20060628 changes"
shows none for anaconda, and none for the kernel.

The FC-development-ppc-rescuecd.iso pushed last night with md5sum
c9af809d83482b1bccf3f02ee0c81839 still gets "No driver found" for HTTP install
on Apple Macintosh PowerPC Power Mac G4.
Comment 9 David Cantrell 2006-06-28 14:32:09 EDT
We haven't had a new build of anaconda since June 23rd.  Remember that a new
rawhide tree != new anaconda build.  The rawhide report shows the results of a
new tree composition, which is a diff against previous RPM changelogs.  So you
get to see in the report is new RPMs that have shown up in the tree.  If you see
nothing for anaconda, that means we did not rebuild the anaconda RPM.

The sentence "this problem has been fixed in rawhide and will be in the next
anaconda build" probably makes absolutely no sense to anyone outside of Red Hat.
 I'll try to do better with explanations in the future.  But, as far as anaconda
goes, we say "closed rawhide" when we mean we have fixed the problem in the HEAD
CVS branch of the anaconda tree.  I say "will be in the next anaconda build" as
a reminder that even though the code fixes are there, users won't see any
changes until we rebuild the RPM.  We don't build new anaconda RPMs each day and
usually try to get the HEAD branch somewhat stable before a new RPM is built. 
Hope that makes a little more sense.  Sorry for the confusion.

And, as noted in comment #7, kernel modules can't load with rawhide's current
kernel (known problem).
Comment 10 John Reiser 2006-06-29 09:11:33 EDT
The bug is back.  Please Re-open; bugzilla won't let me change Status.

"rawhide report: 20060629 changes" claims that anaconda-11.1.0.49-1 has fixed
this bug #195749.  However, using last night's FC-development-ppc-rescuecd.iso
with md5sum 26fa172e209467ca1268792fe9e4dd39, I still get "*** glibc detected
*** /sbin/loader: corrupted double-linked list" and traceback.  The good news is
that the rescue CD apparently did find the driver for the builtin ethernet on
Apple Macintosh PowerPC Power Mac G4, because it got beyond entering the server
and path, and got beyond the DHCP dialog.
Comment 11 Matthias Saou 2006-06-29 09:19:04 EDT
Then it's maybe ppc specific or only happening for the rescue CD because the
i386 boot.iso image dated 20060629 did fix the problem for me.
Comment 12 David Cantrell 2006-06-29 11:32:09 EDT
Reopened and investigating the PPC rescue CD problem.
Comment 13 John Reiser 2006-06-30 09:27:41 EDT
This time no BSOD, but "install terminated abnormally".
sha1sum=830546309ea5a031aaf0a64b74df1a4e71a3b331 
FC-development-ppc-rescuecd.iso of 2006-06-30.

The attached screen shot [.jpg ;-)] of VT3 shows a couple of interesting items.
 First, DHCPv4 was obtained in less than one second at 13:10:07, while DHCPv6
timeout took 47 seconds from 13:10:07 to :54.  That's too long, so there should
be an option to disable DHCPv6.  Second, "13:10:56 ERROR: nic_configure: failed
to configure resolver." and "DHCPv4 interface configuration failed." even though
this network has a healthy DHCPv4 server (Netgear RP614v2; no hostname tracking)
which does provide resolver addresses.
Comment 14 John Reiser 2006-06-30 09:30:19 EDT
Created attachment 131808 [details]
screen photograph of VT3 showing DHCP failure

830546309ea5a031aaf0a64b74df1a4e71a3b331  FC-development-ppc-rescuecd.iso
"boot: linux askmethod" HTTP  "install terminated abnormally"
Comment 15 Matthias Saou 2006-06-30 09:38:50 EDT
I also get "install terminated abnormally" with 20060630 i386 boot.iso trying an
ftp install, but DHCP worked (no IPv6 here either, so I agree about the nearly 1
minute timemout being quite annoying). I got that message right after it
transferred the stage2 image, and the last message on tty2 was "Running anaconda
script /usb/bin/anaconda".

Different problem than initially, but still some anaconda problem that prevents
the installation :-)
Comment 16 David Cantrell 2006-06-30 10:57:37 EDT
OK, too many bug reports in this one BZ entry.  I already know about install
terminated abnormally.  I uncovered that yesterday.  Working on tracking that
down.  It's happening in a few scenarios, but the easy way to recreate it is to
do a static IP configuration and proceed with an NFS install.  You will see that
message.  DHCP net installs work fine.

You can disable ipv6 by passing 'noipv6' as a boot parameter.  If you think the
UI in loader2 should have a check box for that or something, please file an RFE
for that.

Since this bug was originally for HTTP installs crashing and that is working
now, I'm closing the bug.  Other networking issues are present, but are
unrelated to the topic of this one.  Please open new bugs for new issues. 
Marking this one as closed.
Comment 17 Chris Tyler 2006-07-03 14:25:33 EDT
This doesn't work for me in current rawhide -- have the fixes flowed down yet?

I just tested eight different permutations:

- Rawhide version local mirror, July 2
- Two systems: old 400 MHz AMD with RTL3139 networking, and Dell Inspiron 3GHz
P4 laptop (5150) with B44 networking.
- Two protocols: HTTP and NFS
- Two IP assignment schemes: DHCP and static

*None* of the installations worked -- they all aborted at the "Starting
Anaconda" point (all static assignment attempts aborted one screen earlier,
right after the static IP information was entered).

(I've been trying the network installation daily but it hasn't worked for at
least a couple of weeks).

The traceback on VT8 shows:

  ...
  File "/usr/lib/anaconda/fsset.py" line 552, in __init__
  self.partedFileSystemType = parted.file_system_type_get("gfs")
  parted.error: unknown file system type


Note You need to log in before you can comment on or make changes to this bug.