Bug 195770 - yumex dies (yumex dont work with yum 2.9.x)
yumex dies (yumex dont work with yum 2.9.x)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 195269 195804 (view as bug list)
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-06-17 11:40 EDT by david.hagood
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1.0-2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-09 03:43:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david.hagood 2006-06-17 11:40:26 EDT
Description of problem:
yumex won't start:

# yumex
Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 36, in ?
    from yumex.yum24XBase import *
  File "/usr/lib/python2.4/site-packages/yumex/yum24XBase.py", line 26, in ?
    from repomd import mdUtils, mdErrors
ImportError: No module named repomd


Version-Release number of selected component (if applicable):
rpm -q yum yumex
yum-2.9.0-7
yumex-1.0.1-1.0.fc6


How reproducible:
Every time

Steps to Reproduce:
1. run yumex
  
Actual results:
Yumex dies with the above error

Expected results:
Yumex should run.


Additional info:
Comment 1 Jeremy Katz 2006-06-17 19:45:07 EDT
yumex needs to be updated for the API changes occurring in yum 2.9.x
Comment 2 Tim Lauridsen 2006-06-18 03:31:16 EDT
I working on making yumex working with the API Changes in yum 2.9.x.
Comment 3 Tim Lauridsen 2006-06-18 03:33:37 EDT
*** Bug 195269 has been marked as a duplicate of this bug. ***
Comment 4 Tim Lauridsen 2006-06-19 09:08:38 EDT
I have made the development branch of yumex 1.1.x, work with yum CVS head (2.9.x)
I have request a build of 1.1.0 in fedora Extras Development. I should be
available tomorrow.
Check it out and let me now if it works okay with rawhide.
Comment 5 Tim Lauridsen 2006-06-19 09:11:02 EDT
*** Bug 195804 has been marked as a duplicate of this bug. ***
Comment 6 Tim Lauridsen 2006-07-08 02:20:59 EDT
Does it yumex 1.1.x works with the current rawhide ???
Comment 7 david.hagood 2006-07-08 08:59:46 EDT
Yes, it is working with the new rawhide:

rpm -q yum yumex
yum-2.9.2-1
yumex-1.1.0-2.0.fc6
Comment 8 Tim Lauridsen 2006-07-09 03:43:11 EDT
(In reply to comment #7)
> Yes, it is working with the new rawhide:
> 
> rpm -q yum yumex
> yum-2.9.2-1
> yumex-1.1.0-2.0.fc6
> 

Thanks

Note You need to log in before you can comment on or make changes to this bug.