Bug 195779 - anaconda only loads ahci when ata_piix is required
anaconda only loads ahci when ata_piix is required
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 205871 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-17 14:27 EDT by Chris Adams
Modified: 2014-03-16 23:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: 1.2.56-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 17:08:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from lspci -vvv (12.42 KB, text/plain)
2006-09-27 09:15 EDT, Chris Adams
no flags Details

  None (edit)
Description Chris Adams 2006-06-17 14:27:37 EDT
My Thinkpad Z60m has the Intel ICH6M SATA controller (8086:6523).  This PCI ID
is listed in both the ahci and ata_piix modules, but the ahci module doesn't
recognize anything.  In FC5, both modules were loaded by anaconda and it "just
worked" because ata_piix found a drive.  With rawhide (2006-06-16), anaconda
loads ahci, doesn't find any drives, and stops.  I have to manually select ata_piix.

Someone suggested to me that I change my BIOS to get ahci working, but there is
no apparent option.

How about either:

a) going back to the old behavior of loading both modules

b) checking for the IBM vendor ID (1014) in the subsystem ID and loading
ata_piix first
Comment 1 Jesse Keating 2006-06-19 14:23:33 EDT
Moving to FC6 blocker.  Not enough to hold up Test1.
Comment 2 Bill Nottingham 2006-06-19 23:47:08 EDT
OK, some questions:

- Why does only one of the two see the drive?
- What is different that allows it to see the drive?

Generally, there's no way to tell which mode the chip is in, so it's not
something that can be reliably fixed in kudzu.

One thing we could do is change the kudzu abi to return multiple drivers. It'd
be ugly, though.
Comment 3 Chris Adams 2006-06-20 09:50:24 EDT
Okay, I don't know what changed, but now when I boot from the rawhide installer,
it just works.  No ahci module loaded and ata_piix is loaded.  I just booted it
twice and got the same result.  What changed since Friday morning?  I see that
anaconda was updated Friday, but the changelog doesn't mention anything that
sounds relevant.

How does anaconda (or kudzu) choose when more than one module is compatible with
the hardware (e100 vs. eepro100 for another example)?  Is there a static list,
is it a simple alpha sort, or is it random?
Comment 4 Bill Nottingham 2006-06-28 23:39:59 EDT
Picks one, based on ordering in modules.alias.
Comment 5 Chris Adams 2006-09-14 09:47:23 EDT
Well, I tried again with rawhide, and now I'm back to getting ahci loaded but
not ata_piix.  I have to manually load ata_piix.

I looked at modules.alias, and for my PCI ID (8086:2653, I typoed it above), and
ata_piix is listed first, so the ordering isn't working somehow.
Comment 6 Bill Nottingham 2006-09-14 17:11:12 EDT
IIRC, last wins, not first.
Comment 7 Bill Nottingham 2006-09-21 17:08:13 EDT
Hacked around in kudzu-1.2.56-1 for the installer.
Comment 8 Jeff Garzik 2006-09-26 17:35:49 EDT
Please provide a full lspci -vvv.

It sounds like PCI BAR 5 may have an assigned address even in ata_piix (IDE)
mode, to allow access to SATA phy registers.
Comment 9 Chris Adams 2006-09-27 09:15:53 EDT
Created attachment 137220 [details]
output from lspci -vvv
Comment 10 Konrad Rzeszutek 2006-12-05 15:03:22 EST
Chris,

There is discussion in another BZ about the order of loading of the 'ahci' and
'ata_piix'. The big question is if loading 'ahci' first and then 'ata_piix'
would "shadow" the PATA drives. I was wondering if you could help us and change
your /etc/modprobe.conf to have:
alias scsi_hostadapter ahci
alias scsi_hostadapter1 ata_piix

then run:
/sbin/new-kernel-pkg --mkinitrd --depmod --install `uname -r`

reboot and see if having the 'ahci' loaded first doesn't interfere with seeing 
your PATA drives (your hardisk, DVD, etc)?

Much appreciated,

Konrad
Comment 11 Chris Adams 2006-12-21 21:36:46 EST
Sorry for the delay (it has been a crazy month).  I'm not sure quite what you
mean by "shadow".  In my case, the only PATA device is the DVD drive.  The only
hard drive is SATA.

When I ran the above command, I still ended up with an initrd that loaded
ata_piix first and then ahci.  I manually changed the initrd init script; when I
boot and load ahci first, it still doesn't grab anything.  I see in the kernel
output:

libata version 2.00 loaded.
ahci 0000:00:1f.2: version 2.0
ahci: probe of 0000:00:1f.2 failed with error -12

The system seems to work fine like that.
Comment 12 Will Woods 2007-02-16 13:10:51 EST
*** Bug 205871 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.