Bug 205871 - Anaconda hangs initialising ahci
Anaconda hangs initialising ahci
Status: CLOSED DUPLICATE of bug 195779
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-09 04:38 EDT by Gawain Lynch
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-16 13:10:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gawain Lynch 2006-09-09 04:38:50 EDT
Description of problem:
When using rawhide 20060908 on an IBM R52 anaconda hangs after loading modules

Version-Release number of selected component (if applicable):
anaconda-11.1.0.94-1
kernel-2.6.17-1.2630.fc6

How reproducible:
Everytime

Steps to Reproduce:
1. Boot from iso or use initrd/vmlinuz
  
Actual results:
Kernel boots, anaconda starts, loads `ohci' then `ahci' then hangs

Expected results:
"Choose a Language" screen should appear and install proceeds

Additional info:
kernel-2.6.17-1.2630.fc6 boots OK when installed on this machine under FC5.

# lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem
Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751M Gigabit
Ethernet PCI Express (rev 11)
0b:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
0b:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
0b:02.0 Network controller: Intel Corporation PRO/Wireless 2915ABG MiniPCI
Adapter (rev 05)
Comment 1 Gawain Lynch 2006-09-10 18:38:02 EDT
Current rawhide (20060910) fixes this.

Comment 2 Gawain Lynch 2006-09-12 18:08:32 EDT
Problem is back in rawhide 20060912.  

Several attempts using rawhide from in between days were all successful.
Comment 3 Gawain Lynch 2006-09-14 03:22:43 EDT
While playing around I noticed on one of the tty's before it locked up that
device 0000:00:1f.2 "failed with error -12"

Comment 4 Gawain Lynch 2006-09-21 01:44:43 EDT
Changed summary and component.

Exact error on tty4 is:

  ahci 0000:00:1f.2 version 2.0
  ahci: probe of 0000:00:1f.2 failed with error -12

Kernel 2.6.17-1.2647.fc6 boots fine.
Comment 5 Gawain Lynch 2006-09-21 01:46:59 EDT
Do'h!  Might help if I reassign to the right people.
Comment 6 Jeremy Katz 2006-09-21 08:45:34 EDT
The problem is that the kernel is saying that the PCI id is supported by both
ahci and ata_piix so it's a tossup as to which gets loaded by anaconda -- the
hang then shouldn't occur.

This seems to be happening with a lot more frequency this time around... I'm
wondering what's changed in sata land to be tickling this more
Comment 7 Carl Henrik Lunde 2006-09-24 20:09:04 EDT
I have the same problem on my Dell Precision M20.  Same message on tty4, and my
lspci-output is the same.  FC6 Test 3.
Comment 8 Gawain Lynch 2006-09-24 20:29:06 EDT
Being that this is not an uncommon chipset I'm adding it to FC6KernelBlocker.

/me wants FC6 goodness too.
Comment 9 Carl Henrik Lunde 2006-09-25 06:41:55 EDT
This may have been fixed by bug #195779 - however I'm not sure how to verify
that it works now.
Comment 10 Gawain Lynch 2006-09-27 20:42:13 EDT
Carl is correct, the fix for bug #195779 seems to coincide with this working for
me again.
Comment 11 Will Woods 2007-02-16 13:10:35 EST

*** This bug has been marked as a duplicate of 195779 ***

Note You need to log in before you can comment on or make changes to this bug.