Bug 195782 - GL on PCIE R300 fails
GL on PCIE R300 fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 188228 196470 200677 (view as bug list)
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-06-17 14:41 EDT by Chris Adams
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 18:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2006-06-17 14:41:20 EDT
On my Thinkpad Z60m with an ATI Radeon Mobility X600 (RV380 PCIE), running
"glxgears" results in "drmRadeonCmdBuffer: -22 (exiting)".  When I check the
kernel log, I see:

[drm:r300_emit_3d_load_vbpntr] *ERROR* Offset failed range check (k=0 i=2) while
processing 3D_LOAD_VBPNTR packet.
[drm:r300_emit_packet3] *ERROR* r300_emit_raw_packet3 failed
[drm:r300_do_cp_cmdbuf] *ERROR* r300_emit_packet3 failed
Comment 1 Jesse Keating 2006-06-17 17:12:57 EDT
Not really a Test1 blocker.  not sure if t would be an FC6 blocker either,
making it FC6Target
Comment 2 Mike A. Harris 2006-06-19 18:00:06 EDT
Would seemingly be a bug in the kernel DRM, or in the 3D driver.

Assuming the latter, reassigning to mesa...
Comment 3 Adam Jackson 2006-06-23 17:11:10 EDT
*** Bug 196470 has been marked as a duplicate of this bug. ***
Comment 4 Adam Jackson 2006-06-23 17:11:51 EDT
*** Bug 188228 has been marked as a duplicate of this bug. ***
Comment 5 Adam Jackson 2006-06-23 17:12:46 EDT
For reference, this is fixed in Mesa head, and the backport difficulty is too
high to justify.  Planning to fix with either a build of Mesa HEAD or, ideally,
6.5.1 if it ever exists.
Comment 6 Chris Adams 2006-06-23 17:18:52 EDT
What does that mean for FC6 and rawhide?
Comment 7 Mike A. Harris 2006-06-25 15:32:50 EDT
"fix with" implies that.
Comment 8 Chris Adams 2006-07-28 14:40:59 EDT
Any chance we'll see an updated Mesa before FC6T2?
Comment 9 Adam Jackson 2006-08-04 01:01:06 EDT
*** Bug 200677 has been marked as a duplicate of this bug. ***
Comment 10 Chris Adams 2006-08-15 07:35:34 EDT
Are we going to get an updated Mesa that fixes this?  I saw discussion on the
mailing list about this, and I thought that someone was going to build a new
Mesa, but I haven't seen anything yet.
Comment 11 Andy Burns 2006-08-15 18:56:30 EDT
I originally reported this issue (though my bug got duped to this newer one)

My ATI based box has been my live box so for rawhide I've been mainly testing on
a nVidia based box, I thought I saw some Mesa updates so I'd revisit this now
FC6T2 has been released, did a fresh install on spare partition of my ATI box

Still get an error running glxgears, though now different to console

libGL warning: 3D driver claims to not support visual 0x4b
drmRadeonCmdBuffer: -22 (exiting)

same in /var/log/messages
Aug 14 23:08:35 htpc kernel: [drm:r300_emit_3d_load_vbpntr] *ERROR* Offset
failed range check (k=0 i=2) while processing 3D_LOAD_VBPNTR packet.
Aug 14 23:08:35 htpc kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Aug 14 23:08:35 htpc kernel: [drm:r300_do_cp_cmdbuf] *ERROR* r300_emit_packet3
failed

unsurprisingly compiz also fails and causes Xorg to restart, should this be any
further forward, or do I still need to wait for a(nother) Mesa update?

Comment 12 Tom Horsley 2006-08-20 11:06:16 EDT
Hey! The latest kernel/X/mesa updates on FC6t2 have opengl apps working
now, but the driver still seems a bit flakey. I start seeing little short
segments of horizontal white lines flashing on and off when running opengl
with the radeon driver on FC6t2 x86_64.

On the exact same machine, running fglrx on FC5 i686 no flashing lines appear,
the screen seems very clean with fglrx.
Comment 13 Andy Burns 2006-08-20 12:18:59 EDT
OK, just updated to rawhide, took the latest mesa/xorg-ati/kernel updates
and AIGLX functions for me, similar to comment #12 I have seen one or two stray
horizontal lines of corruption on screen.

I have desktops on a cube which whizz round merrily, and glxgears is smooth and
FWIW runs at 1400 fps (yes, I know it's not a benchmark)

My tooltips in gnome-panel wibble about a little bit, but though compiz *is*
running, it's as though I have no wndowmanager, windows have no decoration, no
borders, no menu, I'll chack and log a separate bugzilla for that though,
excellent work guys :-))
Comment 14 Andy Burns 2006-08-20 21:01:13 EDT
I notice that though most of the GL screensavers work fine in the small gnome
screensaver preview window, they don't work in the full-screen preview, or when
the screensaver kicks in for real. 

Also some of the GL screensavers (GLMatrix, GLForestfire, GLHanoi) are obviously
a bit too close to the edge for current r300 DRI, they sometimes work, sometimes
fail after a few seconds.

Comment 15 Hans de Goede 2006-08-22 16:19:47 EDT
Andy those problems you are experiencing are those with compiz (or an other
compostiing manager) or with just a plain windowmanager? With AIGLX / a
composite manager you can expect problems, thats still very new stuff. more
important is how 3D works in the plain setup.
Comment 16 Andy Burns 2006-09-01 14:03:13 EDT
the lack of window decorations is with compiz, mostly 3D isteld seems good, the
openGL screensavers seem happier to run in preview window than full screen,
glxgears if ok, google earth faster than without hardware 3D, but still slow,
though I gather that is due to anti-aliased line drawing dropping back to
software implementation.
Comment 17 Hans de Goede 2006-09-01 15:40:41 EDT
Are you getting fallback messages on the terminal when starting googleearth frm
the terminal?

Ifso update your mesa to the latest from rawhide that contains a workaround for
the googleearth problem, please report if you stil, have problems with google
earth after updating.

Comment 18 Tom Horsley 2006-09-08 14:22:43 EDT
Just thought I'd mention: With the latest updates on FC6t2 I no longer
see the flickering lines as described in Comment #12 above, everything
seems pretty smooth.
Comment 19 Adam Jackson 2006-09-15 18:08:41 EDT
This should be fixed as of the first 6.5.1 rc.  Please open new bugs for any
further issues on this hardware.

Note You need to log in before you can comment on or make changes to this bug.