This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 195783 - Suspend/hibernate on Thinkpad Z60m fails
Suspend/hibernate on Thinkpad Z60m fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-17 14:45 EDT by Chris Adams
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 21:47:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pm-suspend /var/log/messages (8.14 KB, text/plain)
2006-07-05 20:47 EDT, Chris Adams
no flags Details

  None (edit)
Description Chris Adams 2006-06-17 14:45:23 EDT
Niether suspend nor hibernate appear to work correctly on my Thinkpad Z60m with
rawhide 2006-06-16.

pm-suspend has failed two different ways:
- appears to suspend but won't resume at all
- won't suspend: I got a text screen with a blink cursor; nothing happened for
30 seconds so I hit the power button and the system properly shut down

pm-hibernate appeared to hibernate okay and then appeared to resume okay;
however, when I did something that caused an xterm to scroll, the display froze.
 No more keyboard input worked, however moving the mouse cursor still worked
(but clicking didn't do anything).  I had to hard power-off as the system was
otherwise dead.
Comment 1 Bill Nottingham 2006-07-05 19:29:08 EDT
Do you have messages similar to the ones in bug 197675?
 
Comment 2 Chris Adams 2006-07-05 20:47:16 EDT
Similar.  However, with 2.6.17-1.2339.fc6, I get a kernel error and NM crash
when it restarts when trying to pm-suspend (log attached).  This may be
something else but I figured I toss it in just in case it helped show the problem.

Also, if I run pm-suspend at the command line, I get (when it comes back - don't
know where in the process this happens):

open: No such file or directory
/etc/pm/functions: line 191: echo: write error: Resource temporarily unavailable
Comment 3 Chris Adams 2006-07-05 20:47:57 EDT
Created attachment 131973 [details]
pm-suspend /var/log/messages
Comment 4 Chris Adams 2006-12-21 21:47:03 EST
Okay, with FC6, suspend/resume seems to work.  The only problem is that after
resume, the text console is gone.  If I switch to it (or when I shut down and X
exits), the screen "fades" to blue-white.  X works fine however.

Hibernate to disk and resume also seems to work; the only problem there is my
Bluetooth mouse goes crazy.  I have to disable/re-enable the Bluetooth
controller (via /proc/acpi/ibm/bluetooth) to reset it (power cycling the mouse
doesn't fix it).
Comment 5 Nigel Cunningham 2006-12-22 17:01:14 EST
Could you please open separate bugs for each of these other issues?

Note You need to log in before you can comment on or make changes to this bug.