Bug 195801 - Wrong driver for Samsung ML-1610
Wrong driver for Samsung ML-1610
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: Reopened
Depends On:
Blocks: FC6Update
  Show dependency treegraph
Reported: 2006-06-17 17:53 EDT by Jon Burgess
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.0.2-39.4.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-17 12:06:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jon Burgess 2006-06-17 17:53:36 EDT
Description of problem: Foomatic doesn't have a driver listed for the Samsung
ML-1610 in the database.

Version-Release number of selected component (if applicable):

How reproducible: Every time

Steps to Reproduce:
1. Attach samsung ML-1610 printer
2. Run system-config-printer
Actual results:
No match for USB device:
  mfr "Samsung"
  model "ML-1610"
  desc ""
  cmdset "GDI"

Expected results:

Additional info:
The printer appears to work using the ML-1710 / GDI driver.
Comment 1 Fedora Update System 2006-11-13 15:45:13 EST
Fixed in update: foomatic-3.0.2-39.1.fc6
Comment 2 Jon Burgess 2006-11-13 17:35:18 EST
I'm having mixed results with this. I removed all previous print queues and
restarted. There was no sign of HAL adding this printer automatically (unlike
the Epson Stylus Photo R220 in bug 195794). Could this be because there seems to
be a choice of 2 drivers GDI vs Postscript?

I first added the printer via the cups web interface selecting the GDI driver
and this seemed to work OK (at least the test page).

Next I tried to add another printer this time using system-config-printer and
select the postscript driver. The first problem I found was that I got an error:

   There was an error during the CUPS operation: 'server-error-internal-error'

I tried the same thing via the cups web interface and got:

  "PPD file is empty" 

Next when I look in the cups web interface I see a broken entry specifying:
	Description: {printer_info}
Location: {printer_location}
Make and Model: {printer_make_and_model}
Printer State: stopped, rejecting jobs, published.

On the console of system-config-printer I see:
Samsung-ML-1610 foomatic:Samsung-ML-1610-Postscript.ppd
PPD name: foomatic:Samsung-ML-1610-Postscript.ppd

I can't find any such file as "Samsung-ML-1610-Postscript.pp" in any of the
foomatic or gutenprint rpms. There is some reference to a vendor supplied
Postscript PPD in the Samsung-ML-1610.xml file, could this be it?

Given this is a sub-$100 printer, i'd be surprised if it did support Postscript
directly, I certainly wasn't expecting it, but I can't say for sure.
Comment 3 Tim Waugh 2006-11-14 06:37:04 EST
Okay, thanks for testing.  Investigating.
Comment 4 Tim Waugh 2006-11-23 09:44:15 EST
Does bug #216065 look like it might be the problem?

What processor speed is that computer?
Comment 5 Jon Burgess 2006-11-23 20:53:49 EST
Athlon 64 3000, in this case I think there was a genuine error with the PPD file
rather than a timeout. 

# time /usr/lib/cups/daemon/cups-driverd cat foomatic:Samsung-ML-1610-Postscript.ppd
The printer (null) (null) (ID: Samsung-ML-1610) is not supported by the driver
Could not run "foomatic-combo-xml"/"foomatic-perl-data"! at
/usr/lib/perl5/vendor_perl/5.8.8/Foomatic/DB.pm line 572.

real    0m1.604s
user    0m0.676s
sys     0m0.282s
Comment 6 Tim Waugh 2006-12-05 08:05:39 EST

*** This bug has been marked as a duplicate of 216065 ***
Comment 7 Jon Burgess 2006-12-05 13:11:24 EST
is it really too slow? it only took 1.6 seconds to run the command above.
Comment 8 Tim Waugh 2006-12-06 04:33:21 EST
Oops, sorry, changed the wrong bug summary.
Comment 9 Tim Waugh 2006-12-06 08:38:18 EST
Okay, 'Postscript' has been removed from the drivers list for that printer in
foomatic-3.0.2-39.2.fc6.  Unfortunately you need the 'splix' driver which there
doesn't seem to be an Extras package for. :-/
Comment 10 Fedora Update System 2007-01-17 11:27:09 EST
Fixed in update: foomatic-3.0.2-39.4.fc6

Note You need to log in before you can comment on or make changes to this bug.