Bug 195841 - udevd[4821]: add_to_rules: unknown key 'MODALIAS'
udevd[4821]: add_to_rules: unknown key 'MODALIAS'
Status: CLOSED DUPLICATE of bug 195693
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
Reported: 2006-06-18 11:55 EDT by Tom London
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-19 09:29:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tom London 2006-06-18 11:55:09 EDT
Description of problem:
Get messages similar to
     udevd[4821]: add_to_rules: unknown key 'MODALIAS'
on boot console. 

Can't locate them in dmesg or /var/log/messages, though.

Version-Release number of selected component (if applicable):

How reproducible:
every time

Steps to Reproduce:
1. boot
2. look at console
Actual results:

Expected results:

Additional info:
Comment 1 Florian La Roche 2006-06-18 14:06:20 EDT
Setting clock  (localtime): Mon Jun 19 02:06:57 CEST 2006  [  OK  ]
Starting udev: udevd[469]: add_to_rules: unknown key 'MODALIAS'
udevd[469]: add_to_rules: unknown key 'MODALIAS'
udevd[469]: add_to_rules: unknown key 'MODALIAS'
                                                           [  OK  ]
Comment 2 Jesse Keating 2006-06-18 14:24:20 EDT
Not really a Test1 blocker, moving to FC6.
Comment 3 Harald Hoyer 2006-06-19 02:26:41 EDT
Please execute:
$ fgrep -ri MODALIAS /etc/udev/rules.d/
And provide the output here.

Comment 4 Tom London 2006-06-19 09:16:28 EDT
[root@localhost ~]# fgrep -ri MODALIAS /etc/udev/rules.d/
/etc/udev/rules.d/50-udev.rules:ACTION=="add", SUBSYSTEM=="?*",
ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
/etc/udev/rules.d/50-udev.rules:ACTION=="add", SUBSYSTEM=="pcmcia",
ENV{MODALIAS}=="?*", RUN+="/bin/sh -c 'echo 1 > /sys/$DEVPATH/allow_func_id_match'"
/etc/udev/rules.d/60-pcmcia.rules:# modprobe $modalias loads all possibly
appropriate modules
/etc/udev/rules.d/60-pcmcia.rules:ACTION=="add", SUBSYSTEM=="pcmcia",
MODALIAS=="?*", \
/etc/udev/rules.d/60-pcmcia.rules:              RUN+="/sbin/modprobe $modalias"
/etc/udev/rules.d/60-pcmcia.rules:ACTION=="add", SUBSYSTEM=="pcmcia",
MODALIAS=="?*", \
/etc/udev/rules.d/60-pcmcia.rules:ACTION=="add", SUBSYSTEM=="pcmcia",
MODALIAS=="?*", \
[root@localhost ~]#
Comment 5 Harald Hoyer 2006-06-19 09:29:44 EDT

*** This bug has been marked as a duplicate of 195693 ***

Note You need to log in before you can comment on or make changes to this bug.