Bug 195854 - Display blocked by "rss-glx-gnome-screensaver" II
Summary: Display blocked by "rss-glx-gnome-screensaver" II
Status: CLOSED DUPLICATE of bug 195851
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-18 20:22 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-04 12:59:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2006-06-18 20:22:10 UTC
Description of problem:
After choosing one of the "rss-glx" modules in the "gnome-screensaver"
preferences and locking the screen, it is impossible to quit the
screensaver gracefully. The unlock dialog pops up, but after entering
the password, the screen turns black and the system just sits there
without responding to user interaction. It is necessary to kill the
corresponding process from a virtual console to unlock the screen.

Version-Release number of selected component (if applicable):
rss-glx-gnome-screensaver-0.8.1.p-3.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Open "gnome-screensaver" preferences.
2. Choose an "rss-glx" module.
3. Lock the screen.
  
Actual results:
The screensaver sets in correctly with enabled direct rendering. After
entering the password to unlock the screen, nothing happens, and the
screensaver does not respond anymore.

Expected results:
The screensaver should unlock the screen.

Additional info:
The same happens, if the screensaver sets in after the given time
interval, and it was set to lock the screen when active.
However, when the screensaver sets in without locking the screen,
moving the mouse or hitting a key lets it exit gracefully.

Comment 1 Joachim Frieben 2006-06-24 12:36:12 UTC
Seems to be driver issue ("xorg-x11-drv-savage") since on my desktop
system with a "Radeon 7200" graphics card, everything works correctly.
Assigning to "Fedora Core devel".

Version: "xorg-x11-drv-savage-2.1.1-3"

Comment 2 Nils Philippsen 2006-07-04 12:59:54 UTC

*** This bug has been marked as a duplicate of 195851 ***


Note You need to log in before you can comment on or make changes to this bug.