Bug 195851 - Update Savage driver to fix DRI hang
Update Savage driver to fix DRI hang
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
: 195854 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 16:12 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-03 07:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-06-18 16:12:56 EDT
Description of problem:
Choosing one of the rss-glx modules in the "gnome-screensaver"
preferences and clicking the "Preview" button makes a mouse cursor
appear in front of a white background - no screensaver is visible
though. Hitting a key or clicking the left mouse button has no effect.
The screen is actually blocked.

Version-Release number of selected component (if applicable):
rss-glx-gnome-screensaver-0.8.1.p-3.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Open "gnome-screensaver" preferences.
2. Choose an "rss-glx" module.
3. Click "Preview" button.
  
Actual results:
Screen turns white. It is possible to move the mouse cursor but it's
impossible to exit the preview mode gracefully.

Expected results:
Screensaver should set in and exit upon mouse click or keystroke.

Additional info:
The screensaver module correctly renders the small preview window in
the preferences window but not full-screen.
Comment 1 Joachim Frieben 2006-06-24 08:33:39 EDT
Seems to be driver issue ("xorg-x11-drv-savage") since on my desktop
system with a "Radeon 7200" graphics card, everything works correctly.
Comment 2 Nils Philippsen 2006-07-04 09:00:06 EDT
*** Bug 195854 has been marked as a duplicate of this bug. ***
Comment 3 Joachim Frieben 2006-07-06 14:35:00 EDT
After commenting out 'Load  "dri"' in "xorg.conf" and restarting the
"X" server, the screensaver behaves correctly. Moreover, "glxgears",
which otherwise only displays a black window, works again, albeit at
an (expected) slow frame rate.
Comment 4 Nils Philippsen 2006-07-06 15:42:25 EDT
glxgears displaying a black window with DRI enabled is a good indicator for a
problem in the driver (IMO).
Comment 5 Joachim Frieben 2006-07-06 16:55:26 EDT
I had also posted bug #196011 which might be of potential interest and which
is related to an issue with "xscreensaver-gl-extras".
Comment 6 Joachim Frieben 2006-09-18 12:25:30 EDT
I have submitted a patch derived from A. Deucher's suggestion at:

  https://bugs.freedesktop.org/show_bug.cgi?id=6357 .

The Fedora patch can be found here:

  https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=136548 .

It fixes both bug 196011 and bug 195851.
Comment 7 Joachim Frieben 2006-09-19 09:30:51 EDT
According to the author of the patch, it has been committed upstream:

  https://bugs.freedesktop.org/show_bug.cgi?id=6357#c30
Comment 8 Adam Jackson 2006-09-20 17:53:57 EDT
Updating summary to remind me to take care of this.
Comment 9 Joachim Frieben 2006-09-21 08:56:43 EDT
Caveat: I have rebuilt the "xorg-x11-drv-savage" package again, this
time using a pristine copy of the current "git" tree of the "savage"
driver, including the "DRI locking" fix and it turns out that direct
rendering is not working anymore. "env LIBGL_DEBUG=verbose glxgears"
now reports:

  ... libGL error: drmMap of framebuffer failed (Invalid argument)
      libGL error: reverting to (slow) indirect rendering ...

So, the task is possibly not as straightforward as one might have thought.
Comment 10 Joachim Frieben 2006-09-27 17:26:58 EDT
A rather soonish update of the driver by adding the patch submitted above
would be highly welcome, as it might also be beneficial for users affected
by bug 206710.
Comment 11 Joachim Frieben 2006-12-02 09:18:44 EST
(In reply to comment #9)
After updating the "savage" driver "RPM" to version "2.1.12" from
"Xorg 7.2 RC2" and dropping all patches, one still gets the "drmMap"
error message from comment #9. Btw, "Xorg.0.log" has a:

   (II) SAVAGE(0): Direct rendering enabled

so it's rather a "GL" problem. Reverting to "2.1.11" plus A. Deucher's
"DRI" patch from comment #6.
Comment 12 Joachim Frieben 2006-12-08 08:50:27 EST
The "drmMap" issue of the 2.1.2 driver release has already been reported
upstream, see: https://bugs.freedesktop.org/show_bug.cgi?id=8800
Comment 13 Joachim Frieben 2007-01-14 07:46:08 EST
The current "rawhide" kernel "2.6.19-1.2911.fc7" still does not have
the upstream "DRM" version required to make the "2.1.2" driver of
"Xorg 7.2 RC3" work.
This suggests to fix settle the issue preliminary according to the
procedure outlined in comment #6. The inclusion of the relevant patch
[level "easy fix"] has been pending for almost 4 months now (!).
Comment 14 Joachim Frieben 2007-02-03 06:03:30 EST
The failure reported in comment #9 still applies to the combination of
"kernel-2.6.19-1.2917.fc7" and "xorg-x11-drv-savage-2.1.2-1.fc7".
Comment 15 Joachim Frieben 2007-02-17 10:08:30 EST
The failure reported in comment #9 still applies to the combination of
"kernel-2.6.20-1.2932.fc7" and "xorg-x11-drv-savage-2.1.2-2.fc7".
Comment 16 Joachim Frieben 2007-04-03 07:13:17 EDT
This bug is probably no valid anymore: nowadays, it only affects "FC6"
[see bug 229979], since the "devel" tree has moved to "Xorg 7.2" and
"savage" driver version 2.1.2 which already includes the patch mentioned
above.
Hardware rendering does not work at all anymore due to a mismatch between
the current kernel "DRM" and the one required by the 2.1.2 driver, but
this is a kernel issue that I have reported upstream at:

  http://bugzilla.kernel.org/show_bug.cgi?id=7767 .

Therefore closing this bug for "Fedora development".
Comment 17 Joachim Frieben 2007-06-02 06:48:11 EDT
Direct rendering for driver version 2.1.2 finally working correctly with
kernel version "2.6.21-1.3199.fc8".

Note You need to log in before you can comment on or make changes to this bug.