RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1959874 - Rebase rpm-ostree to latest upstream release 2021.5 (includes fixes for libsolv 0.7.17 using %_dbpath)
Summary: Rebase rpm-ostree to latest upstream release 2021.5 (includes fixes for libso...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rpm-ostree
Version: 8.5
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: pre-dev-freeze
: 8.5
Assignee: Luca BRUNO
QA Contact: Micah Abbott
URL:
Whiteboard:
: 1959907 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-12 13:52 UTC by Xiaofeng Wang
Modified: 2021-11-10 01:14 UTC (History)
10 users (show)

Fixed In Version: rpm-ostree-2021.5-1.el8
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
New release, see https://github.com/coreos/rpm-ostree/releases/tag/v2021.5.
Clone Of:
Environment:
Last Closed: 2021-11-09 18:46:52 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1894573 1 high CLOSED Rebase libmodulemd to >= 2.12.0 2023-06-26 11:43:44 UTC
Red Hat Bugzilla 1951405 1 high CLOSED Rebase libsolv to >= 0.7.17 2023-06-26 10:31:48 UTC
Red Hat Bugzilla 1951407 1 high CLOSED Rebase librepo to >= 1.14.0 2023-09-09 08:25:23 UTC
Red Hat Bugzilla 1961289 1 medium CLOSED Rebase ostree to latest upstream version v2021.2 2023-03-26 07:31:31 UTC
Red Hat Bugzilla 1964906 1 unspecified CLOSED Rebase rpm to 4.16.x (or backport rpmver logic from PR#1221), please? 2021-09-14 11:48:31 UTC
Red Hat Product Errata RHBA-2021:4272 0 None None None 2021-11-09 18:46:54 UTC

Description Xiaofeng Wang 2021-05-12 13:52:06 UTC
Description of problem:
Install a rpm package failed with "rpm-ostree install http://file-server-virt-qe-3rd.apps.ocp4.prod.psi.redhat.com/greenboot-failing-unit-1.0-1.el8.noarch.rpm".
Error log: "error: Sanity-checking final rpmdb: Didn't find package 'greenboot-failing-unit-1.0-1.el8.noarch"

This issue looks the same as issue https://github.com/coreos/rpm-ostree/pull/2490
Why does this issue only happen on RHEL 8.5 and not on RHEL 8.4?
RHEL 8.5 uses libsolv-0.7.17-2 which includes "check %_dbpath macro in rpmdb code" fix(https://src.osci.redhat.com/rpms/libsolv/blob/rhel-8.5.0/f/libsolv.spec), but RHEL 8.4 uses libsolv-0.7.16 which does not include that fix.

And "check %_dbpath macro in rpmdb code" fix in libsolv-0.7.17-2 needs rpm-ostree fix "core: Set _dbpath back to /usr/share/rpm after writing rpmdb" which is not included in rpm-ostree-2020.7 which is used by RHEL 8.5.

Version-Release number of selected component (if applicable):

libsolv-0.7.17-2.el8.x86_64

ostree-libs-2020.7-4.el8.x86_64
rpm-ostree-2020.7-4.el8.x86_64
ostree-2020.7-4.el8.x86_64
rpm-ostree-libs-2020.7-4.el8.x86_64


How reproducible:

Steps to Reproduce:
1. build or install an ostree like system
2. run "sudo rpm-ostree install http://file-server-virt-qe-3rd.apps.ocp4.prod.psi.redhat.com/greenboot-failing-unit-1.0-1.el8.noarch.rpm"

Actual results:
Should install rpm without error, like:

Downloading 'http://file-server-virt-qe-3rd.apps.ocp4.prod.psi.redhat.com/greenboot-failing-unit-1.0-1.el8.noarch.rpm'... done!
Checking out tree ca6875c... done
No enabled rpm-md repositories.
Importing rpm-md... done
Resolving dependencies... done
Checking out packages... done
Running pre scripts... done
Running post scripts... done
Running posttrans scripts... done
Writing rpmdb... done
Writing OSTree commit... done
Staging deployment... done
Added:
  greenboot-failing-unit-1.0-1.el8.noarch
Run "systemctl reboot" to start a reboot

Expected results:
Downloading 'http://file-server-virt-qe-3rd.apps.ocp4.prod.psi.redhat.com/greenboot-failing-unit-1.0-1.el8.noarch.rpm'... done!
Checking out tree 0cca2fd... done
No enabled rpm-md repositories.
Importing rpm-md... done
Resolving dependencies... done
Checking out packages... done
Running pre scripts... done
Running post scripts... done
Running posttrans scripts... done
Writing rpmdb... done
error: Sanity-checking final rpmdb: Didn't find package 'greenboot-failing-unit-1.0-1.el8.noarch'

Additional info:

Comment 1 Jonathan Lebon 2021-05-12 15:49:25 UTC
Yeah, I think we need to backport both https://github.com/coreos/rpm-ostree/pull/2490 and https://github.com/coreos/rpm-ostree/pull/2553.

Comment 2 Jonathan Lebon 2021-05-12 15:49:58 UTC
*** Bug 1959907 has been marked as a duplicate of this bug. ***

Comment 3 Jonathan Lebon 2021-05-12 15:56:33 UTC
It looks like we're unblocked on the libmodulemd front (https://bugzilla.redhat.com/show_bug.cgi?id=1894573), so we should be able to rebase.

Comment 6 Luca BRUNO 2021-05-26 08:44:03 UTC
This rebase needs the following library updates to land in 8.5 first:
 * libmodulemd >= 2.11.2-2 (2.12.1-1 done in https://bugzilla.redhat.com/show_bug.cgi?id=1894573)
 * librepo >= 1.13.0 (1.14.0-1 in progress at https://bugzilla.redhat.com/show_bug.cgi?id=1951407)
 * libsolv >= 0.7.17 (0.7.17-2 done in https://bugzilla.redhat.com/show_bug.cgi?id=1951405)
 * ostree >= 2020.7 (2021.2 done in https://bugzilla.redhat.com/show_bug.cgi?id=1961289)

Once librepo is done too, I think this should be able to proceed too.

Comment 7 Luca BRUNO 2021-05-26 10:29:35 UTC
One more obstacle for this rebase is that it needs newer librpm API too, asked about that at https://bugzilla.redhat.com/show_bug.cgi?id=1964906.

Comment 21 Luca BRUNO 2021-06-18 08:25:39 UTC
The followup bug for osbuild is related to _dbpath location handling in `rpm-ostree compose commit`, tracked at https://bugzilla.redhat.com/show_bug.cgi?id=1973579.

Comment 22 Xiaofeng Wang 2021-06-21 13:59:36 UTC
Verified on rpm-ostree-2021.5-2.el8.x86_64 and rpm-ostree-libs-2021.5-2.el8.x86_64.

Comment 26 errata-xmlrpc 2021-11-09 18:46:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (rpm-ostree bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4272


Note You need to log in before you can comment on or make changes to this bug.