Bug 196063 - All GTK applications crash with accessibility enabled (AMD64)
All GTK applications crash with accessibility enabled (AMD64)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
: Regression, Reopened
: 193909 (view as bug list)
Depends On:
Blocks: 169147 FC5Update
  Show dependency treegraph
 
Reported: 2006-06-20 14:26 EDT by Chris Lee
Modified: 2008-02-05 13:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 13:05:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eog backtrace (1.51 KB, text/plain)
2006-06-20 14:30 EDT, Chris Lee
no flags Details
eog memory map (30.81 KB, text/plain)
2006-06-20 14:35 EDT, Chris Lee
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 337239 None None None Never

  None (edit)
Description Chris Lee 2006-06-20 14:26:31 EDT
Version-Release number of selected component (if applicable): 
glib2-2.10.3-1.x86_64
gtk2-2.8.18-1.x86_64

How reproducible: Always


Steps to Reproduce:
1. Turn on accessibility (gconftool-2 --set --type bool
/desktop/gnome/interface/accessibility true)
2. Launch a GTK-based application (metacity, evince, eog)
3. Watch the app dump its memory map on the console and freeze.

Additional info:
This did not happen with the packages included in the FC5 release - it only
started happening after I updated to the latest available packages as of
yesterday afternoon.
Comment 1 Chris Lee 2006-06-20 14:30:21 EDT
Created attachment 131210 [details]
eog backtrace

This is a backtrace from eog when I launch it with accessibility turned on.
Comment 2 Chris Lee 2006-06-20 14:35:57 EDT
Created attachment 131211 [details]
eog memory map

This is the memory map dumped to the console when eog crashes. I get similar
dumps from every other GTK program. (If any other program's backtraces or
memory maps are required, I can provide them.)
Comment 3 Zack Cerza 2006-06-20 15:02:50 EDT
You know what? Yesterday I noticed that I couldn't log in with a11y enabled on
my x86_64 workstation. Couldn't find any useful information in logs. Maybe this
is why... :)
Comment 4 Matthias Clasen 2006-06-20 15:09:23 EDT
I spent a week trying to track this down prior to fc5 and gave up. It is filed
upstream, but I have not seen any action on the bug.
Comment 5 Zack Cerza 2006-06-20 15:22:07 EDT
Matthias, can you add a reference to the upstream bug to this one?
Comment 6 Chris Lee 2006-07-21 15:17:02 EDT
Noting, as zcerza asked me to, that this is in fact a regression from the
packages that shipped in FC5-release.
Comment 7 Zack Cerza 2006-07-21 17:01:54 EDT
I went and found the upstream bug.
Comment 8 Matthias Clasen 2006-07-27 22:45:08 EDT
I think we either need to track this down or revert the memleak fix that 
introduced it.
Comment 9 Alexander Larsson 2006-07-28 16:13:25 EDT
Fixed in at-spi-1.7.9-3.
Comment 10 Matthias Clasen 2006-08-01 23:11:02 EDT
Unfortunately, the fix leads to other crashes
Comment 11 Tim Reilly 2006-08-04 14:43:55 EDT
*** Bug 193909 has been marked as a duplicate of this bug. ***
Comment 12 Matthias Clasen 2006-08-05 13:31:10 EDT
I haven't seen a11y-related crashes with the latest version of at-spi, so maybe
this is fixed after all. 
Comment 13 Ray Strode [halfline] 2006-08-10 18:06:49 EDT
I played around with things on the box in the megacube and i'm not seeing any
crashes.  I'm going to close this for now.  We can open a new bug if problems
pop up.
Comment 14 Zack Cerza 2006-08-10 18:14:18 EDT
The megacube box is running RHEL5 beta. I'm glad the bug is fixed there, but
this bug was reported against FC5, and to my knowledge it hasn't been fixed
there. Reopening.
Comment 15 Ray Strode [halfline] 2006-08-10 18:20:19 EDT
Moving off FC6Blocker list...
Comment 16 Matthias Clasen 2008-02-05 13:05:02 EST
Finally closing this. FC5 is no longer supported, and the bug is fixed in newer
releases, I believe.

Note You need to log in before you can comment on or make changes to this bug.