This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 196102 - Fetching Exchange email breaks after initial success
Fetching Exchange email breaks after initial success
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 204802 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-20 22:12 EDT by Steffen Kluge
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: evolution-connector-2.6.3-2.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 11:17:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
SRPM with patch applied (984.61 KB, application/x-redhat-package-manager)
2006-08-31 14:14 EDT, Per Nystrom
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 349413 None None None Never

  None (edit)
Description Steffen Kluge 2006-06-20 22:12:16 EDT
Description of problem:

When evolution is started, the Exchange folders are scanned, available messages
are displayed in the message list pane, and can be read or moved to local folders.

After a while (less than 10 minutes I'd say), this breaks. New messages are
still being indicated (counted up) in the folder pane, but upon selecting the
Inbox folder under the Exchange account the message list pane remains empty, and
no Exchange email can be accessed.

Quitting and restarting evolution makes those new message available, but after a
short while the problem re-occurs.

Version-Release number of selected component (if applicable):

evolution-webcal-2.4.1-3.4
evolution-2.6.2-1.fc5.5
evolution-connector-2.6.2-1.fc5.4
evolution-data-server-1.6.2-1.fc5.1

How reproducible:
As described above.

Steps to Reproduce:
1. Start evolution, fetch all available Exchange email
2. Wait a while
3. New Exchange mail is indicated but not accessible


Additional info:

This problem first occured after the upgrade to version 2.6.2-1 and associated.

Probably related:
When the Inbox problem occurs, the Deleted Messages folder under the Exchange
account is affected as follows: I can expunge the folder, and get a progress
indication in the status bar, but the message list remains unchanged (instead of
being cleared). After restarting evolution the message list for the Deleted
Messages folder is empty and shows that the expunge action did in fact succeed.

When the problem occurs, sending mail via Exchange as well as Exchange Calendar,
Contacts and GAL keep working, i.e. the Exchange Connector isn't dead.
Comment 1 Frank Pineau 2006-07-05 18:06:49 EDT
Seeing the exact same problem here, under x86-64.  Can't downgrade to 2.6.1 due
to dependencies.
Comment 2 Steffen Kluge 2006-07-05 21:10:15 EDT
On my systems (all i386) the only dependency that has to be downgraded along
with evolution is gnome-panel(-devel). No big deal. I seem to remember that some
other packages depend on evolution (e.g. beagle via evolution-sharp) but I'm not
using those.
Comment 3 Frank Pineau 2006-07-05 21:42:16 EDT
******
[frank@hortense tmp]$ sudo yum localinstall
evolution-connector-2.6.1-1.fc5.1.x86_64.rpm
**SNIP**

Error: Missing Dependency: libedata-cal-1.2.so.1()(64bit) is needed by package
evolution-connector
Error: Missing Dependency: libecal-1.2.so.3()(64bit) is needed by package
evolution-connector

[frank@hortense ~]$ locate libedata-cal
/usr/lib64/libedata-cal-1.2.so.5
/usr/lib64/libedata-cal-1.2.so.5.0.0
[frank@hortense ~]$ locate libecal
/usr/lib64/libecal-1.2.so.6
/usr/lib64/libecal-1.2.so.6.0.0

[frank@hortense ~]$ sudo yum whatprovides libecal
**SNIP**
evolution-data-server.x86_64             1.6.2-1.fc5.1          updates
Matched from:
/usr/lib64/libecal-1.2.so.6
/usr/lib64/libecal-1.2.so.6.0.0

[frank@hortense ~]$ sudo yum deplist evolution-data-server
package: evolution-data-server.x86_64 1.5.92-1
  dependency: libcairo.so.2()(64bit)
   provider: cairo.x86_64 1.0.2-5
   provider: cairo.x86_64 1.0.4-1
  dependency: libldap-2.3.so.0()(64bit)
   provider: openldap.x86_64 2.3.19-4
  dependency: libORBit-2.so.0()(64bit)
ETC. ETC. ETC.
********

Both seem to be provided by evolution-data-server, but at a rev below the
evolution-data-server I have installed, which means I'd also have to downgrade
that, which means downgrading about a hundred other packages.  I don't want to
get into a downgrade spiral just to downgrade this one package.  Guess that's
why they call it "dependancy hell", eh? :)
Comment 4 Steffen Kluge 2006-07-05 22:51:20 EDT
Here's what I did:
Downloaded the previous versions from the update repo, then

rpm -Uvh --oldversion evolution-2.6.1-1.fc5.2.i386.rpm \
                      evolution-connector-2.6.1-1.fc5.1.i386.rpm \
                      evolution-data-server-1.6.1-1.fc5.2.i386.rpm \
                      gnome-panel-2.14.1-1.fc5.1.i386.rpm \
                      gnome-panel-devel-2.14.1-1.fc5.1.i386.rpm

That took care of it.
Comment 5 Jeffrey C. Ollie 2006-08-09 10:24:23 EDT
I'm seeing the same with the new 2.6.3-1.fc5.1 from FC5 updates-testing.
Comment 6 Bevis King 2006-08-10 05:26:10 EDT
FYI - there is a patch available in this bug report on the GNOME bugzilla that
fixes this bug (at least for me it does):

http://bugzilla.gnome.org/show_bug.cgi?id=349413
Comment 7 Matthew Barnes 2006-08-10 15:17:04 EDT
I'll commit this right away for Rawhide, but I'm going to wait for upstream to
release 2.6.4 before sending it to Fedora Updates.
Comment 8 Jeffrey C. Ollie 2006-08-10 18:10:09 EDT
I recompiled the evolution-connector RPM with the patch added and it'd working
great!
Comment 9 Matthew Barnes 2006-08-10 18:59:30 EDT
Correction to my previous statement:

It looks like the patch already made it into 2.7.91.
So Rawhide users should have this already.
Comment 10 Frank Pineau 2006-08-23 10:28:11 EDT
Any chance this is going to make it into FC5-Updates?
Comment 11 Matthew Barnes 2006-08-23 10:38:58 EDT
(In reply to comment #10)

Once evolution-2.6.4 is released.
Comment 12 Matthew Barnes 2006-08-31 13:32:05 EDT
*** Bug 204802 has been marked as a duplicate of this bug. ***
Comment 13 Per Nystrom 2006-08-31 14:14:01 EDT
Created attachment 135315 [details]
SRPM with patch applied

This is the SRPM evolution-connector-2.6.3 with the patch at
http://bugzilla.gnome.org/attachment.cgi?id=70622&action=view applied.	I don't
want to wait for 2.6.4, and besides, I fear what other bugs might be lurking
there.
Comment 14 Need Real Name 2006-09-11 16:48:58 EDT
I would really appreciate a fix for this, using the patch from
http://bugzilla.gnome.org/attachment.cgi?id=70622&action=view

It's a bit embarassing preaching Linux, only to have to restart my mail client
every five minutes to read "that e-mail I sent you".
Comment 15 Bevis King 2006-09-12 05:56:39 EDT
See comment #6 - there is a fully working patch to solve this problem.  If
you're having a problem compiling it, I can provide a ready-built RPM for x86_64
machines on request.

Regards, Bevis.
Comment 16 Per Nystrom 2006-09-12 10:38:25 EDT
Or use my attached SRPM, it has the patch.
Comment 17 Need Real Name 2006-09-12 12:51:57 EDT
Thanks very much, I will.
Part of the motivation for adding the comment was to get the bug fixed for
non-commenters :)
Comment 18 Matthew Barnes 2006-09-20 16:01:11 EDT
Upstream has indicated that there are no more 2.6 releases planned for
evolution, so I've pushed the patch into FC5-Test-Updates.

Please try evolution-connector-2.6.3-2.fc5.
Comment 19 Steffen Kluge 2006-09-22 00:29:11 EDT
Thanks very much! Evolution-connector-2.6.3-2, in conjunction with
evolution-2.6.3-1, works well. Problem solved.

Cheers
Steffen.
Comment 20 Need Real Name 2006-09-22 03:09:12 EDT
WFM too. If you asked me to report any oddities, I'd say the mail was delayed a
bit, but I expect this is normal. Thanks!
Comment 21 Need Real Name 2006-09-22 03:20:48 EDT
The delay is ~four minutes.
Comment 22 Matthew Barnes 2007-01-02 11:17:28 EST
Closing per comment #19 and comment #20.  Feel free to re-open this bug report
if you encounter the same problem in Fedora Core 6 or later.

Note You need to log in before you can comment on or make changes to this bug.