Bug 196275 - system-settings.menu file vs. applications-merged dir
system-settings.menu file vs. applications-merged dir
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
bzcl34nup
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2006-06-22 08:07 EDT by Ariszló
Modified: 2008-04-04 07:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 07:17:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample Menu Entry with Categories=Music (100 bytes, text/plain)
2006-06-22 08:07 EDT, Ariszló
no flags Details
patch to remove harmful code from MergeFiles (1012 bytes, patch)
2006-06-26 09:21 EDT, Ariszló
no flags Details | Diff

  None (edit)
Description Ariszló 2006-06-22 08:07:25 EDT
Description of problem:

Both the system-settings.menu of redhat-menus-6.7.5-1 and the
kde-applications.menu of kdelibs-3.5.1-2.3 contain this line

<DefaultMergeDirs/>

which may duplicate menu entries in K Menu.

Details

If you install kdemultimedia then you will have the following config file:

/etc/xdg/menus/applications-merged/kde-multimedia-music.menu

Say you also install a multimedia application with the following menu entry file:

##### /usr/share/applications/sample-menu-entry.desktop begins here
[Desktop Entry]
Name=Sample Menu Entry
Exec=konqueror
Type=Application
Categories=AudioVideo;Music;

##### /usr/share/applications/sample-menu-entry.desktop ends here (with a blank
line at the end)

Now, "Sample Menu Entry" will be listed in both Multimedia-Music and
Administration-Multimedia-Music.

The more submenus a package adds to the K Menu, the messier the Administration
menu becomes.

Version-Release number of selected component (if applicable): 6.7.5

How reproducible:

Easily reproducible. Just install kdemultimedia and copy
sample-menu-entry.desktop into /usr/share/applications/

Steps to Reproduce:
1. Install kdemultimedia to get the
/etc/xdg/menus/applications-merged/kde-multimedia-music.menu config file
2. Copy sample-menu-entry.desktop into /usr/share/applications/
  
Actual results:

"Sample Menu Entry" will be listed in both Multimedia-Music and
Administration-Multimedia-Music in K Menu.

Expected results:

It should only be listed in Multimedia-Music. Please remove the harmful
"<DefaultMergeDirs/>" line from system-settings.menu (and all other merge
files). Keep it only in kde-applications.menu (and applications.menu if necessary).

Additional info:
Comment 1 Ariszló 2006-06-22 08:07:25 EDT
Created attachment 131347 [details]
Sample Menu Entry with Categories=Music
Comment 2 Ariszló 2006-06-26 09:21:01 EDT
Created attachment 131541 [details]
patch to remove harmful code from MergeFiles
Comment 3 Ariszló 2006-10-28 10:55:29 EDT
Bug persists in redhat-menus-6.7.5-3 of Fedora Core 6. Is there anybody still
maintaining redhat-menus?
Comment 4 Ivan Mitev 2006-11-01 03:41:03 EST
same problem, but the content of the submenu added in applications-shared
appears in both administration and in administration/server settings

that's quite annoying since we plan to do a mass deployment on 200+ machines,
and we'd rather not patch manually /etc/xdg/* and have these settings erased on
next redhat-menus rpm upgrade

btw, there are also some references to "applications.d" in the comments, which i
guess should be "applications-merged"

maybe rsrode@redhat doesn't work on that anymore, so if there's no reply we'll
try to contact someone from the redhat-menus' rpm changelog
Comment 5 Ray Strode [halfline] 2007-04-03 17:53:12 EDT
adding to FC7Target
Comment 6 Ray Strode [halfline] 2007-04-18 14:01:22 EDT
This seems like it would be a kde problem.

The spec says that <DefaultMergeDirs> is relative to the name of the file specified.

See the "File Locations" section of
http://standards.freedesktop.org/menu-spec/menu-spec-1.0.html
Comment 7 Ariszló 2007-04-18 18:07:23 EDT
I agree. Nevertheless, I cannot see why the <DefaultMergeDirs/> tags need be
included in the merge files in redhat-menus. All they do is show that KDE is
buggy. They are not used in GNOME because GNOME simply does not merge in any
information from any of the *-merged directories so they are not needed for
GNOME at all. If interpreted correctly, they would point to directories like
system-settings-merged, which either do not exist in Fedora or are just plain empty.

To summarize, the <DefaultMergeDirs/> tags in the merge files are not used by
GNOME, so they can be safely removed. They are only useful in debugging KDE,
which is probably not the main task of the redhat-menus package.
Comment 8 Ray Strode [halfline] 2007-04-18 18:10:01 EDT
They are used by 3rd party packages to customize the menu layout.  We've had to
move them around before to accomodate that.
Comment 9 Bug Zapper 2008-04-03 13:30:04 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 10 Ariszló 2008-04-04 01:16:54 EDT
Solved in KDE4.  See Bug 439378.

Note You need to log in before you can comment on or make changes to this bug.