Bug 196356 - Can't locate utils.pm when running perl plugins
Summary: Can't locate utils.pm when running perl plugins
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nagios-plugins (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike McGrath
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 199890 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-22 18:18 UTC by David Rees
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1.4.3-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 18:28:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Rees 2006-06-22 18:18:39 UTC
Description of problem:
Perl plugins generate the following error when trying to run them, for example,
check_breeze:
Can't locate utils.pm in @INC (@INC contains: nagios/plugins
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8) at ./check_breeze line 8.
BEGIN failed--compilation aborted at ./check_breeze line 8.

Version-Release number of selected component (if applicable):
nagios-plugins-1.4.3-9.fc5

How reproducible:
Every time.

Steps to Reproduce:
1. Install and run the plugin from one of the following RPMs: 
nagios-plugins-breeze-1.4.3-9.fc5
nagios-plugins-disk_smb-1.4.3-9.fc5
nagios-plugins-file_age-1.4.3-9.fc5
nagios-plugins-flexlm-1.4.3-9.fc5
nagios-plugins-ifoperstatus-1.4.3-9.fc5
nagios-plugins-ifstatus-1.4.3-9.fc5
nagios-plugins-ircd-1.4.3-9.fc5
nagios-plugins-ntp-1.4.3-9.fc5
nagios-plugins-rpc-1.4.3-9.fc5
nagios-plugins-wave-1.4.3-9.fc5

Additional info:
The problem seems to be that /usr/lib/nagios/plugins/utils.pm isn't also
installed into one of the path's listed in the error message, for example
/usr/lib/perl5/vendor_perl/5.8.8/utils.pm though I am not sure if that is the
ideal/correct location for it. Copying utils.pm there does let the affected
plugins run.

Comment 1 Mike McGrath 2006-07-24 02:18:19 UTC
*** Bug 199890 has been marked as a duplicate of this bug. ***

Comment 2 Mike McGrath 2006-07-24 02:38:09 UTC
nagios-plugins-1_4_3-14 has been built and should be available to the mirrors in
the next day or two.  Please check it and verify that this solves your errors. 
If it does or doesn't let me know.

Comment 3 David Rees 2006-07-27 18:27:41 UTC
It appears to fix the problem, thanks!

Comment 4 Mike McGrath 2006-07-27 18:28:49 UTC
Awesome.


Note You need to log in before you can comment on or make changes to this bug.