Bug 199890 - Wrong libpath in perl based plugins
Wrong libpath in perl based plugins
Status: CLOSED DUPLICATE of bug 196356
Product: Fedora
Classification: Fedora
Component: nagios-plugins (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-23 21:59 EDT by Roy-Magne Mo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-23 22:18:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to remove some unneeded functionality (666 bytes, patch)
2006-07-23 21:59 EDT, Roy-Magne Mo
no flags Details | Diff

  None (edit)
Description Roy-Magne Mo 2006-07-23 21:59:10 EDT
Description of problem:
The script subst, which is a awk script, messes up just substitued lib path

Version-Release number of selected component (if applicable):
nagios-plugins-1.4.3-12.fc5

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
the full path in seems to be cut short

Expected results:
to see the full path to the directory where utils.pm is

Additional info:
You'll find that debian has a similar approach at
http://lists.alioth.debian.org/pipermail/pkg-nagios-devel/2005-September/001035.html
Comment 1 Roy-Magne Mo 2006-07-23 21:59:10 EDT
Created attachment 132893 [details]
patch to remove some unneeded functionality
Comment 2 Mike McGrath 2006-07-23 22:06:24 EDT
I'm not quite following what the issue is.  Are Nagios plugins failing or
returning bad results as a result of this?  If so which scripts?  
Comment 3 Roy-Magne Mo 2006-07-23 22:13:26 EDT
If you for example look at the subpackage nagios-plugins-breeze, you'll find a
"use lib" line like this:
use lib "nagios/plugins" ;

For embperl to function, you'll have to have a complete path to the directory
where utils.pm is kept, which is /usr/lib/nagios/plugins (at least on 32 bit
systems). This correct replacement is supposed to happen in the subst
awk-script, but the part I commented out seems to mess things up.

The way it is now, the perl script can't compile because it can't find utils.pm
Comment 4 Mike McGrath 2006-07-23 22:18:06 EDT
Got'cha.  This has been reported but not yet fixed.  Please see but #196356 for
more information.  I'm hoping to fix this very soon.  Thanks for reporting it.

*** This bug has been marked as a duplicate of 196356 ***

Note You need to log in before you can comment on or make changes to this bug.