Bug 19646 - Enhancement: avoid percentage info in log files
Summary: Enhancement: avoid percentage info in log files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
: 25223 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-24 00:10 UTC by Need Real Name
Modified: 2015-01-07 23:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 20:49:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-24 00:10:35 UTC
This is a request for a minor enhancement.

Since I can't at the moment use up2date as normally intended
(see bug 19069, update agent fatal error), I tried:
    update -l >file.log
so I could get a list of packages to update.

The percentage done info that is normally output over and over
to the same line on the console is in the file.
It would be good to suppress the percentage done information
when appropriate and where it would not
interfere with the gui's display of percentage
done (e.g., if output is not a tty).

Also, as another nit to pick, package names are displayed with version
and release numbers in separate columns.  It would be nice if there
was an option to display the package file names to make it easier  to
retrieve them by other methods.

Comment 1 Cristian Gafton 2001-02-20 01:32:59 UTC
Assigned QA to jturner

Comment 2 Preston Brown 2001-02-26 23:40:21 UTC
*** Bug 25223 has been marked as a duplicate of this bug. ***

Comment 3 Preston Brown 2001-03-01 20:48:57 UTC
fixed in CVS.

Comment 4 Jay Turner 2001-03-02 16:09:21 UTC
Confirmed resolved in the 3/2/01 CVS code.

Comment 5 Jay Turner 2001-03-02 16:14:13 UTC
Confirmed resolved in the 3/2/01 CVS code.


Note You need to log in before you can comment on or make changes to this bug.