Bug 196511 - Immediate segfault
Immediate segfault
Status: CLOSED DUPLICATE of bug 203725
Product: Fedora
Classification: Fedora
Component: scorched3d (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-23 16:27 EDT by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-23 14:00:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (2.18 KB, application/octet-stream)
2006-08-15 15:15 EDT, Kyrre Ness Sjøbæk
no flags Details
Test program showing bug? (162 bytes, text/plain)
2006-08-23 10:12 EDT, Hans de Goede
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2006-06-23 16:27:07 EDT
Description of problem:
I can't get scorched3d to start at all - it segfaults immediatly.

Version-Release number of selected component (if applicable):
scorched3d-39.1-5.fc5

How reproducible:
Every time

Steps to Reproduce:
1.start scorched3d
2.[kyrre@storeulv ~]$ scorched3d
Minnesegmentsfeil

(Minnesegmentsfeil = segmentation fault)
  
Actual results:
segfaults immediatly

Expected results:
runs

Additional info:
i use the proprietary nvidia driver - but it segfaults before even loading the
menu...
Comment 1 Hans de Goede 2006-06-23 18:03:54 EDT
I cannot reproduce this with a radeon 9200.

Here's what you can do to help:
-edit /etc/yum.repos.d/fedora-extras.repo
-in the [extras-debuginfo] section change enabled to enabled=1
-"yum install scorched3d-debuginfo"
-"gdb `which scorched3d`"
-in gdb type: "run"
-after the crash type "bt"
-if the bt starts in a lib please do a yum install <lib>-debuginfo and
 then start gdb again, run again bt again, etc.


Comment 2 Hans de Goede 2006-08-14 11:12:57 EDT
Closing because of lack of response from submitter.
Comment 3 Kyrre Ness Sjøbæk 2006-08-15 14:47:05 EDT
I somehow missed your reply. sorry. I'll attach a backtrace.
Comment 4 Kyrre Ness Sjøbæk 2006-08-15 15:15:53 EDT
Created attachment 134253 [details]
backtrace
Comment 5 Hans de Goede 2006-08-15 15:21:47 EDT
Hmm, not very helpfull in the mean time 0.40 has been released for FE, maybe
that gives you more luck, please do:
"yum update scorched3d wxGTK"

and then try again.
Comment 6 Kyrre Ness Sjøbæk 2006-08-16 16:24:53 EDT
Hasn't hit my mirror yet. I'll try again tomorrow. I can also try to build from
scratch (source tarball).
Comment 7 Hans de Goede 2006-08-16 16:40:42 EDT
(In reply to comment #6)
> Hasn't hit my mirror yet. I'll try again tomorrow. I can also try to build from
> scratch (source tarball).

Hmm, 0.40 has been released quite some time ago, maybe you already did a yum
update and the backtrace is with 0.40 already?

Comment 8 Kyrre Ness Sjøbæk 2006-08-17 08:32:08 EDT
Looks like it:

scorched3d-40-1.fc5
scorched3d-debuginfo-40-1.fc5
Comment 9 Kyrre Ness Sjøbæk 2006-08-17 11:03:39 EDT
Hmm.. I just installed version 40 from the official site:
http://prdownloads.sourceforge.net/scorched3d/Scorched3D-40-i386.rpm?download

And it worked. So the problem seems to be the fc-extras build.
Comment 10 Hans de Goede 2006-08-18 00:36:23 EDT
(In reply to comment #9)
> Hmm.. I just installed version 40 from the official site:
> http://prdownloads.sourceforge.net/scorched3d/Scorched3D-40-i386.rpm?download
> 
> And it worked. So the problem seems to be the fc-extras build.

That version includes it own copy of wxGTK instead of using the system one, and
sine the traceback points to wxGTK too, I think the problem is wxGTK :)

I'll wip up a small test program whuch uses just to crashing wxGTK function to
see if that also crashes on your system. But that will take some time as I have
a lot of other things todo too.
Comment 11 Kyrre Ness Sjøbæk 2006-08-18 05:23:06 EDT
Thats really great! Ill test it as soon as its ready.

I'll post my versions just to be shure:
[kyrre@storeulv ~]$ rpm -qa | grep wxGTK
compat-wxGTK-common-2.4.2-17.fc5
wxGTK-debuginfo-2.6.3-2.6.3.2.2.fc5
compat-wxGTK-2.4.2-17.fc5
wxGTK-2.6.3-2.6.3.2.2.fc5
Comment 12 Hans de Goede 2006-08-23 10:12:43 EDT
Created attachment 134713 [details]
Test program showing bug?

I've just written a small test program, compile it with:
g++ -o main main.c `wx-config --libs --cflags`

And then run: "./main"

For me the output is:
wxusername: H

While the output should be:
wxusername: Hans de Goede

So I think that I'm right on my hunch that the crash is not a scorched3d bug
but  a wxwindows bug. Because the above behaviour is obviously wrong. Please
let me know how this works for you.


The wrong above behaviour has been filed under bug 203725.
Comment 13 Kyrre Ness Sjøbæk 2006-08-23 11:19:58 EDT
Had to install wxGTK-devel (which, for some reason installed wxGTK-gl as a
dep?!? Strange...).

But, it crashed - segfault:
[kyrre@storeulv Desktop]$ g++ -o main main.c `wx-config --libs --cflags`
[kyrre@storeulv Desktop]$ ./main
Minnesegmentsfeil

The debug session looked like this:
(gdb) [kyrre@storeulv Desktop]$ gdb main
GNU gdb Red Hat Linux (6.3.0.0-1.122rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) run
Starting program: /home/kyrre/Desktop/main
Reading symbols from shared object read from target memory...(no debugging
symbols found)...done.
Loaded system supplied DSO at 0x95e000
warning: the debug information found in "/usr/lib/debug//lib/ld-2.4.so.debug"
does not match "/lib/ld-linux.so.2" (CRC mismatch).

(no debugging symbols found)
warning: the debug information found in "/usr/lib/debug//lib/libm-2.4.so.debug"
does not match "/lib/libm.so.6" (CRC mismatch).

warning: the debug information found in
"/usr/lib/debug//lib/libpthread-2.4.so.debug" does not match
"/lib/libpthread.so.0" (CRC mismatch).

[Thread debugging using libthread_db enabled]
[New Thread -1208559920 (LWP 3823)]
warning: the debug information found in "/usr/lib/debug//lib/libc-2.4.so.debug"
does not match "/lib/libc.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//lib/libdl-2.4.so.debug"
does not match "/lib/libdl.so.2" (CRC mismatch).

warning: the debug information found in
"/usr/lib/debug//lib/libnss_files-2.4.so.debug" does not match
"/lib/libnss_files.so.2" (CRC mismatch).


Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208559920 (LWP 3823)]
0x009ebca9 in wcsncpy () from /lib/libc.so.6
(gdb) bt
#0  0x009ebca9 in wcsncpy () from /lib/libc.so.6
#1  0x0443435c in wxGetUserName (buf=0x90ce1dc, sz=1024)
    at ./src/unix/utilsunx.cpp:858
#2  0x044329a7 in wxGetUserName () at ./src/common/utilscmn.cpp:366
#3  0x080486f1 in main ()
(gdb)
Comment 14 Hans de Goede 2006-08-23 14:00:17 EDT
OK, closing this as a dup of 203725 then.
Could you try to edit /etc/passwd and change your name to plain ASCII to see if
that fixes scorched?


*** This bug has been marked as a duplicate of 203725 ***

Note You need to log in before you can comment on or make changes to this bug.