Bug 203725 - wxGetUserName() buggy, causes crashes
wxGetUserName() buggy, causes crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wxGTK (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
:
: 196511 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 10:10 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 22:42:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test program showing bug (162 bytes, text/plain)
2006-08-23 10:10 EDT, Hans de Goede
no flags Details
Patch against wxGTK 2.8.1 to fix the issue (5.38 KB, patch)
2007-03-13 14:04 EDT, İsmail Dönmez
no flags Details | Diff

  None (edit)
Description Hans de Goede 2006-08-23 10:10:50 EDT
Description of problem:

It started with bug 196511, which contains a backtrace of scorched3d crashing
within wxwindows, in the wxGetUserName() method. Since scorched wasn't doing
anything obiously wrong, I decided to write a small wxGetUserName() test program
and give that to the user to see if that would crash too.

I still have to attach this test program to bug 169511 and see what it does for
the reporter, but the test program misfunctions for me too, hence this bug
report. When running the attached program, compiled with:
g++ -o main main.c `wx-config --libs --cflags`

The output is:
wxusername: H

While the output should be:
wxusername: Hans de Goede

So I think that I'm right on my hunch that the crash is not a scorched3d bug but
 a wxwindows bug. Because tjhe above behaviour is obviously wrong.
Comment 1 Hans de Goede 2006-08-23 10:10:52 EDT
Created attachment 134712 [details]
Test program showing bug
Comment 2 Kyrre Ness Sjøbæk 2006-08-23 11:24:26 EDT
The test program crashes on my setup. I have a hunch that it migth be due to
inclusions of international characters in my name - my /etc/passwd line is:

kyrre:x:500:500:Kyrre Ness Sjøbæk:/home/kyrre:/bin/bash

And when using a version of scorch with a staticaly compiled wxGTK, it fails to
display my name in the "options" dialog.
Comment 3 Matthew Miller 2006-08-23 13:45:55 EDT
Thanks for the report -- I'll look into it. Sounds like it's likely to be an
upstream problem, yeah?
Comment 4 Hans de Goede 2006-08-23 14:00:20 EDT
*** Bug 196511 has been marked as a duplicate of this bug. ***
Comment 5 Hans de Goede 2006-08-23 14:02:41 EDT
Yeah this most likely is an upstream problem, that doesnot mean however that we
should immediatly delegate it to upstream. I think we should be able to fix this
ourselves with some C++ knowledge. It would be a good idea to file this
upstream, maybe its already fixed or they can fix it within 2 minutes :)
Comment 6 Matthew Miller 2006-08-28 11:16:42 EDT
I'm really busy and won't have time to look at this until later this week. If
someone else has a pointer to something upstream or a fix of some sort, that'd
be great -- otherwise, it'll be Wednesday or so.
Comment 7 Matthew Miller 2006-11-01 22:58:56 EST
Had baby. Now have 0 time. I'll try to get to this mid-Month, although if
someone has a patch I can maybe find time sooner. Sorry about this. (Well, not
sorry for having the baby.)
Comment 8 Kyrre Ness Sjøbæk 2006-11-03 19:06:10 EST
Congratulations! :) Don't be sorry, at least i can wait :) - and most other
people dont use such funny chars ... Or do they... Hmm... Whatever. However, its
nice to hear :)
Comment 9 Matthew Miller 2007-02-03 10:13:30 EST
So, does this happen with 2.8 in devel?
Comment 10 Vadim Zeitlin 2007-03-11 19:44:53 EDT
This was indeed a bug in wxWidgets and it was fixed as soon as we learnt about
it, see thread at http://article.gmane.org/gmane.comp.lib.wxwidgets.devel/84070.
The fix will first appear in the (soon to be released) 2.8.2 as well as future
2.9 series.
Comment 11 İsmail Dönmez 2007-03-13 14:04:42 EDT
Created attachment 149964 [details]
Patch against wxGTK 2.8.1 to fix the issue
Comment 12 Matthew Miller 2007-03-13 14:33:05 EDT
Awesome, thanks. Will test tomorrow.
Comment 13 Hans de Goede 2007-03-13 14:38:20 EDT
Any chance this can be easily backported to 2.6 for the compat-wxGTK package?

Comment 14 Matthew Miller 2007-04-15 13:39:14 EDT
I'm updating to 2.8.3 in Rawhide, which should include the fix. Sorry for being
slow with this. Leaving this open 'cause I plan to backport to FC6.
Comment 15 Matthew Miller 2007-07-16 12:14:00 EDT
Rawhide and F-7 should be fixed. I'm inclined, at this point, to *not* backport
to FC6....

Note You need to log in before you can comment on or make changes to this bug.