Bug 196522 - yumex update killed png recognition
yumex update killed png recognition
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
: 197355 (view as bug list)
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-06-23 18:24 EDT by Dave Horton
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 04:35:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Horton 2006-06-23 18:24:47 EDT
Description of problem: After performing a yumex update, my system no longer
recognizes png files. When the sytem boots, before the login screen comes up, I
get a bunch of errors like: "There was an error loading the theme FedaraBubbles.
Couldn't recognize the image file format for file
'/usr/share/gdm/themes/FedoraBubbles/background.png'".

I then get a login screen, but it will not let me type in my username -- so I
can't login at the console.

If I log in through VNC, many applications don't work (like yumex itself). When
launching, it dies because it can't recognize png files. Here is the info from
the Exception Occurred window:

"Component: yumex
Version: 1.0.2
Summary: TBe2817d01 yumexmain.py:657:setup_gui:GError: Couldn't recognize the
image file format for file '/usr/share/pixmaps/yumex/yumex-icon.png'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 948, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 469, in __init__
    self.setup_gui()
  File "/usr/share/yumex/yumexmain.py", line 657, in setup_gui
    gtk.window_set_default_icon_from_file( const.PIXMAPS_PATH + '/yumex-icon.png' )
GError: Couldn't recognize the image file format for file
'/usr/share/pixmaps/yumex/yumex-icon.png'

Local variables in innermost frame:
self: <__main__.YumexMainApplication instance at 0xb799950c>"



Version-Release number of selected component (if applicable):
yumex.noarch 1.0.2-1.0.fc5
yum.noarch 2.6.0-1
yum.noarch 2.6.1-0.fc5
yum-fedorafaq.noarch 5-2006.05.09
selinux-policy.noarch 2.2.43-4.fc5


How reproducible: I don't know.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: This has happened to other folks as well. See
http://forums.fedoraforum.org/showthread.php?t=114474&page=1&pp=15.

Additional info-1: The yumex update the caused the problem made the following
updates to my machine (from /var/log/yum.log):
Jun 21 19:58:56 (yumex) Updated: gtk2.i386 2.8.19-2
Jun 21 19:59:08 (yumex) Updated: glib-java.i386 0.2.5-0.FC5
Jun 21 19:59:13 (yumex) Updated: cairo-java.i386 1.0.4-0.FC5
Jun 21 19:59:49 (yumex) Updated: libgtk-java.i386 2.8.5-0.FC5
Jun 21 20:00:57 (yumex) Updated: perl.i386 4:5.8.8-5
Jun 21 20:01:02 (yumex) Updated: nss.i386 3.11.1-1.fc5
Jun 21 20:01:24 (yumex) Updated: evolution-data-server.i386 1.6.2-1.fc5.1
Jun 21 20:01:29 (yumex) Updated: fedora-logos.noarch 1.1.42-1.fc5.1
Jun 21 20:01:57 (yumex) Updated: evolution.i386 2.6.2-1.fc5.5
Jun 21 20:01:59 (yumex) Updated: libsepol.i386 1.12.17-1.fc5
Jun 21 20:02:00 (yumex) Updated: libselinux.i386 1.30.3-3.fc5
Jun 21 20:02:00 (yumex) Updated: coreutils.i386 5.96-1.2
Jun 21 20:02:54 (yumex) Updated: python.i386 2.4.3-4.FC5
Jun 21 20:03:01 (yumex) Updated: mysql.i386 5.0.22-1.FC5.1
Jun 21 20:03:10 (yumex) Updated: shadow-utils.i386 2:4.0.14-9.FC5
Jun 21 20:03:11 (yumex) Updated: perl-DBD-MySQL.i386 3.0004-1.FC5
Jun 21 20:03:11 (yumex) Updated: avahi.i386 0.6.10-1.FC5
Jun 21 20:03:12 (yumex) Updated: libselinux-python.i386 1.30.3-3.fc5
Jun 21 20:03:16 (yumex) Updated: policycoreutils.i386 1.30.10-2.fc5
Jun 21 20:03:35 (yumex) Updated: gnome-panel.i386 2.14.2-1.fc5.1
Jun 21 20:03:41 (yumex) Updated: libgnome-java.i386 2.12.3-0.FC5
Jun 21 20:03:45 (yumex) Updated: libglade-java.i386 2.12.4-0.FC5
Jun 21 20:03:48 (yumex) Updated: libvte-java.i386 0.12.0-0.FC5
Jun 21 20:03:59 (yumex) Updated: subversion.i386 1.3.2-2.1
Jun 21 20:04:10 (yumex) Updated: planner.i386 0.13-4.4
Jun 21 20:04:17 (yumex) Updated: qt.i386 1:3.3.6-0.1.fc5
Jun 21 20:04:24 (yumex) Updated: tcl.i386 8.4.13-1.1
Jun 21 20:04:24 (yumex) Updated: gdm.i386 1:2.14.9-1
Jun 21 20:04:28 (yumex) Updated: yumex.noarch 1.0.2-1.0.fc5
Jun 21 20:05:24 (yumex) Updated: gnome-themes.noarch 2.14.2-1.fc5.1
Jun 21 20:05:28 (yumex) Updated: rhgb.i386 0.16.3-1.fc5.1
Jun 21 20:09:02 (yumex) Installed: kernel-smp-devel.i686 2.6.16-1.2133_FC5
Jun 21 20:09:19 (yumex) Updated: frysk.i386 0.0.1.2006.06.15.rh4-0.FC5
Jun 21 20:09:22 (yumex) Updated: libselinux-devel.i386 1.30.3-3.fc5
Jun 21 20:09:23 (yumex) Updated: evolution-sharp.i386 0.10.2-9.3
Jun 21 20:09:27 (yumex) Updated: evolution-webcal.i386 2.4.1-3.4
Jun 21 20:09:33 (yumex) Updated: system-config-lvm.noarch 1.0.18-1.2.FC5
Jun 21 20:09:33 (yumex) Installed: kernel-smp.i686 2.6.16-1.2133_FC5
Jun 21 20:10:10 (yumex) Updated: python-devel.i386 2.4.3-4.FC5
Jun 21 20:13:39 (yumex) Installed: kernel-devel.i586 2.6.16-1.2133_FC5
Jun 21 20:13:40 (yumex) Updated: rsync.i386 2.6.8-1.FC5.1
Jun 21 20:13:45 (yumex) Updated: desktop-backgrounds-basic.noarch 2.0-31.fc5.1
Jun 21 20:14:18 (yumex) Updated: firefox.i386 1.5.0.4-1.2.fc5
Jun 21 20:14:23 (yumex) Updated: gnome-session.i386 2.14.2-1.fc5.1
Jun 21 20:14:27 (yumex) Updated: autofs.i386 1:4.1.4-27
Jun 21 20:14:28 (yumex) Updated: avahi-glib.i386 0.6.10-1.FC5
Jun 21 20:14:30 (yumex) Updated: smartmontools.i386 1:5.36-fc5.1
Jun 21 20:14:32 (yumex) Updated: dhclient.i386 11:3.0.3-28
Jun 21 20:14:34 (yumex) Updated: xterm.i386 213-1.FC5
Jun 21 20:14:34 (yumex) Updated: mysql-server.i386 5.0.22-1.FC5.1
Jun 21 20:14:51 (yumex) Updated: selinux-policy.noarch 2.2.43-4.fc5
Jun 21 20:14:57 (yumex) Updated: gnome-screensaver.i386 2.14.2-1.fc5.1
Jun 21 20:36:53 (yumex) Updated: coreutils.i386 5.96-1.2
Jun 21 20:36:53 (yumex) Updated: avahi.i386 0.6.10-1.FC5
Jun 21 20:36:54 (yumex) Updated: gdm.i386 1:2.14.9-1
Jun 21 20:36:54 (yumex) Installed: kernel-smp.i686 2.6.16-1.2133_FC5
Jun 21 20:36:54 (yumex) Updated: mysql-server.i386 5.0.22-1.FC5.1
Comment 1 Horst Kausch 2006-06-25 19:54:50 EDT
I just encountered the same problem after upgrading. It seems the issue is with
gtk2.i386 2.8.19-2. Problems disappeared when reverting to gtk2.i386 2.8.18-1.
Comment 2 Tim Lauridsen 2006-07-07 01:29:13 EDT
Does gtk2.i386 2.8.20-1 solve the problem ???
Comment 3 Tim Lauridsen 2006-07-08 02:11:41 EDT
*** Bug 197355 has been marked as a duplicate of this bug. ***
Comment 4 Tim Lauridsen 2006-07-18 04:35:49 EDT
Look like gtk2.i386 2.8.20-1 solves the issue,

Note You need to log in before you can comment on or make changes to this bug.