Bug 196547 - Radeon R300 doesn't recover after suspend in 2.6.17-1.2139_FC5
Summary: Radeon R300 doesn't recover after suspend in 2.6.17-1.2139_FC5
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 197196 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-24 15:01 UTC by Paul W. Frields
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-24 15:16:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'lspci -vv' showing video card details (1.73 KB, text/plain)
2006-06-24 15:01 UTC, Paul W. Frields
no flags Details

Description Paul W. Frields 2006-06-24 15:01:43 UTC
Description of problem:
Using kernel-2.6.17-1.2139_FC5, the ATI Radeon R300 (Mobility M22) in my
ThinkPad T43 (2687-D3U) doesn't recover after a suspend (lid close/reopen). 
This worked fine in FC5 up through 2.6.16-1.2133_FC5.  The following message is
all I have at the end of Xorg.0.log:

(II) RADEON(0): BIOS HotKeys Enabled
(II) RADEON(0): [RESUME] Attempting to re-init Radeon hardware.

The machine is not locked up, although video no longer responds at that point
(just a static screen of snowy garbage).  I can shutdown the machine with the
"soft" power switch, but I can't switch to a text terminal with
Ctrl+Alt+F{1..6}.  Any tips on producing more relevant data are appreciated, and
I'll be happy to try them right away.


Version-Release number of selected component (if applicable):
2.6.17-1.2139_FC5.

How reproducible:
Every time.

Steps to Reproduce:
1.  Log in to GNOME desktop as usual.
2.  Close lid on ThinkPad to suspend.
3.  Reopen.
  
Actual results:
Screen is garbled to the point of illegibility.

Expected results:
Screen returns to desktop as usual.

Additional info:
lspci -vv of video card attached.

Comment 1 Paul W. Frields 2006-06-24 15:01:43 UTC
Created attachment 131481 [details]
'lspci -vv' showing video card details

Comment 2 Paul W. Frields 2006-06-24 15:16:04 UTC
Ugh, I am a moron.  Somehow I forgot to ensure that the dri module was commented
out in my xorg.conf file, as we've been told for some time that DRI isn't
working for r300 yet in the radeon module.  Problem solved, sorry to waste
anyone's time.  

Comment 3 tengel 2006-06-30 18:23:20 UTC
*** Bug 197196 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.