Bug 197196 - kernel-2.6.17-1.2139_FC5 corrupt screen after suspend on T43
kernel-2.6.17-1.2139_FC5 corrupt screen after suspend on T43
Status: CLOSED DUPLICATE of bug 196547
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-29 02:48 EDT by tengel
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 14:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tengel 2006-06-29 02:48:22 EDT
Description of problem:
Waking from suspend on a T43 Thinkpad (2687D3U) results in screen corruption.
The screen is black with horizontal white lines immediately, locked up. Have to
press power button to initiate a low-level complete shutdown to reboot.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2139_FC5 i686

How reproducible:
Always with this kernel.

Steps to Reproduce:
1. install/boot to kernel-2.6.17-1.2139_FC5, runlevel 5
2. (F) menu -> Suspend
3. Press power button to wake laptop
  
Actual results:
Screen is a solid, slightly off-horizontal set of white lines on a black screen,
no visible pattern (image) it may have come from.

Expected results:
Normal resume from suspend screen as with previous kernels

Additional info:
- Previous kernel kernel-2.6.16-1.2133_FC5, and all other kernels from FC5 so
far, have worked just fine. Appears to be something new with this kernel.

- CTL+ALT+BKSP (and others) nonfunctional to try and resolve the problem; must
press the power button to initiate a lowlevel shutdown, which works correctly at
least.

- all updates applied as of 2006-06-28 23:30 PST

Hardwaare modules are all stock from FC5 RPMs, nothing custom. ATI Radeon X300
video in native 1400x1050 mode. Very vanilla install, has been been A-OK prior
to this kernel - currently booted to kernel-2.6.16-1.2133_FC5 and operating as
expected.
Comment 1 Paul W. Frields 2006-06-30 10:32:38 EDT
This is very likely the same situation I had in #196547 (I have the *exact* same
ThinkPad T43, model and trimline).  I don't think DRI works yet with the Radeon
X300.  Try commenting out the following line in the "Module" section of your
/etc/X11/xorg.conf file:

  # Load "dri"

If that fixes your problem, you can close this bug as a DUPLICATE of #196547.
Comment 2 Paul W. Frields 2006-06-30 10:34:33 EDT
Sorry, I had no intention of closing this unilaterally and just mis-moused.  I'm
reopening so the reporter can test the fix.
Comment 3 tengel 2006-06-30 14:22:45 EDT
I'll close this as a duplicate, thanks for the link to the other bug. My caveat
to this (disabling dri) is that the system has been working perfectly for a long
time  - with every other kernel and dri enabled - until this newest kernel was
released. 

I still feel something has broken in the kernel in 2139, whether or not anyone
decides to investigate and fix.


*** This bug has been marked as a duplicate of 196547 ***

Note You need to log in before you can comment on or make changes to this bug.