Bug 196558 - No sound with kernel 2.6.17.1-2139
No sound with kernel 2.6.17.1-2139
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 14:23 EDT by Francisco Miguel Biete
Modified: 2008-05-06 12:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:02:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from system-config-soundcard (no sound played) (7.75 KB, text/plain)
2006-06-24 14:23 EDT, Francisco Miguel Biete
no flags Details
Output of 'lspci -v' with kernel-2.6.16-1.2133_FC5 (5.18 KB, text/plain)
2006-07-02 03:13 EDT, Joni Yrjana
no flags Details
Output of 'lspci -v' with kernel-2.6.17-1.2139_FC5 (5.66 KB, text/plain)
2006-07-02 03:16 EDT, Joni Yrjana
no flags Details

  None (edit)
Description Francisco Miguel Biete 2006-06-24 14:23:17 EDT
Created attachment 131484 [details]
Log from system-config-soundcard (no sound played)
Comment 1 Francisco Miguel Biete 2006-06-24 14:23:17 EDT
Description of problem:

I updated from kernel-2.6.16-1.2133_FC5 to kernel-2.6.17-1.2139_FC5. With the 
2.6.17 the disabled onboard soundcard (VIA 8237) get detected and used (I have 
it disabled from the BIOS since i have another one).
The second soundcard, Creative Sound Blaster Live 5.1, gets detected too.
After startup i have sound from the VIA soundcard but not from the Creative.
I used the system-config-soundcard to tell the system to use the Creative, but 
it doesn't seem to work. I can't hear anything.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2139_FC5

How reproducible:
bootup with the kernel-2.6.17-1.2139_FC5

Steps to Reproduce:
1. boot the system with the kernel-2.6.17-1.2139_FC5
2. try to play something by the Creative card
  
Actual results:
No sound by the Creative soundcard.
A BIOS disabled, onboard card get enabled and used as default.

Expected results:
Creative SoundBlaster Live running fine and onboard audio disabled.

Additional info:
Motherboard: ASUS K8V SE DELUXE
Comment 2 Andy Shellam 2006-06-26 15:10:51 EDT
I have the same problem with virtually identical setup (kernel 2.6.15_2054 going
to 2.6.17_xxxx) - Creative Labs 5.1 Player with VIA 82xx onboard audio.
The VIA is disabled in the BIOS, and booting back into the 2.6.15 kernel, the
VIA doesn't even get picked up by system-config-soundcard.

In 2.6.17 kernel, VIA is detected and used as default - no sound will play from
the Creative, also in the system-config-soundcard, when you select Creative as
default device, no "mixer devices" appear, as they do with the VIA.

No errors in the log - it appears as if it's playing OK, which it does, from the
VIA!!!

Andy
Comment 3 Andy Shellam 2006-06-26 15:14:31 EDT
Also note - this was OK in the 2.6.16 kernel - any way I can force yum to
install that kernel version, as I also need the -dev library for the same kernel
version I'm running, which is 2.6.15, but I can't find out how to force yum to
use a specific version of a package rather than the latest?
Comment 4 Joni Yrjana 2006-07-02 03:13:51 EDT
Created attachment 131845 [details]
Output of 'lspci -v' with kernel-2.6.16-1.2133_FC5
Comment 5 Joni Yrjana 2006-07-02 03:15:25 EDT
Oops, forgot to save first befor attaching the above =)
The same happens to me too: no sound in 2.6.17 but works in 2.6.16.
Motherboard is Asus A7V880, its soundcard is disabled because it has never
produced sound for me.
The output of lspci shows differencies between the two kernel versions.
Comment 6 Joni Yrjana 2006-07-02 03:16:39 EDT
Created attachment 131846 [details]
Output of 'lspci -v' with kernel-2.6.17-1.2139_FC5
Comment 7 Joni Yrjana 2006-07-02 03:29:16 EDT
The problem got solved for me. Now after couple reboots (17->16->17) and running
system-configure-soundcard, alsamixer(gui), gnome volume control the sound
started working in 2.6.17.
Comment 8 paul.knowles 2006-07-03 01:26:11 EDT
There is also some information concerning this in sndconfig bug 197067
Comment 9 Joni Yrjana 2006-07-03 05:09:21 EDT
Well, the problem wasn't solved for me permanently. Today I rebooted and the
sound stopped working (no sound could be heard but applications didn't give any
errors). This time I couldn't figure out how to fix it, I got sound back only by
restoring from backups /etc/asound.{conf,state} and going to the old kernel
version (2.6.16).
Comment 10 Francisco Miguel Biete 2006-07-06 11:17:45 EDT
Updated to Kernel 2.6.17-1.2145

Same behaviour than Kernel 2.6.17-1.2139 (system defaulting to the VIA 
integrated soundcard, what is disabled from BIOS).

I had some free time so i played a bit with the system, and got the problem 
solved (or at least a workaround by now).
Edit /etc/modprobe.conf and change the line
"options snd-via82xx index=0"
by this one
"options snd-via82xx index=1"

The system now sees the other soundcard as the default (snd-emu10k1). 
Run "system-config-soundcard" and check the default soundcard. It must be the 
EMU10K1 (Sound Blaster Live 5.1), and now it has a mixer in the another 
dropdownlist. I rebooted the system, and checked it again. KDE seems to work 
fine, arts server running, amarok, mplayer, xine...

i'm leaving the bug open since the DISABLED (BIOS disabled) VIA soundcard got 
yet detected (but it's not a big problem since i'm listening my music from the 
sound blaster Live).
Comment 11 Ondrej Svejda 2006-07-15 16:59:06 EDT
Just tried kernel-2.6.17-1.2157_FC5.
Onboard VIA soundcard (disabled in BIOS) detected instead of SB Audigy 2 ZS.
Motherboard is ASUS A7V600.
Comment 12 a Fedora user 2006-07-17 17:35:20 EDT
The same problem here with the onboard VIA sound enabled, while being disabled
in the BIOS, as 'dmesg' shows: "PCI: enabled onboard AC97/MC97 devices"

My Audigy 2 is also detected, but is not configurable in the soundcard detection
tool.

Adding the following line "options snd-via82xx index=1" to "/etc/modprobe.conf"
works for me, but is a workaround.
Comment 13 Terry Gruber 2006-08-12 15:25:27 EDT
The same occurred with me when I updated to 2.6.17.XXXX from 2.6.16.xxxx with my
SB Live card and onboard VIA sound on my Asus K8V-MX with the sound disabled in
the bios.  The particular kernal that did it was 2.6.17-1.2157_FC5.  My other
machine is using a SB Audigy platinum and an Asus board with the VIA onboard
sound disabled and had the same result with the SB being disabled.
Comment 14 Igor Miletic 2006-08-20 13:29:07 EDT
Same problem here. Asus K8V motherboard, and Audigy ZX. Kernel 2.6.16 works, any
2.6.17.xxx kernel does not work. Sound detection detects both cards, but only
disabled VIA card can be configured.
Comment 15 Dave Jones 2006-10-16 16:13:07 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 16 Terry Gruber 2006-10-16 21:08:10 EDT
The bug continues with the 2.6.18XXXX version.  Same results as before.  Only
the 2.6.15XXXX version works properly.
Comment 17 Dave Jones 2006-10-16 21:19:28 EDT
This is probably worth reporting upstream at https://bugtrack.alsa-project.org
Comment 18 Bug Zapper 2008-04-03 23:09:23 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 19 Bug Zapper 2008-05-06 12:02:36 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.