This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 196565 - Wacom mouse wheel misbehaves following latest kernel upgrade
Wacom mouse wheel misbehaves following latest kernel upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 17:22 EDT by Pete Chown
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-04 06:06:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pete Chown 2006-06-24 17:22:24 EDT
Description of problem:

Today I upgraded the kernel from kernel-2.6.16-1.2133_FC5 to
kernel-2.6.17-1.2139_FC5.  When I did so, the direction of travel associated
with my mouse wheel reversed itself.  Now, when I move the mouse wheel in a
downward direction, the scrollbars move up!

I am using a Wacom USB graphics tablet.  This uses the "wacom" kernel driver. 
The tablet comes with both a pen and a mouse.  The pen works as normal, and the
mouse works apart from the oddity with the wheel.

Version-Release number of selected component (if applicable):

I am using linuxwacom-0.7.2-1.2 but as the problem was brought on by the kernel
upgrade, I assume it is kernel related.  Reverting to the old kernel cures the
problem.

How reproducible:

Always.

Steps to Reproduce:
1.  Attach a Wacom tablet to your computer and configure it in xorg.conf.
2.  Install kernel-2.6.17-1.2139_FC5.
3.  Start X.
4.  Observe that the mouse wheel moves scrollbars the wrong way.
5.  Revert to kernel-2.6.16-1.2133_FC5.
6.  Observe that the mouse wheel works correctly.
  
Actual results:

Moving the mouse wheel down moves scrollbars up.

Expected results:

Moving the mouse wheel should move scrollbars in the same direction.

Additional info:
Comment 1 Johan Kok 2006-06-27 11:28:45 EDT
My tablet (a Wacom Volito USB) completly stopped working after the latest
upgrade. In dmesg I found only one line mentioning the loading of the
Graphire/Intuos driver, but the Wacom tablet does not respond at all.
Comment 2 Pete Chown 2006-06-27 11:51:28 EDT
I just remembered something I forgot to say in my original report.  I tried
reversing the order of the numbers in the ZAxisMapping.  I expected that to
reverse the direction and get things back to normal, but in fact it made no
difference at all.
Comment 3 Pete Zaitcev 2006-06-27 14:36:33 EDT
Johan, that's very interesting, but it seems not very relevant.
Also, please refrain from using words "latest" and "current" when
referring to release numbers.
Comment 4 Johan Kok 2006-06-27 15:02:17 EDT
(In reply to comment #3)
> Johan, that's very interesting, but it seems not very relevant.
> Also, please refrain from using words "latest" and "current" when
> referring to release numbers.

Sorry about that. I will try to collect more information about that issue and
file it in more relevant place.
Comment 5 Pete Chown 2006-07-12 07:45:50 EDT
FYI, this is still a problem with kernel-2.6.17-1.2145_FC5.  (I'm not sure if
there are actually any changes to the Wacom driver in this release, but I
thought I'd let you know just in case.)
Comment 6 Pete Zaitcev 2006-07-12 11:41:55 EDT
I didn't do anything, sorry. It's on my list.
Comment 7 Pete Chown 2006-08-14 16:01:55 EDT
I've managed to get my own system working now.  What you have to do is download
the latest linuxwacom (0.7.4-3) from http://linuxwacom.sourceforge.net/.  The
tar file contains a directory called prebuilt, and in there is a file called
wacom_drv.so.  wacom_drv.so is a module which is meant to be loaded into the X
server.  Replacing the Fedora-supplied wacom_drv.so with the one from the tar
file fixes the problem.  (Building the driver from source, rather than using the
prebuilt driver, works as well.)

Presumably, after the kernel update, there was a mismatch between the kernel
Wacom driver, and the X server one.
Comment 8 Pete Zaitcev 2006-08-14 17:38:06 EDT
I contacted Dmitry and he thinks it may be a regression.
I can plainly see where Ping got it wrong in the patch.
Currently, we're waiting on Ping to make the determination.

So, I'm not going to throw this bug over to Kristian.
I'll just add him on cc:, so he knows that the issue exists.
Comment 9 Dave Jones 2006-10-16 15:03:22 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 10 Pete Chown 2006-10-17 05:11:34 EDT
Unfortunately the problem seems to have got worse.  The workaround in comment 7
no longer works (and it doesn't work if I return to the Fedora-supplied Wacom
driver, either).  As well as the mouse wheel, there now seem to be problems
setting the tablet options, like absolute versus relative positioning.
Comment 11 Pete Chown 2006-11-04 06:06:29 EST
I just upgraded to FC6 and the Wacom tablet is now working perfectly.

I think it may have worked with the new FC5 kernel after all, actually.  I had
been testing by booting up as normal, switching to a text console and making
changes to xorg.conf, and then running "xinit -- :1".  When setting the tablet
up with FC6, I discovered that this doesn't work.  Only the first X server seems
to be able to make configuration changes to the tablet.

Note You need to log in before you can comment on or make changes to this bug.