This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 196582 - Missing BuildRequires: lcms-devel
Missing BuildRequires: lcms-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-25 05:36 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 00:10:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2006-06-25 05:36:39 EDT
ImageMagick-devel Requires lcms-devel, however lcms-devel isnot BuildRequires by
ImageMagick causing ImageMagick to be build without lcms support.

This is with ImageMagick from rawhide installed:
[hans@shalem ~]$ ldd /usr/lib64/libMagick.so
        libtiff.so.3 => /usr/lib64/libtiff.so.3 (0x00002aaaaae9c000)
        libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x00002aaaab0f5000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00002aaaab217000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00002aaaab45c000)
        libSM.so.6 => /usr/lib64/libSM.so.6 (0x00002aaaab66d000)
        libICE.so.6 => /usr/lib64/libICE.so.6 (0x00002aaaab877000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00002aaaaba93000)
        libXt.so.6 => /usr/lib64/libXt.so.6 (0x00002aaaabd9a000)
        libbz2.so.1 => /usr/lib64/libbz2.so.1 (0x00002aaaabffb000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaaac10c000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaac28d000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00002aaaac3a5000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00002aaaac518000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaac62c000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaac730000)
        libexpat.so.0 => /lib64/libexpat.so.0 (0x00002aaaac97a000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00002aaaaca9d000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00002aaaacca0000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)

And this with a local rebuild of the srpm with lcms-devel installed:
[hans@shalem ~]$ ldd /usr/lib64/libMagick.so
        liblcms.so.1 => /usr/lib64/liblcms.so.1 (0x00002aaaaae9c000)
        libtiff.so.3 => /usr/lib64/libtiff.so.3 (0x00002aaaaafd0000)
        libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x00002aaaab229000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00002aaaab34c000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00002aaaab590000)
        libSM.so.6 => /usr/lib64/libSM.so.6 (0x00002aaaab7a1000)
        libICE.so.6 => /usr/lib64/libICE.so.6 (0x00002aaaab9ac000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00002aaaabbc7000)
        libXt.so.6 => /usr/lib64/libXt.so.6 (0x00002aaaabece000)
        libbz2.so.1 => /usr/lib64/libbz2.so.1 (0x00002aaaac130000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaaac240000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaac3c1000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00002aaaac4da000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00002aaaac64c000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaac760000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaac865000)
        libexpat.so.0 => /lib64/libexpat.so.0 (0x00002aaaacaae000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00002aaaacbd1000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00002aaaacdd5000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)

I noticed this while taking a closer look at bug 196010, because at first I
though this bug may be caused by missing BRs. While looking at this I also
noticed that ImageMagick ./configure checks for libxml2-devel, so you could /
should BR that too I think, although I don't know for what purpose ImageMagick
wants it.

Last while looking at the configure output I noticed that ImageMagick also looks
for jasper for JPEG-2000 support. However jasper currently is in Extra's it
might be a good idea to move jasper to core though, not only for ImageMagick but
also for Ghostscript and Netpbm which according to the jasper homepage:
http://www.ece.uvic.ca/~mdadams/jasper/
Can both also use jasper. If you do this please coordinate this with the current
Extra's maintainer.

Let me know if you want the libxml and jasper issues in seperate bugs.
Comment 1 Rex Dieter 2006-06-25 09:34:34 EDT
FYI, 

lcms (in Core) support:
./configure --with-lcms
BuildRequires: lcms-devel

jasper (in Extras) support:
BuildRequires: jasper-devel
./configure --with-jp2

graphviz (in Extras):
BuildRequires: graphviz
./configure --with-dot

Note You need to log in before you can comment on or make changes to this bug.