Bug 196609 - framebuffer corruption in gnome-panel
framebuffer corruption in gnome-panel
Status: CLOSED DUPLICATE of bug 183341
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-25 19:34 EDT by Rik van Riel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 09:18:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot with red part of line visible (271.42 KB, image/png)
2006-06-25 19:36 EDT, Rik van Riel
no flags Details

  None (edit)
Description Rik van Riel 2006-06-25 19:34:49 EDT
+++ This bug was initially created as a clone of Bug #196608 +++

Description of problem:

The radeon driver suffers from framebuffer corruption, which only appears to
show up in gnome-panel and nowhere else.  With the FC5 radeon driver I got
corruption in Firefox windows too and general system stability, so I assume this
problem could still be serious, despite only ever happening in a one pixel high
line.

Due to gnome-screenshot being broken, you cannot see one detail that might
matter: this line is the pixel right above the scrolling letters and numbers of
my gtik2 (stock ticker) applet.  Maybe this applet is causing things to go haywire?

The one-pixel high line is intermittant, in what appears to be red and turquoise
intervals.  It is not a continuous line, but intermittant.

Causing a redraw, eg by mousing over the firefox "globe" icon, or clicking into
one of the menus, makes the line go away - but it'll return later.

The problem also happens without Xinerama, on 1280x1024 pixel resolution.  I
have not seen it on 1024x768 while setting up the system as root, but then again
I did not have gtik2 running as root either :)

01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300
(PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]
Comment 1 Rik van Riel 2006-06-25 19:36:44 EDT
Created attachment 131510 [details]
screenshot with red part of line visible
Comment 2 Rik van Riel 2006-06-25 19:57:09 EDT
On retrospect, the colors seem to correspond to the same red and green that
gtik2 uses in its display.  If the market had been more upbeat, I bet the
screenshot would have contained a mostly green line :)
Comment 3 Rik van Riel 2006-06-26 09:18:38 EDT

*** This bug has been marked as a duplicate of 183341 ***

Note You need to log in before you can comment on or make changes to this bug.