Bug 196661 - scim-bridge-gtk should be multilib
scim-bridge-gtk should be multilib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: i18n, Reopened
Depends On:
Blocks: FC6Blocker SCIM FC6Test3Blocker
  Show dependency treegraph
 
Reported: 2006-06-26 06:58 EDT by Jens Petersen
Modified: 2013-01-09 22:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 23:00:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log (36.56 KB, text/plain)
2006-08-16 06:51 EDT, Jens Petersen
no flags Details
anaconda.log (177.34 KB, text/plain)
2006-08-16 06:54 EDT, Jens Petersen
no flags Details
anaconda.syslog (50.71 KB, text/plain)
2006-08-16 06:56 EDT, Jens Petersen
no flags Details
anaconda.xlog (50.57 KB, text/plain)
2006-08-16 06:59 EDT, Jens Petersen
no flags Details
anaconda.log rawhide x86_64 (20060914) (188.87 KB, text/plain)
2006-09-13 23:31 EDT, Caius Chance
no flags Details
anaconda.syslog for x86_64 rawhide-20060914 (24.53 KB, text/plain)
2006-09-13 23:32 EDT, Caius Chance
no flags Details
anaconda.xlog rawhide x86_64 (20060914) (58.70 KB, text/plain)
2006-09-13 23:35 EDT, Caius Chance
no flags Details
install.log rawhide x86_64 (20060914) (38.68 KB, text/plain)
2006-09-13 23:40 EDT, Caius Chance
no flags Details

  None (edit)
Description Jens Petersen 2006-06-26 06:58:38 EDT
Description of problem:
scim-bridge-gtkimm and scim-libs should be multilib on x86_64.

How reproducible:
every time

Steps to Reproduce:
1. install fc6test1 with Asian language support on x86_64
2. rpm -q scim-libs scim-bridge-gtkimm
 
Actual results:
2. Only x86_64 packages installed.

Expected results:
2. Both i386 and x86_64 packages to be installed.

Additional info:
scim-libs.i386 and scim-bridge-gtkimm.i386 are not in x86_64 trees.
Comment 1 Jesse Keating 2006-06-26 09:23:12 EDT
Multi-lib is determined by packages that have a -devel component.  There is no
longer a "whitelist" of packages to pull in.  If a package ahs a -devel
subpackage, it is considered multi-lib and thus brought in.  So perhaps making a
-devel subpackage for scim and scim-bridge will solve this for you?
Comment 2 Jens Petersen 2006-06-26 21:37:24 EDT
Ok, I see (and oops scim-libs is multilib in fc6t1:).

However the problem is that scim-bridge is not a library but
just a gtk im module (it provides im-scim-bridge.so): so should there
be an empty dummy scim-bridge-devel package for this?  IMHO
it would be better to have a more general mechanism for multilib
than just existence of -devel, but if an empty -devel package is
the only way then that can be added I suppose.
Comment 3 Jesse Keating 2006-06-26 21:44:02 EDT
If scim-bridge is just a library, what would use it in i386 manner on an x86_64
system?  If its something we ship, then it should depend on that.  Package dep
chains are brought in for multilib, so something is getting installed i386 on an
x86_64 system but not requiring the bits necessary to do i386 scim?
Comment 4 Jens Petersen 2006-06-26 23:03:17 EDT
(scim-bridge is /not/ a library, but a dynamically loaded .so gtk2 module.)

Any 32bit gtk2 app running on x86_64 for which the user wants to use scim
input needs scim-bridge-gtkimm.i386 installed.  For FC5 I would have answered
openoffice.org on i386, but this is not longer valid - do we ship any i386
only apps in fc6 for x86_64?  Anyway there are plenty of 32bit only gtk2 apps out
there and only having scim-bridge-gtkimm.x86_64 installed will break their usage
badly for scim users.

I tried asking about this on fedora-maintainers a couple of months back  -
ideally I would just like scim-bridge.x86_64 to require scim-bridge-gtkimm.i386,
but Warren discouraged from doing that.  Is there a better way?

Apart from adding scim-bridge-devel, is there any other way to handle this?
Comment 5 Jesse Keating 2006-06-27 07:17:56 EDT
hrm, this is a tough one.  I'll talk to some more people today and try to get a
good answer.  I wonder if the entire depchain of scim-bridge.i386 is already in
the multilib list?  A quick test on my x86-64 shows that scim-bridge.i386 and
scim-bridge-gtkmm.i386 would only pull in scim.x86-64, scim-libs.i386 and
scim-libs.x86-64. 
Comment 6 Jens Petersen 2006-06-27 11:35:23 EDT
Thanks.  BTW it is just scim-bridge-gtkimm that needs to be multilib
(not scim-bridge).
Comment 7 Jens Petersen 2006-07-02 21:54:10 EDT
ping :)
Comment 8 Jesse Keating 2006-07-02 22:11:55 EDT
We're working on an extra list of packages to multi-lib, such as pam and cyrus
modules.  This is not ready yet.  Needs to be by Test2.
Comment 9 Jens Petersen 2006-07-03 07:05:13 EDT
Okay thanks for the update, should this be reassigned to
another component then?
Comment 10 Jesse Keating 2006-07-03 08:33:10 EDT
I'll assign it to distribution for now.
Comment 11 Warren Togami 2006-07-24 13:36:31 EDT
Note, scim-qtimm needs the same multilib treatment.
Comment 12 Jesse Keating 2006-07-24 14:29:39 EDT
These are now included as multilib.  Should show up in tonights rawhide.
Comment 13 Jens Petersen 2006-08-09 00:13:21 EDT
scim-bridge-gtkimm and scim-libs did not get installed multilib
for me on a default Japanese install of fc6 test2.
Comment 14 Jesse Keating 2006-08-09 08:24:18 EDT
scim-libs-1.4.4-29.fc6.i386.rpm
scim-qtimm-0.9.4-5.i386.rpm
scim-bridge-gtkimm-0.2.6-1.fc6.i386.rpm

are all in the x86_64 dirs for Test2.  If they didn't get installed, this is an
anaconda / yum issue.
Comment 15 Jeremy Katz 2006-08-09 18:09:38 EDT
Can you provide /var/log/anaconda* and /root/install.log? 
Comment 16 Jens Petersen 2006-08-16 06:51:25 EDT
Created attachment 134294 [details]
install.log
Comment 17 Jens Petersen 2006-08-16 06:54:49 EDT
Created attachment 134295 [details]
anaconda.log
Comment 18 Jens Petersen 2006-08-16 06:56:38 EDT
Created attachment 134296 [details]
anaconda.syslog
Comment 19 Jens Petersen 2006-08-16 06:59:39 EDT
Created attachment 134297 [details]
anaconda.xlog
Comment 20 Jesse Keating 2006-09-10 11:16:59 EDT
Whats the status on this?
Comment 23 Caius Chance 2006-09-13 23:27:45 EDT
Info got from rawhide (20060914):

`rpm -qa | grep scim`

scim-libs-1.4.4-34.fc6
scim-tables-0.5.6-7
scim-hangul-0.2.2-7.fc6
scim-tables-chinese-0.5.6-7
scim-1.4.4-34.fc6
scim-pinyin-0.5.91-11.4.fc6
scim-bridge-0.4.2-1.fc6
scim-chewing-0.3.1-5
scim-devel-1.4.4-34.fc6
scim-anthy-1.2.0-1.fc6
Comment 24 Caius Chance 2006-09-13 23:31:14 EDT
Created attachment 136226 [details]
anaconda.log rawhide x86_64 (20060914)
Comment 25 Caius Chance 2006-09-13 23:32:43 EDT
Created attachment 136227 [details]
anaconda.syslog for x86_64 rawhide-20060914

FYI, the rpm packages I listed are in rawhide x86_64 (20060914)
Comment 26 Caius Chance 2006-09-13 23:35:45 EDT
Created attachment 136228 [details]
anaconda.xlog rawhide x86_64 (20060914)
Comment 27 Caius Chance 2006-09-13 23:40:54 EDT
Created attachment 136229 [details]
install.log rawhide x86_64 (20060914)
Comment 28 Jens Petersen 2006-09-15 03:43:51 EDT
(In reply to comment #23)
> `rpm -qa | grep scim`

So scim-bridge-gtk was not installed?

The logs attached above seem to be without scim at all.  English install?
Comment 32 Jens Petersen 2006-09-20 23:00:19 EDT
Confirmed fixed in fc6 test3.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.