Bug 196703 - Segfaults on x86_64
Segfaults on x86_64
Status: CLOSED DUPLICATE of bug 174016
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dos2unix (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 11:34 EDT by Dag Wieers
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 11:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Wieers 2006-06-26 11:34:58 EDT
Description of problem:
I have a problem where dos2unix segfaults when performing dos2unix conversions.
I can demonstrate it by doing:

    lftpget 'http://mamboxchange.com/frs/download.php/7877/MamboV4.5.4.tar.gz'
    tar -xzf MamboV4.5.4.tar.gz
    find . -type f -name '*.html' -o -name '*.php' -o -name '*.xml' | xargs -n1
dos2unix

On a RHEL4 x86_64 it segfaults. (although once I have seen a signal 6 problem)
However it does not occur when stracing dos2unix.

There are also errors in dmesg/syslog:

    dos2unix[2369] general protection rip:3f7f067eab rsp:7fbffff610 error:0
    dos2unix[2534] general protection rip:3f7f067eab rsp:7fbffff640 error:0
    dos2unix[2686] general protection rip:3f7f0683c4 rsp:7fbffff700 error:0


Version-Release number of selected component (if applicable):
dos2unix-3.1-21.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. See above
2.
3.
  
Actual results:
Segfaults

Expected results:


Additional info:
Comment 1 Tim Waugh 2006-06-26 11:58:01 EDT

*** This bug has been marked as a duplicate of 174016 ***

Note You need to log in before you can comment on or make changes to this bug.