Bug 196860 - CUPS loses track of remotely printed jobs
Summary: CUPS loses track of remotely printed jobs
Status: CLOSED DUPLICATE of bug 193204
Alias: None
Product: Fedora
Classification: Fedora
Component: cups   
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-27 12:34 UTC by Matthew Saltzman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 13:39:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Saltzman 2006-06-27 12:34:30 UTC
Description of problem:
After sending a job to a remote printer, cups fails to determine that it has
completed.

Version-Release number of selected component (if applicable):
cups-1.2.1-1.7

How reproducible:
Always

Steps to Reproduce:
1. Print a job from GNOME with eggcups running.
2. tail -f /var/log/cups/access_log or tail -f /var/log/error_log
3.
  
Actual results:
In access_log, the following cycle of messages repeats every 5 seconds:

localhost - - [27/Jun/2006:08:35:07 -0400] "POST / HTTP/1.1" 200 75
CUPS-Get-Printers successful-ok
localhost - - [27/Jun/2006:08:35:08 -0400] "POST /printers/laser HTTP/1.1" 200
138 Get-Job-Attributes client-error-not-found
localhost - - [27/Jun/2006:08:35:13 -0400] "POST /printers/laser HTTP/1.1" 200
138 Get-Job-Attributes client-error-not-found

In error_log, the following message repeats every 5 seconds:

E [27/Jun/2006:08:39:33 -0400] Get-Job-Attributes client-error-not-found: Job
#62 does not exist!

The eggcups applet never turns grey and the document status window always shows
status unknown.


Expected results:
No errors, eggcups applet greys out, job status window indicates that job has
completed.

Additional info:

Filed under cups because the problem started occurring when I updated to latest
cups errata release.

This is a very annoying problem on a laptop as status messages keep the disk
spinning.

Comment 1 Tim Waugh 2006-06-27 13:39:53 UTC

*** This bug has been marked as a duplicate of 193204 ***


Note You need to log in before you can comment on or make changes to this bug.