Bug 193204 - eggcups applet broken after updating system
eggcups applet broken after updating system
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 190725 196860 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 21:27 EDT by Dave Maley
Modified: 2008-02-27 06:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 06:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Maley 2006-05-25 21:27:55 EDT
Description of problem:  After yum updating my FC5 systems last night (5/24/06)
the eggcups applet is no longer working properly.  When I print now the eggcups
applet will appear, but when the job completes it doesn't detect it and thus
never closes.

Worse is this bug causes the cups error_log and access_log to be flooded w/
errors.  The following is being logged repeatedly to /var/log/cups/error_log
every 5 seconds:

E [25/May/2006:18:52:42 -0400] Get-Job-Attributes client-error-not-found: Job
#10 does not exist!

And the following to the cups access_log every 5 seconds:

localhost - - [25/May/2006:18:51:47 -0400] "POST /printers/three_east HTTP/1.1"
200 139 Get-Job-Attributes client-error-not-found


Version-Release number of selected component (if applicable):
desktop-printing-0.19-6

possibly relevant:
cups-1.2.1-1.2
cups-libs-1.2.1-1.2
libgnomecups-0.2.2-3.2.1
hal-cups-utils-0.5.5-1.2.fc5.2


How reproducible: every time


Steps to Reproduce:
1. print file (from gnome)
2. 
3.
  
Actual results:  eggcups applet never goes away and /var/log/cups/error_log and
/var/log/cups/access_log get flooded


Expected results:  eggcups applet disappears when print job completes


Additional info:  appears to be the same as (or at least related to) bug 190725
Comment 2 John (J5) Palmieri 2006-05-30 15:40:11 EDT
the whole print system is getting overhauled.  This bug is most likely due to
the change to cups 1.2.  We will have a look at the issue when we get around to
fixing up user feedback area of printing.
Comment 3 oll 2006-05-31 03:38:08 EDT
Personally, I have this bug since the beggining (at least since FC3).
I mean #132289 has never been solved.
I'm really not a specialist but maybe using job-uuid included in the new 1.2
cups instead of job-id could do the trick ?
Comment 4 Dave Maley 2006-05-31 14:03:49 EDT
> This bug is most likely due to the change to cups 1.2.

Exactly what I'd initially thought too.  However rolling back to the cups 1.1
packages didn't fix it, so it seems there's something more involved.
Comment 5 Tim Waugh 2006-06-16 08:27:40 EDT
*** Bug 190725 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2006-06-27 09:39:56 EDT
*** Bug 196860 has been marked as a duplicate of this bug. ***
Comment 7 Matthew Saltzman 2006-06-27 09:44:22 EDT
(In reply to comment #2)
> the whole print system is getting overhauled.  This bug is most likely due to
> the change to cups 1.2.  We will have a look at the issue when we get around to
> fixing up user feedback area of printing.

Does this mean we are stuck with this behavior until FC6?  It fills logs and
keeps laptop disks spinning.  Very user-unfriendly.
Comment 8 Matthias Clasen 2006-09-21 22:42:05 EDT
What I am seeing on fc6 is eggcups filling ~/.xsession-errors with a neverending
stream of

Warning **: IPP request failed with status 1030

We should probably fix that.
Comment 11 Andrew Clayton 2006-11-06 05:14:17 EST
Seeing this also on several machines (x86_64) here with FC6.

Printing to a remote printer (cups / FC5), I got two printer icons in the panel
and a load of errors continuing to come in ~/.xsession-errors.

 ** (eggcups:16552): WARNING **: IPP request failed with status 1030

Note You need to log in before you can comment on or make changes to this bug.