Bug 196901 - qt4: make FHS-friendly
qt4: make FHS-friendly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qt4 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature
: 244837 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 11:49 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-07 13:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-06-27 11:49:09 EDT
In short, move most(all?) of everything out of %{_libdir}/qt4, and use
FHS-friendly dirs like:
libs: %{_libdir}
headers: %{_includedir}

Must be careful about qt(4) addons, like qt4-qsa that (like to) install into
QTDIR/%{_lib}.  We could either 
1.  recommend/force rebuilds against the new configuration (ie, to move out of
QTDIR/%_lib and into the new location, %_libdir).
2.  Keep/own QTDIR/%_lib too.
Comment 1 Rex Dieter 2006-06-27 12:53:12 EDT
Another nice side-effect of using %_libdir would be that we can drop the
ld.so.conf.d funny-business (provided we don't do 2. above).
Comment 2 Rex Dieter 2006-06-29 16:43:25 EDT
Others I've worked on
datadir: %_libdir/qt4 -> %_datadir/qt4
docdir: %_docdir/qt4-doc-%version -> %_docdir/qt4
translationdir: %_libdir/qt4/translations -> %_datadir/qt4/translations
Comment 3 Ville Skyttä 2006-06-29 17:48:23 EDT
> headers: %{_includedir}

Are the headers exactly the same on all arches?  There's movement in making
devel packages multiarch friendly and parallel installable.

> docdir: %_docdir/qt4-doc-%version -> %_docdir/qt4

If this includes stuff I guess it does (haven't checked), it sounds inconsistent
with all other packages out there that use %{_docdir}/%{name}-%{version} despite
of the drawbacks of it being versioned.  Being consistent with the rest of the
world would be good for POLA.  If found faulty, mass-fix everything later.
Comment 4 Rex Dieter 2006-06-29 19:21:22 EDT
>> docdir: %_docdir/qt4-doc-%version -> %_docdir/qt4

>If this includes stuff I guess it does (haven't checked), it sounds inconsistent

qtassistant is qt4's help-browser, and it peruses stuff from there.  Other
apps/pkgs can put stuff in the qt4 docdir as well.  It seemed silly to force a
rebuild of those other apps/pkgs on every qt4 version update, so I chose to make
the dir static.  This is what other distros (well, at least SuSE) do as well.
Comment 5 Ville Skyttä 2006-06-30 05:51:49 EDT
Fair enough, the docdir apparently doesn't contain what I guessed then ;)

Depending on how essential those files are and whether qtassistant works without
them, one additional consideration could be whether to install them as %doc at
all (stuff in %_docdir gets automatically marked as such), think --excludedocs
installs.
Comment 6 Rex Dieter 2006-06-30 07:49:53 EDT
qtassistant will work without any docs, it just won't (be able to) show
anything.  I think the case where someone uses --excludedocs and installs a pkg
called -doc will probably be pretty rare. (:
Comment 7 Ville Skyttä 2006-06-30 08:19:22 EDT
Okay, agreed, I didn't (even) know that qtassistant is also in -doc.
Comment 8 Rex Dieter 2006-07-07 13:39:11 EDT
OK, the deed is done.
Comment 9 Rex Dieter 2007-06-19 09:43:18 EDT
*** Bug 244837 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.