Bug 244837 - qt4-devel installed include-files to /usr/include
qt4-devel installed include-files to /usr/include
Status: CLOSED DUPLICATE of bug 196901
Product: Fedora
Classification: Fedora
Component: qt4 (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 09:28 EDT by Michael Möllney
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 09:43:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Möllney 2007-06-19 09:28:21 EDT
Description of problem:
qt4-devel installs the include files to /usr/include instead of /usr/lib/qt4

Version-Release number of selected component (if applicable):
qt4-devel-4.3.0-2.fc7

How reproducible:
yum install qt4-devel

  
Actual results:
include files installed in /usr/include

Expected results:
include files installed in /usr/lib/qt4 (or even better /usr/lib/qt-4.3 to be
analogous to qt 3.3)

Additional info:
qmake should take care where to find the includes.... so there should be no need
to put it into /usr/include?
Comment 1 Rex Dieter 2007-06-19 09:43:16 EDT
This is by design, mostly for FHS compliance (see also bug #196901)

*** This bug has been marked as a duplicate of 196901 ***

Note You need to log in before you can comment on or make changes to this bug.