Bug 196903 - drivers/md/xor.ko needs unknown symbol xor_ia64_2
drivers/md/xor.ko needs unknown symbol xor_ia64_2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Prarit Bhargava
Brian Brock
: Regression
: 198488 (view as bug list)
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-06-27 12:08 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 10:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix exports for raid5 in ia64 (1.91 KB, patch)
2006-07-27 15:18 EDT, Prarit Bhargava
no flags Details | Diff
New patch to fix this issue. (1.92 KB, patch)
2006-07-27 15:31 EDT, Prarit Bhargava
no flags Details | Diff
New patch proposed by Aron ... much better solution (1.18 KB, patch)
2006-07-31 09:06 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Doug Chapman 2006-06-27 12:08:17 EDT
Description of problem:
This sytem was installed with the rawhide-20060626 build then I attempted to
upgrade the kernel to 2.6.17-1.2307_FC6 rpm.


[root@hplp1 ~]# rpm -ivh kernel-2.6.17-1.2318_FC6.ia64.rpm
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [100%]
WARNING: /lib/modules/2.6.17-1.2318_FC6/kernel/drivers/md/xor.ko needs unknown
symbol xor_ia64_3
WARNING: /lib/modules/2.6.17-1.2318_FC6/kernel/drivers/md/xor.ko needs unknown
symbol xor_ia64_5
WARNING: /lib/modules/2.6.17-1.2318_FC6/kernel/drivers/md/xor.ko needs unknown
symbol xor_ia64_4
WARNING: /lib/modules/2.6.17-1.2318_FC6/kernel/drivers/md/xor.ko needs unknown
symbol xor_ia64_2

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2318_FC6.ia64.rpm

How reproducible:
100%


Steps to Reproduce:
1. install the kernel rpm kernel-2.6.17-1.2318_FC6.ia64.rpm
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Jones 2006-07-12 00:00:01 EDT
*** Bug 198488 has been marked as a duplicate of this bug. ***
Comment 2 Fabio Bettoni 2006-07-13 06:18:07 EDT
Output bootstrapping updated kernel

modprobe: WARNING: Error inserting xor (/lib/modules/2.6.17-
1.2366.fc6/kernel/drivers/md/xor.ko): Unknown symbol in module, or unknown 
parameter (see dmesg)

modprobe: FATAL: Error inserting raid456 (/lib/modules/2.6.17-
1.2366.fc6/kernel/drivers/md/raid456.ko): Unknown symbol in module, or unknown 
parameter (see dmesg)

mdadm: failed to RUN_ARRAY /dev/md0: Invalid argument




from dmesg:
xor: Unknown symbol xor_ia64_3
xor: Unknown symbol xor_ia64_5
xor: Unknown symbol xor_ia64_4
xor: Unknown symbol xor_ia64_2
raid456: Unknown symbol xor_block
md: personality for level 5 is not loaded!
Comment 3 Prarit Bhargava 2006-07-27 15:18:59 EDT
Created attachment 133188 [details]
Fix exports for raid5 in ia64
Comment 4 Prarit Bhargava 2006-07-27 15:31:14 EDT
Created attachment 133192 [details]
New patch to fix this issue.

Added a && IA64 dependency ... don't want this building everywhere ...
Comment 5 Prarit Bhargava 2006-07-31 09:06:37 EDT
Created attachment 133316 [details]
New patch proposed by Aron ... much better solution
Comment 7 Prarit Bhargava 2006-08-08 10:08:24 EDT
Accepted upstream ... closing.

Note You need to log in before you can comment on or make changes to this bug.