Bug 196940 - kernel-2.6.17-1.2139_FC5 breaks sleep mode on IBM T30 laptop
kernel-2.6.17-1.2139_FC5 breaks sleep mode on IBM T30 laptop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 14:45 EDT by David A. De Graaf
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-20 21:51:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David A. De Graaf 2006-06-27 14:45:44 EDT
Description of problem:
kernel-2.6.17-1.2139_FC5 won't sleep


Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2139_FC5


How reproducible:
Always


Steps to Reproduce:
1. Press Fn-F4 to enter sleep mode from X (xfce4); observe black screen
2. Press Fn to awake
3.
  
Actual results:
Prior X display lights up, but is frozen.  So is keyboard.  Can only power off
to regain control.


Expected results:
Normal wakeup with usable keyboard and X display.


Additional info:
IBM T30 laptop with video card:
01:00.0 VGA compatible controller: ATI Technologies Inc
  Radeon Mobility M7 LW [Radeon Mobility 7500]

Fresh install of FC5, with all current updates.
Earlier FC5 kernels worked fine, provided these files are added:
/etc/acpi/events/lid.conf:
  event=button/lid*
  action=/usr/bin/acpitool -s

/etc/acpi/events/sleep.conf:
  event=button/sleep*
  action=/usr/bin/acpitool -s



I tried suggestion from Matthew Saltzman <mjs@ces.clemson.edu>, but it didn't help:

OK try the following:
(1) Edit /etc/modprobe.conf and add the following:
        options radeonfb radeon_force_sleep=1
(2) Create /etc/sysconfig/mkinitrd containing the following line:
        MODULES="radeonfb"
(3) Rebuild your initrd:
        mkinitrd -f /boot/initrd-2.6.17-1.2139_FC5.img 2.6.17-1.2139_FC5
(4) Reboot.
(5) Test suspend.

I also tried this suggestion from Roberto Ragusa <mail@robertoragusa.it>, also
without effect:

Try adding
  acpi_sleep=s3_bios
to the kernel options in your grub.conf.
Comment 1 Dave Jones 2006-10-16 15:27:09 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 2 David A. De Graaf 2006-10-17 14:30:08 EDT
I am happy to report that the new kernel - 2.6.18-1.2200.fc5 - fixes
the sleep problem on my IBM T30 laptop.

First, the pm-suspend command works well, but it always has.

Second, the acpitool -s command also sleeps and reawakens successfully.
This is newly fixed.  It stopped working with kernel 2.6.17-1.2139_FC5.
It's also significantly faster than pm-suspend - 1 sec vs 7 sec.

Third, I learned some new things about initrd - that it is built
silently and automatically when a new kernel is installed and that
it uses info in /etc/modprobe.conf.  Previously, it was necessary to
load the radeonfb module with option  radeon_force_sleep=1  to make
this laptop's screen shut down completely.  The new kernel doesn't
need that option, and won't accept it.  Therefore the radeonfb module
failed to load during boot.  When I peered inside the initrd file 
( with zcat ... | strings | less )  I found the line
    insmod /lib/radeonfb.ko radeon_force_sleep=1  
which caused radeonfb to fail to load.

After deleting the option line from /etc/modprobe.conf, removing the
new kernel with rpm -e, and reinstalling with yum update, the
offending option is gone from initrd.  The radeonfb module loads
during boot and acpitool -s works perfectly.

Good work, everyone.

Note You need to log in before you can comment on or make changes to this bug.