Bug 196979 - no harddisk found (Intel PIIX/ICH ATA controllers) within vmware
no harddisk found (Intel PIIX/ICH ATA controllers) within vmware
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 209871 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 18:14 EDT by Thorsten Scherf
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.22.9-61.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 17:44:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2006-06-27 18:14:05 EDT
Description of problem:
anaconda doesn't detect my Intel PIIX/ICH ATA controllers. Installation stopped,
due to a (reported) missing harddisk. this installation was tried in a vmware
5.5 machine.

Version-Release number of selected component (if applicable):
fc6-test1-iso

How reproducible:
start installation

Steps to Reproduce:
1.boot from dvd 
2.start the installation
3.
  
Actual results:
no harddisk found

Expected results:
ongoing installation

Additional info:
Comment 1 Thorsten Scherf 2006-06-28 03:33:07 EDT
looks like BZ #196397. Here is my lspci output from a fc5 system which had no
problems to detect my sata device during install:

[root@tiffy ~]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem
Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit
Ethernet PCI Express (rev 01)
03:01.0 CardBus bridge: Texas Instruments PCI6515 Cardbus Controller
03:01.5 Communication controller: Texas Instruments PCI6515 SmartCard Controller
03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)
Comment 2 Martin 2007-03-03 17:51:52 EST
same behaviour here with FC7test2 an VMware-server-1.0.2-39867
no disk was found during the installation. (with fc7test1 ok).

My main System FC6 is on a RAID bus controller: 3ware Inc 9550SX SATA-RAID

# lspci
00:00.0 Host bridge: Intel Corporation 82975X Memory Controller Hub (rev c0)
00:01.0 PCI bridge: Intel Corporation 82975X PCI Express Root Port (rev c0)
00:03.0 PCI bridge: Intel Corporation 82975X/3010 PCI Express Root Port (rev c0)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express
Port 5 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface
Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA
Storage Controller IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 Multimedia audio controller: Xilinx Corporation RME Digi96/8 Pad (rev 04)
01:01.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
01:05.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit
Ethernet Controller (rev 14)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8052 PCI-E ASF
Gigabit Ethernet Controller (rev 21)
03:00.0 PCI bridge: Intel Corporation 6702PXH PCI Express-to-PCI Bridge A (rev 09)
04:02.0 RAID bus controller: 3ware Inc 9550SX SATA-RAID
05:00.0 VGA compatible controller: nVidia Corporation GeForce 7900 GS (rev a1)
Comment 3 Martin 2007-03-06 05:39:31 EST
workaround in my case is, to create a customized vmware
with the buslogic SCSI-Driver Setting, not LSI.
Comment 4 Jakub Suchy 2007-03-20 13:30:50 EDT
I can confirm this with RHEL 5 Server and VMware Server 1.0.2. No disk found.
Using workaround with buslogic driver doesn't help.
My working workaround is to create IDE disk...
Comment 5 determan 2007-05-22 00:23:28 EDT
I am having the same problem (no disks found for installation) with the 
following system:

motherboard: ECS Elitegroup P965T V1.0B (P965 Northbridge, ICH8 Southbridge)
cpu: Intel Core2Duo E6400
hard disks: Maxtor SATA II 300 GB (2)
memory: 2 GB
bios: AwardBIOS v6.00PG

The BIOS sees the two identical drives as IDE Channel 0 Master and IDE Channel 
1 Master. I have tried setting the SATA2 controller to both IDE Mode and RAID 
Mode in the BIOS without making the disks visible to the Fedora Core installer.

I have tried several different Fedora builds:

Fedora Core 6 (FC-6-x86_64-DVD):
The installer loads the ahci and ata_piix drivers.
Anaconda does not see any hard drives to use for the installation.

Fedora Core 5 (FC-5-x86_64-DVD):
The installer loads the ata_piix driver.
The installer says "No driver found" and asks me to either select a driver 
or use a driver disk.Since I do not know what driver to install, I have not
proceeded beyond this point.

Fedora 7 Test 1 (F-6.90-x86_64-DVD):
The installer loads the pata_jmicron and ata_piix drivers.
Anaconda does not see any hard drives to use for the installation.

Fedora 7 Test 3 (F-6.92-x86_64-DVD):
The installer loads the pata_jmicron and ata_piix drivers.
Anaconda generates an exception at the point where it should present the drive 
installation options. I do not know how to save the exception details, but 
here is the traceback:

	File "/usr/lib/anaconda/iw/autopart_type.py", line 286, in getScreen
	defaultBoot = self.anaconda.id.bootloader.drivelist[0]
	File "/usr/lib/anaconda/gui.py", line 1128, in setScreen
	new_screen = self.currentWindow.getScreen(anaconda)
	File "/usr/lib/anaconda/gui.py", line 1039, in nextClicked
	self.setScreen()
	IndexError: list index out of range

Fedora 7 Test 4 (F-6.93-x86_64-DVD):
The installer loads the pata_jmicron and ata_piix drivers.
Anaconda does not see any hard drives to use for the installation.

I do not have a practical workaround for the problem, because the motherboard 
only has one IDE controller, and an IDE cable is not long enough to reach from 
the hard drive bay to the DVD drive bay in my Antec case.
Comment 6 Chuck Ebbert 2007-09-13 17:44:39 EDT
*** Bug 209871 has been marked as a duplicate of this bug. ***
Comment 7 Chuck Ebbert 2007-09-14 15:09:43 EDT
Fix in kernel-2.6.22.6-55.fc6, submitted for testing.

(We really shouldn't have to fix vmware's bugs -- this workaround may be removed
in some future release.)
Comment 8 Martin 2007-09-18 08:46:39 EDT
Chuck, where can i download the new kernel, on testing 
http://mirrors.kernel.org/fedora/core/updates/testing/6/i386/ the kernel isn't 
already available.
Comment 9 Chuck Ebbert 2007-09-18 11:03:47 EDT
Test kernels are at:

http://people.redhat.com/cebbert/kernels/FC6/

Note You need to log in before you can comment on or make changes to this bug.