Bug 209871 - Initial boot fails, no disk found - with VMware and virtual scsi disk
Initial boot fails, no disk found - with VMware and virtual scsi disk
Status: CLOSED DUPLICATE of bug 196979
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-07 03:24 EDT by Greg Buzzard
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 17:44:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Buzzard 2006-10-07 03:24:04 EDT
Description of problem:
Booting DVD install disk without any special arguments in a VMware virtual
machine with a virtual scsi disk fails due to lack of ability for anaconda to
"see" the (virtual) SCSI disk.  If at the initial boot prompt, I enter "linux
noprobe" and then select the "buslogic SCSI" controller, anaconda proceeds
successfully.


Version-Release number of selected component (if applicable):
FC6 T3 (pre-DVD)

How reproducible: Easily reproduced with steps below.  Requires VMWare Server
Console v1.01  


Steps to Reproduce:
1.  Create a VMware virtual machine with a virtual SCSI disk.
2.  Install FC6 within such a virtual machine.
3.
  
Actual results:
The dialog to select disk/partitioning options fails -- no disks found.

Expected results:
Successful dialog to select disk and partitioning options.

Additional info:
At a minimum, it should be easy to select a boot-time option for using a SCSI
disk for initial system installation.  It appears that manually loading the
buslogic SCSI driver is all that was necessary to get a good result.
Comment 1 steven tardy 2007-01-16 14:49:59 EST
to install fc6 to a vmware server use the fc5 rescue cd .iso and install via an
online mirror(http) and add the buslogic scsi device driver.
Comment 2 Jakub Suchy 2007-03-20 11:49:30 EDT
I can confirm this with Red Hat Enterprise Linux 5 Server and VMware Server 1.0.2.
Also seems to be duplicate of #196979
Comment 3 Chuck Ebbert 2007-09-13 17:44:38 EDT

*** This bug has been marked as a duplicate of 196979 ***

Note You need to log in before you can comment on or make changes to this bug.