Bug 197032 - kernel 2.6.17-1.2139_FC5smp /dev/nvram device reads only first 8192 bytes on IBM 7025-F50 machine
kernel 2.6.17-1.2139_FC5smp /dev/nvram device reads only first 8192 bytes on ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ppc64-utils (Show other bugs)
9
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 03:23 EDT by Alexey Bozrikov
Modified: 2009-06-10 02:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 02:26:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Bozrikov 2006-06-28 03:23:46 EDT
Description of problem:
When trying to use 'nvram' command or 'bootlist' command with various arguments 
(from ppc64-utils-0.9-12.2.1 package), following error is reported:
[quote bootlist -r -m normal]
/usr/sbin/nvram: WARNING: expected 28672 bytes, but only read 8192!
[unquote]
When kernel is booting, nvram size reported is not the same as actual size 
of /dev/nvram:
[quote dmesg]
CHRP nvram contains 28672 bytes
[unquote]
[quote wc -c /dev/nvram]
8192 /dev/nvram
[unquote]
Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2139_FC5smp

How reproducible:
always

Steps to Reproduce:
1. nvram --print-vpd
2. bootlist -r -m normal
3.
  
Actual results:
WARNING: expected 28672 bytes, but only read 8192!

Expected results:
1. output VPD information
2. output current machine boot list
Additional info:
1) 'nvsetenv' command from same package works fine (possibly environment is 
contained in first 8192 bytes of NVRAM)
2) Fedora Core 5 with all latest updates installed on IBM RS6000 7025-F50, 3GB 
RAM, 4xPowerPC604 332MHz CPUs. 'Stock' FC5 kernel has same problem, so do other 
distributions I have tried (SuSE, Debian), so looks like typical kernel issue.
Comment 1 Dave Jones 2006-10-16 14:09:31 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 2 Alexey Bozrikov 2006-10-17 02:26:59 EDT
New kernel version does not fix the issue with /dev/nvram:
[quote]
[root@f50 ~]# nvram --nvram-size=8192 -v --print-config=boot-device
nvram: WARNING: expected 28672 bytes, but only read 8192!
Segmentation fault
[root@f50 ~]# uname -a
Linux f50.mydomain.com 2.6.18-1.2200.fc5smp #1 SMP Sat Oct 14 17:52:41 EDT 2006 
ppc ppc ppc GNU/Linux
[unquote]

Now I am suspecting that package ppc64-utils, 
containing 'nvram', 'bootlist', 'nvsetenv' and some other commands for NVRAM 
manipulation work only on 64-bit PowerPC platform machines with different NVRAM 
size, and not on PowerPC 604e found on IBM 7025-F50, B50 and similar machines.

Alexey
bozy@pisem.net
Comment 3 Dave Jones 2006-11-07 01:06:01 EST
it's strange that it's expecting 28672 bytes when you're explicitly telling it
that it's only 8k.  Maybe this is a ppc64-utils bug. Leaving it sat as a kernel
bug doesn't seem to be getting it any attention regardless, so reassigning &
hoping for the best ;)
Comment 4 Paul Nasrat 2006-11-07 04:29:29 EST
Can you test with ppc64-utils-0.11-1.fc7 from tomorrows rawhide which contains
powerpc-utils (and -papr) 1.0.3.
Comment 5 Alexey Bozrikov 2006-11-08 10:44:52 EST
Done that, installed rawhide ppc64-utils. Looks like same result:
[root@f50 ~]# rpm -q ppc64-utils
ppc64-utils-0.11-1.fc7
[root@f50 ~]# nvram --print-vpd
nvram: WARNING: expected 28672 bytes, but only read 8192!
Segmentation fault
[root@f50 ~]# nvram --nvram-size=8192 --print-vpd
nvram: WARNING: expected 28672 bytes, but only read 8192!
Segmentation fault
[root@f50 ~]# nvram --nvram-size=8192 --dump
nvram: option `--dump' requires an argument
[root@f50 ~]# nvram --nvram-size=8192 --dump 1
nvram: WARNING: expected 28672 bytes, but only read 8192!
Segmentation fault
[root@f50 ~]# bootlist -r -m normal
/usr/sbin/nvram: WARNING: expected 28672 bytes, but only read 8192!
[root@f50 ~]# hexdump -C /dev/nvram | head -10l
00000000  02 a2 00 80 69 62 6d 2c  65 72 72 2d 6c 6f 67 00  |....ibm,err-log.|
00000010  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
.....skipped....

Contents of /dev/nvram did not change in newest kernel, so it should be 
utilities rather than kernel issue, you are right.

Alex
Comment 6 Red Hat Bugzilla 2007-08-21 01:24:24 EDT
User pnasrat@redhat.com's account has been closed
Comment 7 Bug Zapper 2008-04-03 23:10:41 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 8 Alexey Bozrikov 2008-04-04 03:32:24 EDT
I have checked this matter on Fedora 7 with latest kernel/ppc utilities updated 
as of 02/03/2008 and the matter is still the same - can read only 8192 bytes. 
FC8 and Rawhide kernels do not boot properly on 7025-F50 (due to, possibly, 
problem with LSI Logic SCSI driver - cannot recognize all SCSI devices on boot, 
rootfs not found) , therefore I cannot test them.
Comment 9 Bug Zapper 2008-05-13 22:11:10 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-06-09 18:11:27 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Alexey Bozrikov 2009-06-10 02:26:06 EDT
I presume this cannot be fixed, as NVRAM size/layout on 32-bit machines like 7025-F50 is different from 64-bit machines. The part of package providing default boot list at installation time works fine.

Note You need to log in before you can comment on or make changes to this bug.