Bug 197135 - Thunderbird mail command results in improper To field.
Thunderbird mail command results in improper To field.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
: 199638 (view as bug list)
Depends On:
Blocks: 171491 FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-28 14:57 EDT by Ryan Powers
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 00:22:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch corrects improper Thunderbird URL handling string (589 bytes, patch)
2006-09-11 23:26 EDT, Ryan Powers
no flags Details | Diff

  None (edit)
Description Ryan Powers 2006-06-28 14:57:38 EDT
Description of problem:
The default launch string for Thunderbird (thunderbird mailto:%s) in "Preferred
Applications" will cause mail links from Firefox to be put in the To field as
mailto:<address>. When sent in this state, and m ends up prefixed before the
actual address resulting in incorrectly directed mail.


Version-Release number of selected component (if applicable):
control-center-2.14.2-1

How reproducible:
Always (from clickable links with mailto: prefixes).

Steps to Reproduce:
1. Click a mail link that includes mailto:
2. mailto: appears in Thunderbird's To: field
3. Attempt to send mail
  
Actual results:
An "m" is prefixed to the address and is incorrect. (This may be my mailserver's
interpretation 

Expected results:
"mailto:" does not appear in Thunderbird's To: field.

Additional info:
I've found a work around by using the launch string "thunderbird -compose %s"
rather than "thunderbird mailto:%s". Adding the prefix of mailto: seems to cause
problems on URLs that already contain mailto: and result in the improper
address. Using -compose will properly handle both cases where there is a mailto:
and there is no mailto: prefix.

This could potentially be filed against Thunderbird, and if you feel it should,
just let me know.
Comment 1 Andre Robatino 2006-06-28 20:45:59 EDT
  I noticed this after installing FC5 but didn't know which component to report
it under.  The correct component is definitely NOT thunderbird, since it's in no
way responsible for how it's invoked.  In Preferred Applications, I had to
change the Mail Reader to Custom, since using Thunderbird didn't allow me to
edit the Command, then I entered the command "thunderbird %s", since the
corresponding default commands for Evolution and Mutt are "evolution %s" and
"mutt %s", resp.  Thunderbird is unique in having "mailto:" in its default
command.  Does this mean that the other default commands should also be changed?
Comment 2 Martin 2006-07-21 10:22:32 EDT
*** Bug 199638 has been marked as a duplicate of this bug. ***
Comment 3 A. Lok 2006-09-03 16:33:41 EDT
Could the version be updated to fc6tst2? Since it doesn't work in fedora core 6
test 2 with control-center-2.15.92-5.fc6.
Comment 4 Gerry Tool 2006-09-07 15:51:39 EDT
I confirm that this problem exists in both FC5 and FC6T2.
The System > Preferences > More Preferences > Preferred Applications > Mail
Reader setting for the Thunderbird Mail choice sets the command to "thunderbird
mailto:%s" where it should be "thunderbird %s", the same as the other choices
for evolution and kmail.  To get a mailto: link in a web page to set the address
in thunderbird correctly, one has to use the Custom setting and remove the
mailto: part of the command. 
Comment 5 Ryan Powers 2006-09-11 12:04:34 EDT
(In reply to comment #3)
> Could the version be updated to fc6tst2? Since it doesn't work in fedora core 6
> test 2 with control-center-2.15.92-5.fc6.

I've updated the version to fc6test2 at your request.
Comment 6 Ryan Powers 2006-09-11 23:26:58 EDT
Created attachment 136050 [details]
Patch corrects improper Thunderbird URL handling string
Comment 7 Ryan Powers 2006-09-11 23:29:52 EDT
Comment on attachment 136050 [details]
Patch corrects improper Thunderbird URL handling string

I did some poking around in the source for this package. The vanilla config
contains the correct string, but is changed to the incorrect string by the
Fedora patch control-center-2.13.90-fedora-apps.patch
. This patch reverts the Thunderbird string to the correct one.
Comment 8 Ryan Powers 2006-09-11 23:35:52 EDT
I forgot to add, if someone with an FC6T2 environment could test this patch to
make sure it applies properly to a fully prepared source tree, I'd appreciate
it. I'm still using FC5, so I wasn't able to perform an rpmbuild -bp.
Comment 9 Warren Togami 2006-09-12 12:01:10 EDT
There will be existing user profiles with gconf using the wrong command, thus
thunderbird's URL handler launching script should be corrected to recognize both
the old and new syntax.
Comment 10 Matthias Clasen 2006-09-13 00:22:55 EDT
The thunderbird command is fixed in 2.16.0-3.
If you want to make thunderbird understand mailto:wtogami,
please open a thunderbird bug.

Note You need to log in before you can comment on or make changes to this bug.