Bug 197145 - Kernel 2.6.17-1.2139_FC5 freezes System completely
Kernel 2.6.17-1.2139_FC5 freezes System completely
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On: 198121
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 16:15 EDT by Daniel Hammer
Modified: 2008-08-02 19:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 16:42:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci (1.60 KB, text/plain)
2006-07-16 13:16 EDT, Stephen Adler
no flags Details

  None (edit)
Description Daniel Hammer 2006-06-28 16:15:57 EDT
Description of problem: I have a Thinkpad T42p with no extra Hardware and FC5
installed (close to vanilla, e.g., without any additional software). 
When booting kernel 2.6.17-1.2139_FC5 the system freezes completely with no
traces in /var/log/messages. I have to pull the plug and restart with an other
kernel to get it working again


Version-Release number of selected component (if applicable): 2.6.17-1.2139_FC5


How reproducible: 

Steps to Reproduce:
1. boot with kernel 2.6.17-1.2139_FC5
2. see how init 5 is entered
3. see nothing more, no key does ever work
  
Additional info:

With kernel 2.6.17-1.2139_FC4 on FC4 there are similar problems:
 - cups doesn't start anymore
 - no network card recognition (SK-9821 V2.0 Gigabit Ethernet 10/100/1000Base-T
Adapter)
 - plenty of error messages

Seems to me as if kernel 2.6.17-1.2139_FC4/5 is horribly broken
Comment 1 Daniel Hammer 2006-06-29 02:03:25 EDT
Errors concerning kernel 2.6.17-1.2139_FC4 on FC4 refer to another hardware
(fujitsu siemens), never tried it on that ThinkPad.
Comment 2 Dax Kelson 2006-06-29 14:15:29 EDT
I have a ThinkPad T42p and within 5 minutes of boot (about enough time for me to
login, open email and browser) it freezes solid.

This has happened 5 times in a row.

kernel-2.6.16-1.2133_FC5 <-- good no trouble (same with all previous FC5 kernels)
kernel-2.6.17-1.2139_FC5 <-- not good

I'm going to try to get some crash/lockup data by using netdump.
Comment 3 Holger Urbanek 2006-07-04 04:46:27 EDT
Same here. I also own an IBM t42p.

With four boot-trials using 2.6.17-1.2139_FC5 it onece locked up when starting
xorg, and twice with starting the gnome-panels and once after about 5 minutes of
running.

2.6.15-1.2054_FC5 however runs completely fine.

smartctl reports no problems.
memcheck86 -- well, right at the moment I have no time to perform that check --
however, I don't think there is any problem there.

Well, also no clue in /var/log/messages

Also many similar Notebookproblems are found here:
http://forums.fedoraforum.org/showthread.php?p=563316
Comment 4 Bertho 2006-07-05 09:33:13 EDT
Almost the same on my T42p, only it freezes as soon as X has blanked the screen
(probably initialized part of the chipset/PCI). But, there are leftovers after
the lockup. Rebooting in the previous 2.6.16-1.2133_FC5 results is nonfunctional
network. A second reboot into 2.6.16-1.2133_FC5 is required to get the network
functional again.

--
Greetings Bertho
Comment 5 Daniel Hammer 2006-07-06 01:26:29 EDT
Unfortunately, nothing has changed with new kernel 2.6.17-1.2145_FC5 on the IMB
ThinkPad T42p.
Comment 6 Daniel Hammer 2006-07-06 01:44:00 EDT
The same, unfortunately, applies to the Fujitsu-Siemens hardware and kernel
2.6.17-1.2141_FC4 on Fedora Core 4:

- no network card recognition (sk98lin with SK-9821 V2.0 Gigabit Ethernet
10/100/1000Base-T Adapter)
- "cupsd: child excited with status 99!"
- dhcpd startup failed ... etc.

the latter two probably due to card recognition failure for sk98lin.
No interesting messages in /var/log/messages.
Comment 7 Dax Kelson 2006-07-06 19:00:30 EDT
I discovered that my Thinkpad T42p does not lock up with the new kernel if I
don't start X. If I boot directly to runlevel 3 then I can hammer the system
with no freezes.

The last kernel that works for me is: kernel-2.6.16-1.2133_FC5

Other interesting data points:

1) The stock kernel.org kernel v2.6.17 exhibits the problem too, so this isn't
caused by a fedora kernel patch.

2) I did a git bisect marking v2.6.16 good and v2.6.17 bad. Every single kernel
I compiled and tested (12 of them, uggh) all exhibited the bug! Very odd.

I'm compiling 2.6.18-rc1 to see if there is any change.
Comment 8 Charles R. Anderson 2006-07-08 12:42:25 EDT
Same here on a Dell PowerEdge 400SC with an ATI Radeon 9500 Pro, radeon driver.
 FC5 with 2.6.17-1.2139_FC5 hangs solid 5-10 minutes after logging in to GNOME.
 2.6.16-1.2133_FC5 doesn't have this issue.
Comment 9 Daniel Hammer 2006-07-09 13:40:04 EDT
As for the Fujitzu Siemens architecture I cannot confirm the posting of Dax
Kelson . I am actually writing 

# uname -r
2.6.17.4.h0m6r3

on a system running the 2.6.17.4 (Helsinki) vanilla kernel downloaded from
kernel.org an just compiled some minutes ago. Compilation went absolutely smooth
and all the silly things of the fedora 2.6.17 update kernels (even on this
architecture) do not show up.
I'll try later the same kernel on the ThinkPad.
Comment 10 Daniel Hammer 2006-07-09 15:09:53 EDT
Okay, have compiled the 2.6.17.4 (Helsinki) vanilla kernel on the ThinkPad T42p.
Booting FC5 runs smoothly, no error messages, no oops. But, when loging in as
some user, the machine freezes when gnome panel tries to show up.

No graphics, no problem: on runlevel 3 nothing bad happens. Demesg is okay, no
heavy memory or cpu usage, etc..

So in runlevel 5 even 2.6.17.4 (Helsinki) vanilla kernel does not work. When
system freezes, I have to plug it off, then plug in again and reboot.
Comment 11 Bertho 2006-07-09 15:32:45 EDT
Does the vanilla kernel 2.6.17.4 on thinkpad t42p hang when it is booted with
ACPI turned off (acpi=off)?
I am thinking that acpi could be a problem with the messages of missing sleep
functionality after introduction of 2.6.17 and t42p uses acpi_sleep=s3_bios to
make sleeping work. Disabling acpi totally might give us a hint.
Comment 12 Dax Kelson 2006-07-09 19:00:30 EDT
The vanilla kernel.org kernel has the same problem. I verfied the problem exists
from vanilla v2.6.16 through v2.6.18-rc1.

I'm 99% sure this problem we T42p owners (and likely others with the same video
card) stems from a patch fix that was *dropped* when the Fedora kernel rebased
to v2.6.17.

Specifically the patch "linux-2.6-drm-cripple-r300.patch". I created bug 198121
to re-add that patch.

One work around I discovered is to use the the ATI fglrx video driver. No
lockups. The following two commands will do that for you if you wish:

rpm -Uvh http://rpm.livna.org/livna-release-5.rpm
yum install kmod-fglrx
Comment 13 Daniel Hammer 2006-07-10 06:13:02 EDT
Hi Dax, what you write sound logical. I've noticed that the problem appears also
on a TravelMate 292LMI which has a "ATI Mobility Radeon 9700" video card (same
type you've mentioned above). The above mentioned Fujitsu-Siemens hardware has
an "nVidia NV34 GeForce FX 5200" adapter, and there it works fine.
Although not "clean" (IMHO), the workaround with livna does a good job. Thanx a lot.
Comment 14 Stephen Adler 2006-07-16 13:15:20 EDT
I would like to add that I also have this same problem. My hardware
configuration is attached. (The output from lspci) Bascially I have an intel
motherboard with a ATI Radeon R300 filegl x1 video card.

All kernel releases since 2.6.16-1.2133_FC5smp have frozen my computer. I have
not done the no XOrg test, (i.e. init level 3) In anycase, I just wanted to
throw in my two cents about this bug since it's a big pain in my butt... :( (At
least the 2.6.16-1.2133_FC5smp does work.)
Comment 15 Stephen Adler 2006-07-16 13:16:50 EDT
Created attachment 132525 [details]
output of lspci
Comment 16 Stephen Adler 2006-07-16 14:14:29 EDT
I tried the updates listed in comment #12 and broke my XOrg setup. Apply them
with caution. I would suggest reading through rpm.lavin.org before proceeding
with the suggested workaround. (I undid the patch and I'm back to running
2.6.16-2133_FC5

:(
Comment 17 Dave Jones 2006-10-16 17:38:04 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.